summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2011-08-15 15:03:04 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2011-08-15 15:03:04 +0000
commit25a6e231e30c84a01e177cd545b2e86d366f9050 (patch)
tree5dac1ca98e8503256ebb699cbac281e55cc53db8 /kde-base/kwin
parentBump to 0.9_rc3, from gnome overlay for great justice (and GNOME 3) (diff)
downloadgentoo-2-25a6e231e30c84a01e177cd545b2e86d366f9050.tar.gz
gentoo-2-25a6e231e30c84a01e177cd545b2e86d366f9050.tar.bz2
gentoo-2-25a6e231e30c84a01e177cd545b2e86d366f9050.zip
Fix xcomposite automagic, bug 376785
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/kwin')
-rw-r--r--kde-base/kwin/ChangeLog8
-rw-r--r--kde-base/kwin/files/kwin-4.7.0-xcomposite_cmake_automagic.patch16
-rw-r--r--kde-base/kwin/kwin-4.7.0-r1.ebuild67
3 files changed, 90 insertions, 1 deletions
diff --git a/kde-base/kwin/ChangeLog b/kde-base/kwin/ChangeLog
index 811e9d54e9d6..bfdaa4be8dc5 100644
--- a/kde-base/kwin/ChangeLog
+++ b/kde-base/kwin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kwin
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kwin/ChangeLog,v 1.236 2011/08/12 19:19:32 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kwin/ChangeLog,v 1.237 2011/08/15 15:03:04 dilfridge Exp $
+
+*kwin-4.7.0-r1 (15 Aug 2011)
+
+ 15 Aug 2011; Andreas K. Huettel <dilfridge@gentoo.org> +kwin-4.7.0-r1.ebuild,
+ +files/kwin-4.7.0-xcomposite_cmake_automagic.patch:
+ Fix xcomposite automagic, bug 376785
12 Aug 2011; Andreas K. Huettel <dilfridge@gentoo.org> -kwin-4.6.4.ebuild:
Drop KDE 4.6.4
diff --git a/kde-base/kwin/files/kwin-4.7.0-xcomposite_cmake_automagic.patch b/kde-base/kwin/files/kwin-4.7.0-xcomposite_cmake_automagic.patch
new file mode 100644
index 000000000000..726abe9a5962
--- /dev/null
+++ b/kde-base/kwin/files/kwin-4.7.0-xcomposite_cmake_automagic.patch
@@ -0,0 +1,16 @@
+diff -ruN kwin-4.7.0.orig/ConfigureChecks.cmake kwin-4.7.0/ConfigureChecks.cmake
+--- kwin-4.7.0.orig/ConfigureChecks.cmake 2011-05-20 22:32:06.000000000 +0200
++++ kwin-4.7.0/ConfigureChecks.cmake 2011-08-15 16:56:52.165002024 +0200
+@@ -67,6 +67,12 @@
+ macro_bool_to_01(X11_XShm_FOUND HAVE_XSHM) # kwin, ksplash
+ macro_bool_to_01(X11_XTest_FOUND HAVE_XTEST) # khotkeys, kxkb, kdm
+ macro_bool_to_01(X11_Xcomposite_FOUND HAVE_XCOMPOSITE) # kicker, kwin
++
++if(NOT WITH_X11_Xcomposite)
++ set(X11_Xcomposite_FOUND FALSE)
++ MESSAGE(STATUS "Disabling Xcomposite as requested on commandline.")
++endif(NOT WITH_X11_Xcomposite)
++
+ macro_bool_to_01(X11_Xcursor_FOUND HAVE_XCURSOR) # many uses
+ macro_bool_to_01(X11_Xdamage_FOUND HAVE_XDAMAGE) # kwin
+ macro_bool_to_01(X11_Xfixes_FOUND HAVE_XFIXES) # klipper, kicker, kwin
diff --git a/kde-base/kwin/kwin-4.7.0-r1.ebuild b/kde-base/kwin/kwin-4.7.0-r1.ebuild
new file mode 100644
index 000000000000..1faf5af55ab6
--- /dev/null
+++ b/kde-base/kwin/kwin-4.7.0-r1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kwin/kwin-4.7.0-r1.ebuild,v 1.1 2011/08/15 15:03:04 dilfridge Exp $
+
+EAPI=4
+
+KMNAME="kde-workspace"
+OPENGL_REQUIRED="optional"
+inherit kde4-meta
+
+DESCRIPTION="KDE window manager"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug gles +xcomposite xinerama"
+
+COMMONDEPEND="
+ $(add_kdebase_dep kephal)
+ $(add_kdebase_dep libkworkspace)
+ $(add_kdebase_dep liboxygenstyle)
+ x11-libs/libXdamage
+ x11-libs/libXfixes
+ >=x11-libs/libXrandr-1.2.1
+ x11-libs/libXrender
+ opengl? ( >=media-libs/mesa-7.10 )
+ gles? ( >=media-libs/mesa-7.10[egl(+),gles] )
+ xcomposite? ( x11-libs/libXcomposite )
+ xinerama? ( x11-libs/libXinerama )
+"
+DEPEND="${COMMONDEPEND}
+ x11-proto/damageproto
+ x11-proto/fixesproto
+ x11-proto/randrproto
+ x11-proto/renderproto
+ xcomposite? ( x11-proto/compositeproto )
+ xinerama? ( x11-proto/xineramaproto )
+"
+RDEPEND="${COMMONDEPEND}
+ x11-apps/scripts
+"
+
+KMEXTRACTONLY="
+ ksmserver/
+ libs/kephal/
+ libs/oxygen/
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-4.4.2-xinerama_cmake_automagic.patch"
+ "${FILESDIR}/${PN}-4.7.0-xcomposite_cmake_automagic.patch"
+)
+
+# you can use just gles or opengl or none
+REQUIRED_USE="opengl? ( !gles ) gles? ( !opengl )"
+
+src_configure() {
+ # FIXME Remove when activity API moved away from libkworkspace
+ append-cppflags "-I${EPREFIX}/usr/include/kworkspace"
+
+ mycmakeargs=(
+ $(cmake-utils_use_with gles OpenGLES)
+ $(cmake-utils_use gles KWIN_BUILD_WITH_OPENGLES)
+ $(cmake-utils_use_with opengl OpenGL)
+ $(cmake-utils_use_with xinerama X11_Xinerama)
+ $(cmake-utils_use_with xcomposite X11_Xcomposite)
+ )
+
+ kde4-meta_src_configure
+}