summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2014-03-04 19:30:47 +0000
committerJohannes Huber <johu@gentoo.org>2014-03-04 19:30:47 +0000
commitac2fc7b2db98c04967a88a433f7cfeb60c389323 (patch)
tree263867635d36ff95fd0e1dc9d62de089b7591798 /kde-base/kwin
parentAdd ~mips keyword. (diff)
downloadgentoo-2-ac2fc7b2db98c04967a88a433f7cfeb60c389323.tar.gz
gentoo-2-ac2fc7b2db98c04967a88a433f7cfeb60c389323.tar.bz2
gentoo-2-ac2fc7b2db98c04967a88a433f7cfeb60c389323.zip
Version bump KDE Workspace 4.11.7
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key F3CFD2BD)
Diffstat (limited to 'kde-base/kwin')
-rw-r--r--kde-base/kwin/ChangeLog7
-rw-r--r--kde-base/kwin/kwin-4.11.7.ebuild80
2 files changed, 86 insertions, 1 deletions
diff --git a/kde-base/kwin/ChangeLog b/kde-base/kwin/ChangeLog
index 269946fa4b0d..fac9fd067334 100644
--- a/kde-base/kwin/ChangeLog
+++ b/kde-base/kwin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kwin
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kwin/ChangeLog,v 1.375 2014/02/23 10:01:50 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kwin/ChangeLog,v 1.376 2014/03/04 19:30:41 johu Exp $
+
+*kwin-4.11.7 (04 Mar 2014)
+
+ 04 Mar 2014; Johannes Huber <johu@gentoo.org> +kwin-4.11.7.ebuild:
+ Version bump KDE Workspace 4.11.7
23 Feb 2014; Agostino Sarubbo <ago@gentoo.org> -kwin-4.11.2.ebuild:
Remove old
diff --git a/kde-base/kwin/kwin-4.11.7.ebuild b/kde-base/kwin/kwin-4.11.7.ebuild
new file mode 100644
index 000000000000..58a5a28da0de
--- /dev/null
+++ b/kde-base/kwin/kwin-4.11.7.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kwin/kwin-4.11.7.ebuild,v 1.1 2014/03/04 19:30:41 johu Exp $
+
+EAPI=5
+
+KMNAME="kde-workspace"
+DECLARATIVE_REQUIRED="always"
+OPENGL_REQUIRED="always"
+
+#VIRTUALX_REQUIRED=test
+RESTRICT=test
+# test 8: kwin-TestVirtualDesktops hangs even with virtualx
+
+inherit flag-o-matic kde4-meta
+
+DESCRIPTION="KDE window manager"
+HOMEPAGE+=" http://userbase.kde.org/KWin"
+KEYWORDS=" ~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug gles opengl wayland"
+
+COMMONDEPEND="
+ $(add_kdebase_dep kactivities)
+ $(add_kdebase_dep kdelibs opengl)
+ $(add_kdebase_dep kephal)
+ $(add_kdebase_dep libkworkspace)
+ $(add_kdebase_dep liboxygenstyle)
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/xcb-util-image
+ x11-libs/xcb-util-keysyms
+ x11-libs/libXcomposite
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ >=x11-libs/libXrandr-1.2.1
+ x11-libs/libXrender
+ x11-libs/libXxf86vm
+ opengl? ( >=media-libs/mesa-7.10 )
+ gles? ( >=media-libs/mesa-7.12[egl(+),gles2] )
+ wayland? ( >=media-libs/mesa-9.0[egl(+),wayland] )
+"
+DEPEND="${COMMONDEPEND}
+ x11-libs/xcb-util-renderutil
+ x11-proto/compositeproto
+ x11-proto/damageproto
+ x11-proto/fixesproto
+ x11-proto/randrproto
+ x11-proto/renderproto
+"
+RDEPEND="${COMMONDEPEND}
+ x11-apps/scripts
+"
+
+KMEXTRACTONLY="
+ ksmserver/
+ libs/kephal/
+ libs/oxygen/
+"
+
+# you need one of these
+REQUIRED_USE="!opengl? ( gles ) !gles? ( opengl ) wayland? ( gles )"
+
+src_configure() {
+ # FIXME Remove when activity API moved away from libkworkspace
+ append-cppflags "-I${EPREFIX}/usr/include/kworkspace"
+
+ mycmakeargs=(
+ $(cmake-utils_use_with gles OpenGLES)
+ $(cmake-utils_use gles KWIN_BUILD_WITH_OPENGLES)
+ $(cmake-utils_use_with opengl OpenGL)
+ $(cmake-utils_use_with wayland Wayland)
+ -DWITH_X11_Xcomposite=ON
+ )
+
+ kde4-meta_src_configure
+}