summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2009-03-08 14:08:49 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2009-03-08 14:08:49 +0000
commitaf9e4620e709b9a55f78d59663dffdec37610ef4 (patch)
tree417a104e09440282901418b3dd83e6d556b72f53 /kde-base/kwin
parentSemi-automatic merge, Update deps. (diff)
downloadgentoo-2-af9e4620e709b9a55f78d59663dffdec37610ef4.tar.gz
gentoo-2-af9e4620e709b9a55f78d59663dffdec37610ef4.tar.bz2
gentoo-2-af9e4620e709b9a55f78d59663dffdec37610ef4.zip
Semi-automatic merge, Update deps.
(Portage version: 2.2_rc23/cvs/Linux i686)
Diffstat (limited to 'kde-base/kwin')
-rw-r--r--kde-base/kwin/ChangeLog5
-rw-r--r--kde-base/kwin/kwin-4.2.1.ebuild19
2 files changed, 17 insertions, 7 deletions
diff --git a/kde-base/kwin/ChangeLog b/kde-base/kwin/ChangeLog
index 68b4bc84b3f1..93871162fcfc 100644
--- a/kde-base/kwin/ChangeLog
+++ b/kde-base/kwin/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for kde-base/kwin
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kwin/ChangeLog,v 1.141 2009/03/04 22:34:09 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kwin/ChangeLog,v 1.142 2009/03/08 14:08:49 scarabeus Exp $
+
+ 08 Mar 2009; Tomas Chvatal <scarabeus@gentoo.org> kwin-4.2.1.ebuild:
+ Semi-automatic merge, Update deps.
*kwin-4.2.1 (04 Mar 2009)
diff --git a/kde-base/kwin/kwin-4.2.1.ebuild b/kde-base/kwin/kwin-4.2.1.ebuild
index 751470283a27..525c1d42793b 100644
--- a/kde-base/kwin/kwin-4.2.1.ebuild
+++ b/kde-base/kwin/kwin-4.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kwin/kwin-4.2.1.ebuild,v 1.1 2009/03/04 22:34:09 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kwin/kwin-4.2.1.ebuild,v 1.2 2009/03/08 14:08:49 scarabeus Exp $
EAPI="2"
@@ -12,29 +12,36 @@ DESCRIPTION="KDE window manager"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
IUSE="debug captury xcomposite xinerama"
-COMMONDEPEND="x11-libs/libXdamage
+COMMONDEPEND="
+ >=kde-base/kephal-${PV}:${SLOT}[kdeprefix=]
+ x11-libs/libXdamage
x11-libs/libXfixes
>=x11-libs/libXrandr-1.2.1
x11-libs/libXrender
captury? ( media-libs/libcaptury )
opengl? ( virtual/opengl )
xcomposite? ( x11-libs/libXcomposite )
- xinerama? ( x11-libs/libXinerama )"
+ xinerama? ( x11-libs/libXinerama )
+"
DEPEND="${COMMONDEPEND}
- kde-base/kephal:${SLOT}
x11-proto/damageproto
x11-proto/renderproto
xcomposite? ( x11-proto/compositeproto )
- xinerama? ( x11-proto/xineramaproto )"
+ xinerama? ( x11-proto/xineramaproto )
+"
RDEPEND="${COMMONDEPEND}"
-src_configure() {
+src_prepare() {
if ! use captury; then
sed -e 's:^PKGCONFIG..libcaptury:#DONOTFIND &:' \
-i "${S}"/kwin/effects/CMakeLists.txt || \
die "Making captury optional failed."
fi
+ kde4-meta_src_prepare
+}
+
+src_configure() {
mycmakeargs="${mycmakeargs}
$(cmake-utils_use_with opengl OpenGL)"