summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2007-10-19 23:51:42 +0000
committerWulf Krueger <philantrop@gentoo.org>2007-10-19 23:51:42 +0000
commit41dba1e4b65c6d9bf2b7fd9cd6bd3799648db22e (patch)
treea401d26e1bcddcee42e546511b12f6f24b0deebe /kde-base/libkpimexchange/libkpimexchange-3.5.8.ebuild
parentBump to KDE 3.5.8. (diff)
downloadgentoo-2-41dba1e4b65c6d9bf2b7fd9cd6bd3799648db22e.tar.gz
gentoo-2-41dba1e4b65c6d9bf2b7fd9cd6bd3799648db22e.tar.bz2
gentoo-2-41dba1e4b65c6d9bf2b7fd9cd6bd3799648db22e.zip
Bump to KDE 3.5.8.
(Portage version: 2.1.3.15)
Diffstat (limited to 'kde-base/libkpimexchange/libkpimexchange-3.5.8.ebuild')
-rw-r--r--kde-base/libkpimexchange/libkpimexchange-3.5.8.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/kde-base/libkpimexchange/libkpimexchange-3.5.8.ebuild b/kde-base/libkpimexchange/libkpimexchange-3.5.8.ebuild
new file mode 100644
index 000000000000..a7a35331d57f
--- /dev/null
+++ b/kde-base/libkpimexchange/libkpimexchange-3.5.8.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/libkpimexchange/libkpimexchange-3.5.8.ebuild,v 1.1 2007/10/19 23:51:41 philantrop Exp $
+
+KMNAME=kdepim
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta eutils
+
+DESCRIPTION="KDE PIM exchange library"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="$(deprange $PV $MAXKDEVER kde-base/libkcal)"
+
+RDEPEND="${DEPEND}"
+
+KMCOPYLIB="libkcal libkcal"
+# libkcal is installed because a lot of headers are needed, but it don't have to be compiled
+KMEXTRACTONLY="
+ libkcal/"
+KMCOMPILEONLY="
+ libkcal/libical/src/libical/
+ libkcal/libical/src/libicalss/"
+
+src_compile() {
+ kde-meta_src_compile myconf configure
+ # generate "ical.h"
+ cd "${S}/libkcal/libical/src/libical" && make ical.h
+ # generate "icalss.h"
+ cd "${S}/libkcal/libical/src/libicalss" && make icalss.h
+
+ kde-meta_src_compile make
+}