summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-09-04 18:45:48 +0000
committerJohannes Huber <johu@gentoo.org>2012-09-04 18:45:48 +0000
commit15e1e7fdd1e191927f169caf35f9223d23a57246 (patch)
treea24b9205d75050edee2d793b88c839b440af63fc /kde-base/marble
parentAdd net-misc/leechcraft-launchy, thanks to 0xd34df00d (diff)
downloadgentoo-2-15e1e7fdd1e191927f169caf35f9223d23a57246.tar.gz
gentoo-2-15e1e7fdd1e191927f169caf35f9223d23a57246.tar.bz2
gentoo-2-15e1e7fdd1e191927f169caf35f9223d23a57246.zip
Version bump KDE SC 4.9.1
(Portage version: 2.2.0_alpha124/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/marble')
-rw-r--r--kde-base/marble/ChangeLog8
-rw-r--r--kde-base/marble/files/marble-4.9.1-shapelib.patch13
-rw-r--r--kde-base/marble/marble-4.9.1.ebuild88
-rw-r--r--kde-base/marble/metadata.xml1
4 files changed, 109 insertions, 1 deletions
diff --git a/kde-base/marble/ChangeLog b/kde-base/marble/ChangeLog
index 52b985f54552..05754e29857b 100644
--- a/kde-base/marble/ChangeLog
+++ b/kde-base/marble/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/marble
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/marble/ChangeLog,v 1.156 2012/09/03 14:31:26 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/marble/ChangeLog,v 1.157 2012/09/04 18:45:28 johu Exp $
+
+*marble-4.9.1 (04 Sep 2012)
+
+ 04 Sep 2012; Johannes Huber <johu@gentoo.org> +marble-4.9.1.ebuild,
+ +files/marble-4.9.1-shapelib.patch:
+ Version bump KDE SC 4.9.1
03 Sep 2012; Johannes Huber <johu@gentoo.org>
-files/marble-4.7-magic-r1.patch, -files/marble-4.8.0-lower-qt48.patch,
diff --git a/kde-base/marble/files/marble-4.9.1-shapelib.patch b/kde-base/marble/files/marble-4.9.1-shapelib.patch
new file mode 100644
index 000000000000..2f86c7378b8f
--- /dev/null
+++ b/kde-base/marble/files/marble-4.9.1-shapelib.patch
@@ -0,0 +1,13 @@
+diff --git a/src/plugins/runner/CMakeLists.txt b/src/plugins/runner/CMakeLists.txt
+index 4ab295a..0b82fa7 100644
+--- a/src/plugins/runner/CMakeLists.txt
++++ b/src/plugins/runner/CMakeLists.txt
+@@ -26,7 +26,7 @@ add_subdirectory( osm )
+ add_subdirectory( pnt )
+ add_subdirectory( log )
+
+-find_package( libshp )
++macro_optional_find_package( libshp )
+ if( LIBSHP_FOUND )
+ add_subdirectory( shp )
+ endif( LIBSHP_FOUND )
diff --git a/kde-base/marble/marble-4.9.1.ebuild b/kde-base/marble/marble-4.9.1.ebuild
new file mode 100644
index 000000000000..9fe2e7c3e450
--- /dev/null
+++ b/kde-base/marble/marble-4.9.1.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/marble/marble-4.9.1.ebuild,v 1.1 2012/09/04 18:45:28 johu Exp $
+
+EAPI=4
+
+KDE_HANDBOOK="optional"
+KDE_REQUIRED="optional"
+CPPUNIT_REQUIRED="optional"
+PYTHON_DEPEND="python? 2"
+inherit kde4-base python
+
+DESCRIPTION="Generic geographical map widget"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug designer-plugin gps +kde plasma python shapefile test"
+
+# tests fail / segfault. Last checked for 4.9.0
+RESTRICT="test"
+
+RDEPEND="
+ x11-libs/qt-core:4
+ x11-libs/qt-declarative:4
+ x11-libs/qt-gui:4[dbus]
+ x11-libs/qt-script:4
+ x11-libs/qt-sql:4
+ x11-libs/qt-svg:4
+ x11-libs/qt-webkit:4
+ gps? ( >=sci-geosciences/gpsd-2.95[qt4] )
+ python? (
+ >=dev-python/PyQt4-4.4.4-r1
+ kde? ( $(add_kdebase_dep pykde4) )
+ )
+ shapefile? ( sci-libs/shapelib )
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( x11-libs/qt-test:4 )
+"
+# the qt dependencies are needed because with USE=-kde nothing is pulled in
+# by default... bugs 414165 & 429346
+
+REQUIRED_USE="
+ plasma? ( kde )
+ python? ( kde )
+"
+
+PATCHES=( "${FILESDIR}/${P}-shapelib.patch" )
+
+pkg_setup() {
+ python_set_active_version 2
+ kde4-base_pkg_setup
+ python_pkg_setup
+}
+
+src_prepare() {
+ kde4-base_src_prepare
+ python_convert_shebangs -r $(python_get_version) .
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with designer-plugin DESIGNER_PLUGIN)
+ $(cmake-utils_use python EXPERIMENTAL_PYTHON_BINDINGS)
+ $(cmake-utils_use_with python PyQt4)
+ $(cmake-utils_use_with python PythonLibrary)
+ $(cmake-utils_use_with python SIP)
+ $(cmake-utils_use_with gps libgps)
+ $(cmake-utils_use !kde QTONLY)
+ $(cmake-utils_use_with plasma)
+ $(cmake-utils_use_with shapefile libshp)
+ -DBUILD_MARBLE_TESTS=OFF
+ -DWITH_liblocation=0
+ $(use kde && cmake-utils_use_with python PyKDE4)
+ )
+
+ kde4-base_src_configure
+}
+
+src_test() {
+ if use kde; then
+ elog "Marble tests can only be run in the qt-only version"
+ else
+ local mycmakeargs=(
+ -DBUILD_MARBLE_TESTS=ON
+ )
+ kde4-base_src_test
+ fi
+}
diff --git a/kde-base/marble/metadata.xml b/kde-base/marble/metadata.xml
index 5c6e78a977ba..90fe1d9d5eb1 100644
--- a/kde-base/marble/metadata.xml
+++ b/kde-base/marble/metadata.xml
@@ -3,6 +3,7 @@
<pkgmetadata>
<use>
<flag name="designer-plugin">Enable designer plugin</flag>
+ <flag name="shapefile">Enable support for ESRI shapefiles</flag>
</use>
<herd>kde</herd>
</pkgmetadata>