summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2011-12-11 18:52:41 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2011-12-11 18:52:41 +0000
commitaa3564c24799d7ef9148aa35aa2294090c7d0672 (patch)
tree564f76c48c05f07f04c01e801b11d91042e6830f /kde-base/okular
parentAdd 3.0 documentation (diff)
downloadgentoo-2-aa3564c24799d7ef9148aa35aa2294090c7d0672.tar.gz
gentoo-2-aa3564c24799d7ef9148aa35aa2294090c7d0672.tar.bz2
gentoo-2-aa3564c24799d7ef9148aa35aa2294090c7d0672.zip
[kde-base] Add long waiting KDE SC 4.7.4
(Portage version: 2.2.0_alpha79/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/okular')
-rw-r--r--kde-base/okular/ChangeLog7
-rw-r--r--kde-base/okular/okular-4.7.4.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/kde-base/okular/ChangeLog b/kde-base/okular/ChangeLog
index c1c13019ecdc..71e2d72eb46c 100644
--- a/kde-base/okular/ChangeLog
+++ b/kde-base/okular/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/okular
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/okular/ChangeLog,v 1.120 2011/12/07 23:07:56 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/okular/ChangeLog,v 1.121 2011/12/11 18:52:32 alexxy Exp $
+
+*okular-4.7.4 (11 Dec 2011)
+
+ 11 Dec 2011; Alexey Shvetsov <alexxy@gentoo.org> +okular-4.7.4.ebuild:
+ Version bump KDE SC 4.7.4
07 Dec 2011; Andreas K. Huettel <dilfridge@gentoo.org> -okular-4.7.2.ebuild:
Drop KDE 4.7.2
diff --git a/kde-base/okular/okular-4.7.4.ebuild b/kde-base/okular/okular-4.7.4.ebuild
new file mode 100644
index 000000000000..8446f40611d5
--- /dev/null
+++ b/kde-base/okular/okular-4.7.4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/okular/okular-4.7.4.ebuild,v 1.1 2011/12/11 18:52:32 alexxy Exp $
+
+EAPI=4
+
+KDE_HANDBOOK="optional"
+KDE_SCM="git"
+inherit kde4-base
+
+DESCRIPTION="Okular is an universal document viewer based on KPDF for KDE 4."
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="chm crypt debug djvu ebook +jpeg +ps +pdf +tiff"
+
+DEPEND="
+ media-libs/freetype
+ media-libs/qimageblitz
+ sys-libs/zlib
+ chm? ( dev-libs/chmlib )
+ crypt? ( app-crypt/qca:2 )
+ djvu? ( app-text/djvu )
+ ebook? ( app-text/ebook-tools )
+ jpeg? ( virtual/jpeg:0 )
+ pdf? ( >=app-text/poppler-0.12.3-r3[lcms,qt4,-exceptions(-)] )
+ ps? ( app-text/libspectre )
+ tiff? ( media-libs/tiff )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with chm)
+ $(cmake-utils_use_with crypt QCA2)
+ $(cmake-utils_use_with djvu DjVuLibre)
+ $(cmake-utils_use_with ebook EPub)
+ $(cmake-utils_use_with jpeg)
+ $(cmake-utils_use_with ps LibSpectre)
+ $(cmake-utils_use_with pdf PopplerQt4)
+ $(cmake-utils_use_with pdf Poppler)
+ $(cmake-utils_use_with tiff)
+ )
+
+ kde4-base_src_configure
+}