summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2014-01-18 11:24:17 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2014-01-18 11:24:17 +0000
commit14c988d01f8c84ab2bd2faa3c01c646602dc1692 (patch)
tree4b095bcf239f3426af85e14e94933b79e8588042 /kde-base/perlqt
parentCleanup. (diff)
downloadgentoo-2-14c988d01f8c84ab2bd2faa3c01c646602dc1692.tar.gz
gentoo-2-14c988d01f8c84ab2bd2faa3c01c646602dc1692.tar.bz2
gentoo-2-14c988d01f8c84ab2bd2faa3c01c646602dc1692.zip
Version bump KDE SC 4.12.1
(Portage version: 2.2.8/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key EBE6A336BE19039C!)
Diffstat (limited to 'kde-base/perlqt')
-rw-r--r--kde-base/perlqt/ChangeLog7
-rw-r--r--kde-base/perlqt/perlqt-4.12.1.ebuild48
2 files changed, 54 insertions, 1 deletions
diff --git a/kde-base/perlqt/ChangeLog b/kde-base/perlqt/ChangeLog
index 5528897c81a9..73ded942c0bd 100644
--- a/kde-base/perlqt/ChangeLog
+++ b/kde-base/perlqt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/perlqt
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/perlqt/ChangeLog,v 1.115 2014/01/10 04:32:15 creffett Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/perlqt/ChangeLog,v 1.116 2014/01/18 11:24:12 dilfridge Exp $
+
+*perlqt-4.12.1 (18 Jan 2014)
+
+ 18 Jan 2014; Andreas K. Huettel <dilfridge@gentoo.org> +perlqt-4.12.1.ebuild:
+ Version bump KDE SC 4.12.1
10 Jan 2014; Chris Reffett <creffett@gentoo.org> -perlqt-4.11.4.ebuild:
Remove KDE SC 4.11.4
diff --git a/kde-base/perlqt/perlqt-4.12.1.ebuild b/kde-base/perlqt/perlqt-4.12.1.ebuild
new file mode 100644
index 000000000000..a6bbd8f5c052
--- /dev/null
+++ b/kde-base/perlqt/perlqt-4.12.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/perlqt/perlqt-4.12.1.ebuild,v 1.1 2014/01/18 11:24:12 dilfridge Exp $
+
+EAPI=5
+
+DECLARATIVE_REQUIRED="optional"
+MULTIMEDIA_REQUIRED="optional"
+OPENGL_REQUIRED="optional"
+QTHELP_REQUIRED="optional"
+KDE_REQUIRED="never"
+VIRTUALX_REQUIRED="test"
+inherit kde4-base
+
+DESCRIPTION="Qt Perl bindings"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug phonon qimageblitz qscintilla qwt webkit"
+
+RDEPEND="
+ >=dev-lang/perl-5.10.1
+ dev-perl/List-MoreUtils
+ $(add_kdebase_dep smokeqt 'declarative?,multimedia?,opengl?,phonon?,qimageblitz?,qscintilla?,qthelp?,qwt?,webkit?')
+"
+DEPEND=${RDEPEND}
+
+PATCHES=(
+ "${FILESDIR}/${PN}-4.10.80-vendor.patch"
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DDISABLE_Qt3Support=ON
+ $(cmake-utils_use_disable declarative QtDeclarative)
+ $(cmake-utils_use_disable multimedia QtMultimedia)
+ $(cmake-utils_use_disable opengl QtOpenGL)
+ $(cmake-utils_use_with phonon)
+ $(cmake-utils_use_with qimageblitz QImageBlitz)
+ $(cmake-utils_use_with qscintilla QScintilla)
+ $(cmake-utils_use_disable qthelp QtHelp)
+ $(cmake-utils_use_disable qwt)
+ $(cmake-utils_use_disable webkit QtWebKit)
+ )
+ kde4-base_src_configure
+}
+
+src_test() {
+ PERL5LIB="${BUILD_DIR}/blib/arch:${BUILD_DIR}/blib/lib" kde4-base_src_test
+}