summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2013-06-04 18:22:23 +0000
committerJohannes Huber <johu@gentoo.org>2013-06-04 18:22:23 +0000
commit20f55f8fb805f8021dd9ded690b2815eb78ffc4f (patch)
tree80067b7b6ce35f4bffa5921e939a528f7d1cae22 /kde-base/perlqt
parentVersion bump. (diff)
downloadgentoo-2-20f55f8fb805f8021dd9ded690b2815eb78ffc4f.tar.gz
gentoo-2-20f55f8fb805f8021dd9ded690b2815eb78ffc4f.tar.bz2
gentoo-2-20f55f8fb805f8021dd9ded690b2815eb78ffc4f.zip
Version bump KDE SC 4.10.4
(Portage version: 2.2.0_alpha177/cvs/Linux x86_64, signed Manifest commit with key F3CFD2BD)
Diffstat (limited to 'kde-base/perlqt')
-rw-r--r--kde-base/perlqt/ChangeLog7
-rw-r--r--kde-base/perlqt/perlqt-4.10.4.ebuild51
2 files changed, 57 insertions, 1 deletions
diff --git a/kde-base/perlqt/ChangeLog b/kde-base/perlqt/ChangeLog
index 987fb00e28ce..496d8e321b97 100644
--- a/kde-base/perlqt/ChangeLog
+++ b/kde-base/perlqt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/perlqt
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/perlqt/ChangeLog,v 1.79 2013/06/04 13:06:34 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/perlqt/ChangeLog,v 1.80 2013/06/04 18:22:19 johu Exp $
+
+*perlqt-4.10.4 (04 Jun 2013)
+
+ 04 Jun 2013; Johannes Huber <johu@gentoo.org> +perlqt-4.10.4.ebuild:
+ Version bump KDE SC 4.10.4
04 Jun 2013; Agostino Sarubbo <ago@gentoo.org> perlqt-4.10.3.ebuild:
Stable for amd64, wrt to bug #471392
diff --git a/kde-base/perlqt/perlqt-4.10.4.ebuild b/kde-base/perlqt/perlqt-4.10.4.ebuild
new file mode 100644
index 000000000000..6f04b0396dd2
--- /dev/null
+++ b/kde-base/perlqt/perlqt-4.10.4.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/perlqt/perlqt-4.10.4.ebuild,v 1.1 2013/06/04 18:22:19 johu Exp $
+
+EAPI=5
+
+DECLARATIVE_REQUIRED="optional"
+MULTIMEDIA_REQUIRED="optional"
+OPENGL_REQUIRED="optional"
+QTHELP_REQUIRED="optional"
+KDE_REQUIRED="never"
+VIRTUALX_REQUIRED="test"
+inherit kde4-base
+
+DESCRIPTION="Qt Perl bindings"
+KEYWORDS=" ~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug phonon qimageblitz qscintilla qwt webkit"
+
+RDEPEND="
+ >=dev-lang/perl-5.10.1
+ dev-perl/List-MoreUtils
+ $(add_kdebase_dep smokeqt 'declarative?,multimedia?,opengl?,phonon?,qimageblitz?,qscintilla?,qthelp?,qwt?,webkit?')
+"
+DEPEND=${RDEPEND}
+
+# Split from kdebindings-perl in 4.7
+add_blocker kdebindings-perl
+
+PATCHES=(
+ "${FILESDIR}/${PN}-4.7.2-vendor.patch"
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DDISABLE_Qt3Support=ON
+ $(cmake-utils_use_disable declarative QtDeclarative)
+ $(cmake-utils_use_disable multimedia QtMultimedia)
+ $(cmake-utils_use_disable opengl QtOpenGL)
+ $(cmake-utils_use_with phonon)
+ $(cmake-utils_use_with qimageblitz QImageBlitz)
+ $(cmake-utils_use_with qscintilla QScintilla)
+ $(cmake-utils_use_disable qthelp QtHelp)
+ $(cmake-utils_use_disable qwt)
+ $(cmake-utils_use_disable webkit QtWebKit)
+ )
+ kde4-base_src_configure
+}
+
+src_test() {
+ PERL5LIB="${CMAKE_BUILD_DIR}/blib/arch:${CMAKE_BUILD_DIR}/blib/lib" kde4-base_src_test
+}