summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2013-08-14 20:24:27 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2013-08-14 20:24:27 +0000
commit053fab4599b7a153575d6540f06f69fecd0d2740 (patch)
tree4f7d23e33c53b4249e734fa22c9151eae906afd0 /kde-base/phonon-kde
parentFixed and marked for ~x64-macos, bug #479554 (diff)
downloadgentoo-2-053fab4599b7a153575d6540f06f69fecd0d2740.tar.gz
gentoo-2-053fab4599b7a153575d6540f06f69fecd0d2740.tar.bz2
gentoo-2-053fab4599b7a153575d6540f06f69fecd0d2740.zip
Version bump KDE SC 4.11.0
(Portage version: 2.2.0_alpha196/cvs/Linux x86_64, signed Manifest commit with key EBE6A336BE19039C!)
Diffstat (limited to 'kde-base/phonon-kde')
-rw-r--r--kde-base/phonon-kde/ChangeLog8
-rw-r--r--kde-base/phonon-kde/phonon-kde-4.11.0.ebuild36
2 files changed, 43 insertions, 1 deletions
diff --git a/kde-base/phonon-kde/ChangeLog b/kde-base/phonon-kde/ChangeLog
index ea598749c4f8..45b692037bdc 100644
--- a/kde-base/phonon-kde/ChangeLog
+++ b/kde-base/phonon-kde/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/phonon-kde
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/phonon-kde/ChangeLog,v 1.183 2013/08/02 17:21:08 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/phonon-kde/ChangeLog,v 1.184 2013/08/14 20:24:25 dilfridge Exp $
+
+*phonon-kde-4.11.0 (14 Aug 2013)
+
+ 14 Aug 2013; Andreas K. Huettel <dilfridge@gentoo.org>
+ +phonon-kde-4.11.0.ebuild:
+ Version bump KDE SC 4.11.0
02 Aug 2013; Johannes Huber <johu@gentoo.org> -phonon-kde-4.10.4.ebuild:
Remove KDE SC 4.10.4
diff --git a/kde-base/phonon-kde/phonon-kde-4.11.0.ebuild b/kde-base/phonon-kde/phonon-kde-4.11.0.ebuild
new file mode 100644
index 000000000000..75878f160235
--- /dev/null
+++ b/kde-base/phonon-kde/phonon-kde-4.11.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/phonon-kde/phonon-kde-4.11.0.ebuild,v 1.1 2013/08/14 20:24:25 dilfridge Exp $
+
+EAPI=5
+
+KMNAME="kde-runtime"
+KMMODULE="phonon"
+inherit kde4-meta
+
+DESCRIPTION="Phonon KDE Integration"
+HOMEPAGE="http://phonon.kde.org"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="alsa debug pulseaudio"
+
+DEPEND="
+ >=media-libs/phonon-4.4.3
+ alsa? ( media-libs/alsa-lib )
+ pulseaudio? (
+ dev-libs/glib:2
+ media-libs/libcanberra
+ >=media-sound/pulseaudio-0.9.21[glib]
+ )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ mycmakeargs=(
+ -DBUILD_tests=OFF
+ -DWITH_Xine=OFF
+ $(cmake-utils_use_with alsa)
+ $(cmake-utils_use_with pulseaudio PulseAudio)
+ )
+
+ kde4-meta_src_configure
+}