summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Callen <abcd@gentoo.org>2010-01-28 06:13:52 +0000
committerJonathan Callen <abcd@gentoo.org>2010-01-28 06:13:52 +0000
commit4530632cc9a1c4a7190811c2173d0b501b947b57 (patch)
tree542a8e4eb6c265cc3f1d220e0e280a00c79d0036 /kde-base/pykde4
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-4530632cc9a1c4a7190811c2173d0b501b947b57.tar.gz
gentoo-2-4530632cc9a1c4a7190811c2173d0b501b947b57.tar.bz2
gentoo-2-4530632cc9a1c4a7190811c2173d0b501b947b57.zip
Fix pykdeuic4 for recent PyQt4
(Portage version: -svn/cvs/Linux i686)
Diffstat (limited to 'kde-base/pykde4')
-rw-r--r--kde-base/pykde4/ChangeLog8
-rw-r--r--kde-base/pykde4/files/pykde4-4.3.5-fix-pykdeuic4.patch11
-rw-r--r--kde-base/pykde4/pykde4-4.3.5-r1.ebuild (renamed from kde-base/pykde4/pykde4-4.3.5.ebuild)3
3 files changed, 20 insertions, 2 deletions
diff --git a/kde-base/pykde4/ChangeLog b/kde-base/pykde4/ChangeLog
index 4f19809d3fa7..23176b28ddeb 100644
--- a/kde-base/pykde4/ChangeLog
+++ b/kde-base/pykde4/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/pykde4
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/pykde4/ChangeLog,v 1.51 2010/01/27 07:28:04 abcd Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/pykde4/ChangeLog,v 1.52 2010/01/28 06:13:52 abcd Exp $
+
+*pykde4-4.3.5-r1 (28 Jan 2010)
+
+ 28 Jan 2010; Jonathan Callen <abcd@gentoo.org> -pykde4-4.3.5.ebuild,
+ +pykde4-4.3.5-r1.ebuild, +files/pykde4-4.3.5-fix-pykdeuic4.patch:
+ Fix pykdeuic4 for recent PyQt4
27 Jan 2010; Jonathan Callen <abcd@gentoo.org> pykde4-4.3.5.ebuild:
Patch from 4.3.4 is still needed (compilation fix) - bug 301106
diff --git a/kde-base/pykde4/files/pykde4-4.3.5-fix-pykdeuic4.patch b/kde-base/pykde4/files/pykde4-4.3.5-fix-pykdeuic4.patch
new file mode 100644
index 000000000000..0117b01daa80
--- /dev/null
+++ b/kde-base/pykde4/files/pykde4-4.3.5-fix-pykdeuic4.patch
@@ -0,0 +1,11 @@
+--- trunk/KDE/kdebindings/python/pykde4/tools/pykdeuic4/pykdeuic4.py 2009/12/21 19:21:54 1064783
++++ trunk/KDE/kdebindings/python/pykde4/tools/pykdeuic4/pykdeuic4.py 2009/12/21 19:22:32 1064784
+@@ -39,7 +39,7 @@
+ def __init__(self,string):
+ original_i18n_string.__init__(self,string)
+ def __str__(self):
+- return "kdecore.i18n(\"%s\")" % (self.escape(self.string),)
++ return "kdecore.i18n(\"%s\")" % (qtproxies.escape(self.string),)
+ qtproxies.i18n_string = kde_i18n_string
+
+ def kdeFilter():
diff --git a/kde-base/pykde4/pykde4-4.3.5.ebuild b/kde-base/pykde4/pykde4-4.3.5-r1.ebuild
index 340c48fcd7fe..5a6d3e5f16c8 100644
--- a/kde-base/pykde4/pykde4-4.3.5.ebuild
+++ b/kde-base/pykde4/pykde4-4.3.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/pykde4/pykde4-4.3.5.ebuild,v 1.2 2010/01/27 07:28:04 abcd Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/pykde4/pykde4-4.3.5-r1.ebuild,v 1.1 2010/01/28 06:13:52 abcd Exp $
EAPI="2"
@@ -28,6 +28,7 @@ RDEPEND="${DEPEND}
PATCHES=(
"${FILESDIR}"/${PN}-4.3.4-typedefs.sip.patch
+ "${FILESDIR}"/${P}-fix-pykdeuic4.patch
)
pkg_setup() {