summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIngmar Vanhassel <ingmar@gentoo.org>2008-02-19 04:16:33 +0000
committerIngmar Vanhassel <ingmar@gentoo.org>2008-02-19 04:16:33 +0000
commitc99a72061e6fd6efd1e6382f115bdd711b05f722 (patch)
tree41d38fcf8a2b1531ee7559bc177e566d6b2423c9 /kde-base/pykde
parentout with the old! (diff)
downloadgentoo-2-c99a72061e6fd6efd1e6382f115bdd711b05f722.tar.gz
gentoo-2-c99a72061e6fd6efd1e6382f115bdd711b05f722.tar.bz2
gentoo-2-c99a72061e6fd6efd1e6382f115bdd711b05f722.zip
Fix dependencies.
(Portage version: 2.1.4.4)
Diffstat (limited to 'kde-base/pykde')
-rw-r--r--kde-base/pykde/pykde-3.5.5-r2.ebuild20
-rw-r--r--kde-base/pykde/pykde-3.5.7.ebuild20
-rw-r--r--kde-base/pykde/pykde-3.5.8.ebuild4
3 files changed, 22 insertions, 22 deletions
diff --git a/kde-base/pykde/pykde-3.5.5-r2.ebuild b/kde-base/pykde/pykde-3.5.5-r2.ebuild
index 7b24d87064a7..81e62f2e7ed1 100644
--- a/kde-base/pykde/pykde-3.5.5-r2.ebuild
+++ b/kde-base/pykde/pykde-3.5.5-r2.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/pykde/pykde-3.5.5-r2.ebuild,v 1.6 2007/02/20 16:58:15 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/pykde/pykde-3.5.5-r2.ebuild,v 1.7 2008/02/19 04:16:33 ingmar Exp $
KMNAME=kdebindings
KMMODULE=python
KM_MAKEFILESREV=1
-MAXKDEVER=$PV
+MAXKDEVER=3.5.8
KM_DEPRANGE="$PV $MAXKDEVER"
inherit kde-meta distutils
@@ -24,12 +24,12 @@ DEPEND="~dev-python/sip-4.2.1
src_unpack() {
kde-meta_src_unpack
- cd ${S}/python/pykde
+ cd "${S}"/python/pykde
epatch "${FILESDIR}/configure.py.diff"
}
src_compile() {
- cd ${S}/python/pykde
+ cd "${S}"/python/pykde
distutils_python_version
local myconf="-d /usr/$(get_libdir)/python${PYVER}/site-packages \
@@ -45,14 +45,14 @@ src_compile() {
}
src_install() {
- cd ${S}/python/pykde
- make DESTDIR=${D} install || die
- find ${D}/usr/share/sip -not -type d -not -iname *.sip -exec rm '{}' \;
+ cd "${S}"/python/pykde
+ make DESTDIR="${D}" install || die
+ find "${D}"/usr/share/sip -not -type d -not -iname *.sip -exec rm '{}' \;
dodoc AUTHORS ChangeLog NEWS README THANKS
use doc && dohtml -r doc/*
if use examples ; then
- cp -r examples ${D}/usr/share/doc/${PF}
- cp -r templates ${D}/usr/share/doc/${PF}
+ cp -r examples "${D}"/usr/share/doc/${PF}
+ cp -r templates "${D}"/usr/share/doc/${PF}
fi
}
diff --git a/kde-base/pykde/pykde-3.5.7.ebuild b/kde-base/pykde/pykde-3.5.7.ebuild
index 96682c5f9b87..3c24e25fad13 100644
--- a/kde-base/pykde/pykde-3.5.7.ebuild
+++ b/kde-base/pykde/pykde-3.5.7.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/pykde/pykde-3.5.7.ebuild,v 1.5 2007/08/19 16:38:44 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/pykde/pykde-3.5.7.ebuild,v 1.6 2008/02/19 04:16:33 ingmar Exp $
KMNAME=kdebindings
KMMODULE=python
KM_MAKEFILESREV=1
-MAXKDEVER=$PV
+MAXKDEVER=3.5.8
KM_DEPRANGE="$PV $MAXKDEVER"
inherit kde-meta distutils
@@ -24,12 +24,12 @@ DEPEND="~dev-python/sip-4.2.1
src_unpack() {
kde-meta_src_unpack
- cd ${S}/python/pykde
+ cd "${S}"/python/pykde
epatch "${FILESDIR}/configure.py.diff"
}
src_compile() {
- cd ${S}/python/pykde
+ cd "${S}"/python/pykde
distutils_python_version
local myconf="-d /usr/$(get_libdir)/python${PYVER}/site-packages \
@@ -45,14 +45,14 @@ src_compile() {
}
src_install() {
- cd ${S}/python/pykde
- make DESTDIR=${D} install || die
- find ${D}/usr/share/sip -not -type d -not -iname *.sip -exec rm '{}' \;
+ cd "${S}"/python/pykde
+ make DESTDIR="${D}" install || die
+ find "${D}"/usr/share/sip -not -type d -not -iname *.sip -exec rm '{}' \;
dodoc AUTHORS ChangeLog NEWS README THANKS
use doc && dohtml -r doc/*
if use examples ; then
- cp -r examples ${D}/usr/share/doc/${PF}
- cp -r templates ${D}/usr/share/doc/${PF}
+ cp -r examples "${D}"/usr/share/doc/${PF}
+ cp -r templates "${D}"/usr/share/doc/${PF}
fi
}
diff --git a/kde-base/pykde/pykde-3.5.8.ebuild b/kde-base/pykde/pykde-3.5.8.ebuild
index 3cac2a91f543..e4e4d2ac73c1 100644
--- a/kde-base/pykde/pykde-3.5.8.ebuild
+++ b/kde-base/pykde/pykde-3.5.8.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/pykde/pykde-3.5.8.ebuild,v 1.5 2008/01/19 02:13:20 ingmar Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/pykde/pykde-3.5.8.ebuild,v 1.6 2008/02/19 04:16:33 ingmar Exp $
KMNAME=kdebindings
KMMODULE=python
KM_MAKEFILESREV=1
-MAXKDEVER=$PV
+MAXKDEVER=3.5.9
KM_DEPRANGE="$PV $MAXKDEVER"
inherit kde-meta distutils