summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIngmar Vanhassel <ingmar@gentoo.org>2008-01-18 02:55:14 +0000
committerIngmar Vanhassel <ingmar@gentoo.org>2008-01-18 02:55:14 +0000
commitbadb0cbc67bb65499420617dfaf4f33f025b922f (patch)
tree3aaa024c08d023f0f4a20c2dfea96d235736e714 /kde-base/qimageblitz/qimageblitz-0.0.4.ebuild
parentAdded kde-base/qimageblitz to package.mask. (diff)
downloadgentoo-2-badb0cbc67bb65499420617dfaf4f33f025b922f.tar.gz
gentoo-2-badb0cbc67bb65499420617dfaf4f33f025b922f.tar.bz2
gentoo-2-badb0cbc67bb65499420617dfaf4f33f025b922f.zip
Added KDE 4.0's qimageblitz.
(Portage version: 2.1.4)
Diffstat (limited to 'kde-base/qimageblitz/qimageblitz-0.0.4.ebuild')
-rw-r--r--kde-base/qimageblitz/qimageblitz-0.0.4.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/kde-base/qimageblitz/qimageblitz-0.0.4.ebuild b/kde-base/qimageblitz/qimageblitz-0.0.4.ebuild
new file mode 100644
index 000000000000..bea65b46d4ce
--- /dev/null
+++ b/kde-base/qimageblitz/qimageblitz-0.0.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/qimageblitz/qimageblitz-0.0.4.ebuild,v 1.1 2008/01/18 02:55:13 ingmar Exp $
+
+EAPI="1"
+
+inherit cmake-utils eutils
+
+DESCRIPTION="Qimageblitz is an interim image effect library that people can use until KDE 4.1"
+HOMEPAGE="http://websvn.kde.org/trunk/kdesupport/qimageblitz/"
+LICENSE="GPL-2 LGPL-2"
+
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+
+IUSE="3dnow altivec debug mmx sse sse2"
+
+DEPEND=">=x11-libs/qt-4.2.0:4"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/qimageblitz-9999-exec-stack.patch
+}
+
+src_compile() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_has 3dnow 3DNOW)
+ $(cmake-utils_has altivec ALTIVEC)
+ $(cmake-utils_has mmx MMX)
+ $(cmake-utils_has sse SSE)
+ $(cmake-utils_has sse2 SSE2)"
+
+ cmake-utils_src_compile
+}