summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-12-02 13:05:19 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-12-02 13:05:19 +0000
commitcaf6063d3d0e3edb422fd920b8042c5117544afc (patch)
tree37760cd1e838789aa53de3bb678d19d640944f8d /kde-base/qtruby
parentamd64/x86 stable, bug #526056 (diff)
downloadgentoo-2-caf6063d3d0e3edb422fd920b8042c5117544afc.tar.gz
gentoo-2-caf6063d3d0e3edb422fd920b8042c5117544afc.tar.bz2
gentoo-2-caf6063d3d0e3edb422fd920b8042c5117544afc.zip
Revision bump to default to ruby20.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'kde-base/qtruby')
-rw-r--r--kde-base/qtruby/ChangeLog7
-rw-r--r--kde-base/qtruby/qtruby-4.14.3-r1.ebuild71
2 files changed, 77 insertions, 1 deletions
diff --git a/kde-base/qtruby/ChangeLog b/kde-base/qtruby/ChangeLog
index 024f3eecba13..b0b29eeed055 100644
--- a/kde-base/qtruby/ChangeLog
+++ b/kde-base/qtruby/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/qtruby
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/qtruby/ChangeLog,v 1.224 2014/11/16 12:21:31 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/qtruby/ChangeLog,v 1.225 2014/12/02 13:05:19 mrueg Exp $
+
+*qtruby-4.14.3-r1 (02 Dec 2014)
+
+ 02 Dec 2014; Manuel Rüger <mrueg@gentoo.org> +qtruby-4.14.3-r1.ebuild:
+ Revision bump to default to ruby20.
*qtruby-4.14.3 (16 Nov 2014)
diff --git a/kde-base/qtruby/qtruby-4.14.3-r1.ebuild b/kde-base/qtruby/qtruby-4.14.3-r1.ebuild
new file mode 100644
index 000000000000..c91ea09a82e8
--- /dev/null
+++ b/kde-base/qtruby/qtruby-4.14.3-r1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/qtruby/qtruby-4.14.3-r1.ebuild,v 1.1 2014/12/02 13:05:19 mrueg Exp $
+
+EAPI=5
+
+OPENGL_REQUIRED="always"
+DECLARATIVE_REQUIRED="optional"
+KDE_REQUIRED="never"
+USE_RUBY="ruby20"
+# Only one ruby version is supported:
+# 1) cmake bails when configuring twice or more - solved with CMAKE_IN_SOURCE_BUILD=1
+# 2) the ebuild can only be installed for one ruby variant, otherwise the compiled
+# files with identical path+name will overwrite each other - difficult :(
+
+inherit kde4-base ruby-ng
+
+DESCRIPTION="Qt Ruby bindings"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug phonon qscintilla qwt webkit"
+HOMEPAGE="http://techbase.kde.org/Development/Languages/Ruby"
+
+DEPEND="
+ $(add_kdebase_dep smokeqt 'declarative?,opengl,phonon?,qscintilla?,qwt?,webkit?')
+"
+
+RDEPEND="${DEPEND}
+"
+
+pkg_setup() {
+ ruby-ng_pkg_setup
+ kde4-base_pkg_setup
+}
+
+src_unpack() {
+ local S="${WORKDIR}/${P}"
+ kde4-base_src_unpack
+
+ cd "${WORKDIR}"
+ mkdir all
+ mv ${P} all/ || die "Could not move sources"
+}
+
+all_ruby_prepare() {
+ kde4-base_src_prepare
+}
+
+each_ruby_configure() {
+ local CMAKE_USE_DIR=${S}
+ local mycmakeargs=(
+ -DRUBY_LIBRARY=$(ruby_get_libruby)
+ -DRUBY_INCLUDE_PATH=$(ruby_get_hdrdir)
+ -DRUBY_EXECUTABLE=${RUBY}
+ $(cmake-utils_use_disable declarative QtDeclarative)
+ $(cmake-utils_use_with phonon)
+ $(cmake-utils_use_with qscintilla QScintilla)
+ $(cmake-utils_use_with qwt Qwt5)
+ $(cmake-utils_use_disable webkit QtWebKit)
+ )
+ kde4-base_src_configure
+}
+
+each_ruby_compile() {
+ local CMAKE_USE_DIR=${S}
+ kde4-base_src_compile
+}
+
+each_ruby_install() {
+ local CMAKE_USE_DIR=${S}
+ kde4-base_src_install
+}