summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2005-07-28 21:16:26 +0000
committerDan Armak <danarmak@gentoo.org>2005-07-28 21:16:26 +0000
commit80ceeb9343ee15917cb727fa4e9f34cfcf2e09d4 (patch)
tree10350f32a739306558a2f194fa917fdb13a0e42c /kde-base/quanta/quanta-3.4.2.ebuild
parentMarked ~ppc. (diff)
downloadgentoo-2-80ceeb9343ee15917cb727fa4e9f34cfcf2e09d4.tar.gz
gentoo-2-80ceeb9343ee15917cb727fa4e9f34cfcf2e09d4.tar.bz2
gentoo-2-80ceeb9343ee15917cb727fa4e9f34cfcf2e09d4.zip
KDE 3.4.2 split ebuilds. p.masked, to be unmasked shortly.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'kde-base/quanta/quanta-3.4.2.ebuild')
-rw-r--r--kde-base/quanta/quanta-3.4.2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/kde-base/quanta/quanta-3.4.2.ebuild b/kde-base/quanta/quanta-3.4.2.ebuild
new file mode 100644
index 000000000000..5e1bc90ff87e
--- /dev/null
+++ b/kde-base/quanta/quanta-3.4.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/quanta/quanta-3.4.2.ebuild,v 1.1 2005/07/28 21:16:26 danarmak Exp $
+KMNAME=kdewebdev
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta eutils
+
+DESCRIPTION="KDE: Quanta Plus Web Development Environment"
+KEYWORDS=" ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc tidy"
+DEPEND="dev-libs/libxml2"
+RDEPEND="$DEPEND
+$(deprange $PV $MAXKDEVER kde-base/kfilereplace)
+$(deprange $PV $MAXKDEVER kde-base/kimagemapeditor)
+$(deprange $PV $MAXKDEVER kde-base/klinkstatus)
+$(deprange $PV $MAXKDEVER kde-base/kommander)
+$(deprange 3.4.1 $MAXKDEVER kde-base/kxsldbg)
+tidy? ( app-text/htmltidy )
+doc? ( app-doc/quanta-docs )"
+
+KMCOMPILEONLY=lib
+
+# TODO: check why this wasn't needed back in the monolithic ebuild
+src_compile () {
+ myconf="--with-extra-includes=$(xml2-config --cflags | sed -e 's:^-I::')"
+
+ export LIBXML_LIBS="`xml2-config --libs`"
+ export LIBXSLT_LIBS="`xslt-config --libs`"
+ kde-meta_src_compile
+}