summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2011-12-11 18:52:41 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2011-12-11 18:52:41 +0000
commitaa3564c24799d7ef9148aa35aa2294090c7d0672 (patch)
tree564f76c48c05f07f04c01e801b11d91042e6830f /kde-base/qyoto
parentAdd 3.0 documentation (diff)
downloadgentoo-2-aa3564c24799d7ef9148aa35aa2294090c7d0672.tar.gz
gentoo-2-aa3564c24799d7ef9148aa35aa2294090c7d0672.tar.bz2
gentoo-2-aa3564c24799d7ef9148aa35aa2294090c7d0672.zip
[kde-base] Add long waiting KDE SC 4.7.4
(Portage version: 2.2.0_alpha79/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/qyoto')
-rw-r--r--kde-base/qyoto/ChangeLog7
-rw-r--r--kde-base/qyoto/qyoto-4.7.4.ebuild31
2 files changed, 37 insertions, 1 deletions
diff --git a/kde-base/qyoto/ChangeLog b/kde-base/qyoto/ChangeLog
index b79c6c87dac4..72755b6bc5d3 100644
--- a/kde-base/qyoto/ChangeLog
+++ b/kde-base/qyoto/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/qyoto
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/qyoto/ChangeLog,v 1.9 2011/12/07 23:07:42 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/qyoto/ChangeLog,v 1.10 2011/12/11 18:52:18 alexxy Exp $
+
+*qyoto-4.7.4 (11 Dec 2011)
+
+ 11 Dec 2011; Alexey Shvetsov <alexxy@gentoo.org> +qyoto-4.7.4.ebuild:
+ Version bump KDE SC 4.7.4
07 Dec 2011; Andreas K. Huettel <dilfridge@gentoo.org> -qyoto-4.7.2.ebuild:
Drop KDE 4.7.2
diff --git a/kde-base/qyoto/qyoto-4.7.4.ebuild b/kde-base/qyoto/qyoto-4.7.4.ebuild
new file mode 100644
index 000000000000..869f6517b32f
--- /dev/null
+++ b/kde-base/qyoto/qyoto-4.7.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/qyoto/qyoto-4.7.4.ebuild,v 1.1 2011/12/11 18:52:18 alexxy Exp $
+
+EAPI=4
+
+KDE_REQUIRED="never"
+KDE_SCM="git"
+inherit kde4-base mono
+
+DESCRIPTION="C# bindings for Qt"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +phonon qscintilla webkit"
+
+DEPEND="
+ dev-lang/mono
+ $(add_kdebase_dep smokeqt 'opengl,phonon?,qscintilla?,webkit?')
+"
+RDEPEND="${DEPEND}"
+
+# Split from kdebindings-csharp in 4.7
+add_blocker kdebindings-csharp
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with phonon)
+ $(cmake-utils_use_disable qscintilla QScintilla)
+ $(cmake-utils_use_disable webkit QtWebKit)
+ )
+ kde4-base_src_configure
+}