summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-04-04 23:59:39 +0000
committerJohannes Huber <johu@gentoo.org>2012-04-04 23:59:39 +0000
commitb31cc0441f4628bad93065beae2d74cb436c08c6 (patch)
treeb946ea6b122ad7c1de4b8c58dc400606f74fb540 /kde-base/qyoto
parentdev-libs/uriparser: 0.7.7 (diff)
downloadgentoo-2-b31cc0441f4628bad93065beae2d74cb436c08c6.tar.gz
gentoo-2-b31cc0441f4628bad93065beae2d74cb436c08c6.tar.bz2
gentoo-2-b31cc0441f4628bad93065beae2d74cb436c08c6.zip
Version bump KDE SC 4.8.2
(Portage version: 2.2.0_alpha98/cvs/Linux i686)
Diffstat (limited to 'kde-base/qyoto')
-rw-r--r--kde-base/qyoto/ChangeLog7
-rw-r--r--kde-base/qyoto/qyoto-4.8.2.ebuild31
2 files changed, 37 insertions, 1 deletions
diff --git a/kde-base/qyoto/ChangeLog b/kde-base/qyoto/ChangeLog
index 57d5c1e5be8d..de2873a33b0a 100644
--- a/kde-base/qyoto/ChangeLog
+++ b/kde-base/qyoto/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/qyoto
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/qyoto/ChangeLog,v 1.19 2012/04/04 19:22:33 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/qyoto/ChangeLog,v 1.20 2012/04/04 23:59:08 johu Exp $
+
+*qyoto-4.8.2 (04 Apr 2012)
+
+ 04 Apr 2012; Johannes Huber <johu@gentoo.org> +qyoto-4.8.2.ebuild:
+ Version bump KDE SC 4.8.2
04 Apr 2012; Agostino Sarubbo <ago@gentoo.org> qyoto-4.8.1.ebuild:
Stable for amd64, wrt bug #409403
diff --git a/kde-base/qyoto/qyoto-4.8.2.ebuild b/kde-base/qyoto/qyoto-4.8.2.ebuild
new file mode 100644
index 000000000000..23a1547d5474
--- /dev/null
+++ b/kde-base/qyoto/qyoto-4.8.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/qyoto/qyoto-4.8.2.ebuild,v 1.1 2012/04/04 23:59:08 johu Exp $
+
+EAPI=4
+
+KDE_REQUIRED="never"
+KDE_SCM="git"
+inherit kde4-base mono
+
+DESCRIPTION="C# bindings for Qt"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug +phonon qscintilla webkit"
+
+DEPEND="
+ dev-lang/mono
+ $(add_kdebase_dep smokeqt 'opengl,phonon?,qscintilla?,webkit?')
+"
+RDEPEND="${DEPEND}"
+
+# Split from kdebindings-csharp in 4.7
+add_blocker kdebindings-csharp
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with phonon)
+ $(cmake-utils_use_disable qscintilla QScintilla)
+ $(cmake-utils_use_disable webkit QtWebKit)
+ )
+ kde4-base_src_configure
+}