summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2005-02-06 17:35:46 +0000
committerDan Armak <danarmak@gentoo.org>2005-02-06 17:35:46 +0000
commit843aae3274cfda51b0f36abb45cfb9825858f61c (patch)
treee3a6d4b84c59234a470355a25afce37716b2bc1d /kde-base/smoke
parentStable on ppc64 (diff)
downloadgentoo-2-843aae3274cfda51b0f36abb45cfb9825858f61c.tar.gz
gentoo-2-843aae3274cfda51b0f36abb45cfb9825858f61c.tar.bz2
gentoo-2-843aae3274cfda51b0f36abb45cfb9825858f61c.zip
the parallel make fix is still needed for beta2; see my comment in bugs.kde.org 92362
(Portage version: 2.0.51-r15)
Diffstat (limited to 'kde-base/smoke')
-rw-r--r--kde-base/smoke/smoke-3.4.0_beta2.ebuild15
1 files changed, 13 insertions, 2 deletions
diff --git a/kde-base/smoke/smoke-3.4.0_beta2.ebuild b/kde-base/smoke/smoke-3.4.0_beta2.ebuild
index 39add7e0e50c..e4a6260ecb7d 100644
--- a/kde-base/smoke/smoke-3.4.0_beta2.ebuild
+++ b/kde-base/smoke/smoke-3.4.0_beta2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/smoke/smoke-3.4.0_beta2.ebuild,v 1.1 2005/02/05 11:39:28 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/smoke/smoke-3.4.0_beta2.ebuild,v 1.2 2005/02/06 17:35:46 danarmak Exp $
KMNAME=kdebindings
KMEXTRACTONLY="kalyptus/kalyptus kalyptus/*.pm"
@@ -13,5 +13,16 @@ DESCRIPTION="Scripting Meta Object Kompiler Engine: a language-agnostic bindings
KEYWORDS="~x86"
IUSE=""
DEPEND="dev-lang/perl"
-PATCHES="$FILESDIR/no-gtk-glib-check.diff"
+PATCHES="$FILESDIR/no-gtk-glib-check.diff
+$FILESDIR/parallel-make.diff" # bugs.kde.org 92362, although that's closed the patch is still needed
+
+# enable-final works, but requires at least 1.5GB of RAM to complete without swapping,
+# so it's best to turn it off here. (I don't have that much RAM, so can't estimate
+# how much would be enough, but it's at least that much... --danarmak)
+src_compile() {
+ kde-meta_src_compile myconf
+ # override myconf's setting of enable-final
+ myconf="$myconf --disable-final"
+ kde-meta_src_compile configure make
+}