summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2014-07-16 17:41:08 +0000
committerJohannes Huber <johu@gentoo.org>2014-07-16 17:41:08 +0000
commitc9d9af7b4a2d35fabb1adf67a471ad2c1f09fc2f (patch)
tree94015d5f29e37019f20bdced917f52e9b11645da /kde-base/smokeqt/smokeqt-4.13.3.ebuild
parentAdd kde-workspace 4.11.11 SRC_URI, remove obsolete. (diff)
downloadgentoo-2-c9d9af7b4a2d35fabb1adf67a471ad2c1f09fc2f.tar.gz
gentoo-2-c9d9af7b4a2d35fabb1adf67a471ad2c1f09fc2f.tar.bz2
gentoo-2-c9d9af7b4a2d35fabb1adf67a471ad2c1f09fc2f.zip
Version bump KDE SC 4.13.3
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xF3CFD2BD)
Diffstat (limited to 'kde-base/smokeqt/smokeqt-4.13.3.ebuild')
-rw-r--r--kde-base/smokeqt/smokeqt-4.13.3.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/kde-base/smokeqt/smokeqt-4.13.3.ebuild b/kde-base/smokeqt/smokeqt-4.13.3.ebuild
new file mode 100644
index 000000000000..3212c73fd649
--- /dev/null
+++ b/kde-base/smokeqt/smokeqt-4.13.3.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/smokeqt/smokeqt-4.13.3.ebuild,v 1.1 2014/07/16 17:40:09 johu Exp $
+
+EAPI=5
+
+DECLARATIVE_REQUIRED="optional"
+MULTIMEDIA_REQUIRED="optional"
+QTHELP_REQUIRED="optional"
+OPENGL_REQUIRED="optional"
+KDE_REQUIRED="never"
+
+inherit kde4-base
+
+DESCRIPTION="Scripting Meta Object Kompiler Engine - Qt bindings"
+KEYWORDS=" ~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug +phonon qimageblitz qscintilla qwt webkit"
+HOMEPAGE="http://techbase.kde.org/Development/Languages/Smoke"
+
+# Maybe make more of Qt optional?
+DEPEND="
+ $(add_kdebase_dep smokegen)
+ dev-qt/qtcore:4
+ dev-qt/qtdbus:4
+ || ( ( >=dev-qt/qtgui-4.8.5:4 dev-qt/designer:4 ) <dev-qt/qtgui-4.8.5:4 )
+ dev-qt/qtscript:4
+ dev-qt/qtsql:4
+ dev-qt/qtsvg:4
+ dev-qt/qttest:4
+ phonon? ( >=media-libs/phonon-4.4.3 )
+ qimageblitz? ( >=media-libs/qimageblitz-0.0.4 )
+ qscintilla? ( x11-libs/qscintilla:= )
+ qwt? ( x11-libs/qwt:5[svg] )
+ webkit? ( dev-qt/qtwebkit:4 )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DDISABLE_Qt3Support=ON
+ -DWITH_QT3_SUPPORT=OFF
+ $(cmake-utils_use_disable declarative QtDeclarative)
+ $(cmake-utils_use_disable multimedia QtMultimedia)
+ $(cmake-utils_use_disable opengl QtOpenGL)
+ $(cmake-utils_use_with phonon)
+ $(cmake-utils_use_with qimageblitz QImageBlitz)
+ $(cmake-utils_use_with qscintilla QScintilla)
+ $(cmake-utils_use_disable qthelp QtHelp)
+ $(cmake-utils_use_disable qwt Qwt5)
+ $(cmake-utils_use_disable webkit QtWebKit)
+ )
+ kde4-base_src_configure
+}