summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2011-09-07 20:14:08 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2011-09-07 20:14:08 +0000
commit469c774bcd0309358560d5b77f5346fb8804f9bf (patch)
treece4119225d8c992262a6486b5bb41718a6a9529c /kde-base/smokeqt
parent[profiles] Update kde mask (diff)
downloadgentoo-2-469c774bcd0309358560d5b77f5346fb8804f9bf.tar.gz
gentoo-2-469c774bcd0309358560d5b77f5346fb8804f9bf.tar.bz2
gentoo-2-469c774bcd0309358560d5b77f5346fb8804f9bf.zip
[kde-base] Add KDE SC 4.7.1
(Portage version: 2.2.0_alpha54/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/smokeqt')
-rw-r--r--kde-base/smokeqt/ChangeLog7
-rw-r--r--kde-base/smokeqt/smokeqt-4.7.1.ebuild57
2 files changed, 63 insertions, 1 deletions
diff --git a/kde-base/smokeqt/ChangeLog b/kde-base/smokeqt/ChangeLog
index 707b09bcfa5b..01c674f2b828 100644
--- a/kde-base/smokeqt/ChangeLog
+++ b/kde-base/smokeqt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/smokeqt
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/smokeqt/ChangeLog,v 1.1 2011/07/27 14:04:29 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/smokeqt/ChangeLog,v 1.2 2011/09/07 20:13:42 alexxy Exp $
+
+*smokeqt-4.7.1 (07 Sep 2011)
+
+ 07 Sep 2011; Alexey Shvetsov <alexxy@gentoo.org> +smokeqt-4.7.1.ebuild:
+ Version bump KDE SC 4.7.1
*smokeqt-4.7.0 (27 Jul 2011)
diff --git a/kde-base/smokeqt/smokeqt-4.7.1.ebuild b/kde-base/smokeqt/smokeqt-4.7.1.ebuild
new file mode 100644
index 000000000000..3522e569e9eb
--- /dev/null
+++ b/kde-base/smokeqt/smokeqt-4.7.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/smokeqt/smokeqt-4.7.1.ebuild,v 1.1 2011/09/07 20:13:42 alexxy Exp $
+
+EAPI=4
+
+DECLARATIVE_REQUIRED="optional"
+MULTIMEDIA_REQUIRED="optional"
+QTHELP_REQUIRED="optional"
+OPENGL_REQUIRED="optional"
+KDE_REQUIRED="never"
+
+KDE_SCM="git"
+
+inherit kde4-base
+
+DESCRIPTION="Scripting Meta Object Kompiler Engine - Qt bindings"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +phonon qimageblitz qscintilla qwt webkit"
+
+# Maybe make more of Qt optional?
+DEPEND="
+ $(add_kdebase_dep smokegen)
+ x11-libs/qt-core:4
+ x11-libs/qt-dbus:4
+ x11-libs/qt-gui:4
+ x11-libs/qt-script:4
+ x11-libs/qt-sql:4
+ x11-libs/qt-svg:4
+ x11-libs/qt-test:4
+ phonon? ( >=media-libs/phonon-4.4.3 )
+ qimageblitz? ( >=media-libs/qimageblitz-0.0.4 )
+ qscintilla? ( x11-libs/qscintilla )
+ qwt? ( x11-libs/qwt:5 )
+ webkit? ( x11-libs/qt-webkit:4 )
+"
+RDEPEND="${DEPEND}"
+
+# Split in 4.7
+add_blocker smoke
+
+src_configure() {
+ mycmakeargs=(
+ -DDISABLE_Qt3Support=ON
+ -DWITH_QT3_SUPPORT=OFF
+ $(cmake-utils_use_disable declarative QtDeclarative)
+ $(cmake-utils_use_disable multimedia QtMultimedia)
+ $(cmake-utils_use_disable opengl QtOpenGL)
+ $(cmake-utils_use_with phonon)
+ $(cmake-utils_use_with qimageblitz QImageBlitz)
+ $(cmake-utils_use_with qscintilla QScintilla)
+ $(cmake-utils_use_disable qthelp QtHelp)
+ $(cmake-utils_use_disable qwt Qwt5)
+ $(cmake-utils_use_disable webkit QtWebKit)
+ )
+ kde4-base_src_configure
+}