summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2011-07-09 15:14:29 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2011-07-09 15:14:29 +0000
commit198ce394c73bbfe7e1f269f6e39a5a98cab823a2 (patch)
tree4491916cd89010371521f0c68a631a977483b823 /kde-base/solid
parentBump to an up-to-date version, and add maintainer (diff)
downloadgentoo-2-198ce394c73bbfe7e1f269f6e39a5a98cab823a2.tar.gz
gentoo-2-198ce394c73bbfe7e1f269f6e39a5a98cab823a2.tar.bz2
gentoo-2-198ce394c73bbfe7e1f269f6e39a5a98cab823a2.zip
[kde-base] Add KDE SC 4.6.5
(Portage version: 2.2.0_alpha43/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/solid')
-rw-r--r--kde-base/solid/ChangeLog7
-rw-r--r--kde-base/solid/solid-4.6.5.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/kde-base/solid/ChangeLog b/kde-base/solid/ChangeLog
index a9803565e69d..f8a75de81ba3 100644
--- a/kde-base/solid/ChangeLog
+++ b/kde-base/solid/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/solid
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/solid/ChangeLog,v 1.107 2011/07/06 20:05:32 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/solid/ChangeLog,v 1.108 2011/07/09 15:14:23 alexxy Exp $
+
+*solid-4.6.5 (09 Jul 2011)
+
+ 09 Jul 2011; Alexey Shvetsov <alexxy@gentoo.org> +solid-4.6.5.ebuild:
+ Version bump KDE SC 4.6.5
06 Jul 2011; Andreas K. Huettel <dilfridge@gentoo.org> -solid-4.6.2.ebuild:
Drop KDE 4.6.2
diff --git a/kde-base/solid/solid-4.6.5.ebuild b/kde-base/solid/solid-4.6.5.ebuild
new file mode 100644
index 000000000000..20fe687f0fae
--- /dev/null
+++ b/kde-base/solid/solid-4.6.5.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/solid/solid-4.6.5.ebuild,v 1.1 2011/07/09 15:14:23 alexxy Exp $
+
+EAPI=4
+
+KMNAME="kdebase-workspace"
+CPPUNIT_REQUIRED="test"
+inherit kde4-meta
+
+DESCRIPTION="Solid: the KDE hardware library"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="debug bluetooth networkmanager wicd"
+
+DEPEND="
+ networkmanager? ( >=net-misc/networkmanager-0.7 )
+ wicd? ( net-misc/wicd )
+"
+RDEPEND="${DEPEND}
+ $(add_kdebase_dep solid-runtime)
+"
+
+PDEPEND="bluetooth? ( net-wireless/bluedevil )"
+
+KMEXTRA="
+ libs/solid/
+"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with networkmanager NetworkManager)
+ $(cmake-utils_use_build wicd)
+ )
+
+ kde4-meta_src_configure
+}