summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2011-07-09 15:14:29 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2011-07-09 15:14:29 +0000
commit198ce394c73bbfe7e1f269f6e39a5a98cab823a2 (patch)
tree4491916cd89010371521f0c68a631a977483b823 /kde-base/step
parentBump to an up-to-date version, and add maintainer (diff)
downloadgentoo-2-198ce394c73bbfe7e1f269f6e39a5a98cab823a2.tar.gz
gentoo-2-198ce394c73bbfe7e1f269f6e39a5a98cab823a2.tar.bz2
gentoo-2-198ce394c73bbfe7e1f269f6e39a5a98cab823a2.zip
[kde-base] Add KDE SC 4.6.5
(Portage version: 2.2.0_alpha43/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/step')
-rw-r--r--kde-base/step/ChangeLog7
-rw-r--r--kde-base/step/step-4.6.5.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/kde-base/step/ChangeLog b/kde-base/step/ChangeLog
index 93d54e513157..7186f63ddf7c 100644
--- a/kde-base/step/ChangeLog
+++ b/kde-base/step/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/step
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/step/ChangeLog,v 1.78 2011/07/06 20:05:35 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/step/ChangeLog,v 1.79 2011/07/09 15:14:23 alexxy Exp $
+
+*step-4.6.5 (09 Jul 2011)
+
+ 09 Jul 2011; Alexey Shvetsov <alexxy@gentoo.org> +step-4.6.5.ebuild:
+ Version bump KDE SC 4.6.5
06 Jul 2011; Andreas K. Huettel <dilfridge@gentoo.org> -step-4.6.2.ebuild:
Drop KDE 4.6.2
diff --git a/kde-base/step/step-4.6.5.ebuild b/kde-base/step/step-4.6.5.ebuild
new file mode 100644
index 000000000000..c9b798d5d68f
--- /dev/null
+++ b/kde-base/step/step-4.6.5.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/step/step-4.6.5.ebuild,v 1.1 2011/07/09 15:14:23 alexxy Exp $
+
+EAPI=4
+
+KDE_HANDBOOK="optional"
+KDE_SCM="git"
+if [[ ${PV} == *9999 ]]; then
+ kde_eclass="kde4-base"
+else
+ KMNAME="kdeedu"
+ kde_eclass="kde4-meta"
+fi
+inherit ${kde_eclass}
+
+DESCRIPTION="The KDE physics simulator"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug +gsl +qalculate"
+
+DEPEND="
+ >=dev-cpp/eigen-2.0.3:2
+ sci-libs/cln
+ >=sci-mathematics/gmm-3.0
+ gsl? ( >=sci-libs/gsl-1.9-r1 )
+ qalculate? ( >=sci-libs/libqalculate-0.9.5 )
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.3.2-solaris.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with gsl)
+ $(cmake-utils_use_with qalculate)
+ )
+ ${kde_eclass}_src_configure
+}