summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Chatzimichos <tampakrap@gentoo.org>2011-01-10 11:53:50 +0000
committerTheo Chatzimichos <tampakrap@gentoo.org>2011-01-10 11:53:50 +0000
commite34c3a2f03ed8d4afca61c9fe8544134d0418962 (patch)
tree0b1689a47d15be3b02dbcefedaa1c6034759911a /kde-base/superkaramba/superkaramba-4.5.5.ebuild
parentBug #351274 - Mask prefix USE flag. (diff)
downloadgentoo-2-e34c3a2f03ed8d4afca61c9fe8544134d0418962.tar.gz
gentoo-2-e34c3a2f03ed8d4afca61c9fe8544134d0418962.tar.bz2
gentoo-2-e34c3a2f03ed8d4afca61c9fe8544134d0418962.zip
Version bump KDE SC 4.5.5
Diffstat (limited to 'kde-base/superkaramba/superkaramba-4.5.5.ebuild')
-rw-r--r--kde-base/superkaramba/superkaramba-4.5.5.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/kde-base/superkaramba/superkaramba-4.5.5.ebuild b/kde-base/superkaramba/superkaramba-4.5.5.ebuild
new file mode 100644
index 000000000000..2acb4734088b
--- /dev/null
+++ b/kde-base/superkaramba/superkaramba-4.5.5.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/superkaramba/superkaramba-4.5.5.ebuild,v 1.1 2011/01/10 11:53:49 tampakrap Exp $
+
+EAPI="3"
+
+KMNAME="kdeutils"
+PYTHON_DEPEND="python? 2"
+inherit python kde4-meta
+
+DESCRIPTION="A tool to create interactive applets for the KDE desktop."
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug python"
+
+DEPEND="
+ media-libs/qimageblitz
+ python? ( $(add_kdebase_dep pykde4) )
+"
+RDEPEND="${DEPEND}
+ python? ( $(add_kdebase_dep krosspython) )
+"
+
+PATCHES=( "${FILESDIR}/${PN}-as-needed.patch" )
+
+pkg_setup() {
+ kde4-meta_pkg_setup
+ python_set_active_version 2
+}
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with python PythonLibs)
+ )
+
+ kde4-meta_src_configure
+}