summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2011-11-02 20:48:23 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2011-11-02 20:48:23 +0000
commit07a5746d946658a2d5d39b2008bdad2d2b2e127c (patch)
treea949b9dad962aee8c01f5011d077283fc50836d4 /kde-base/superkaramba
parent[profiles/arch/powerpc] Update kde mask (diff)
downloadgentoo-2-07a5746d946658a2d5d39b2008bdad2d2b2e127c.tar.gz
gentoo-2-07a5746d946658a2d5d39b2008bdad2d2b2e127c.tar.bz2
gentoo-2-07a5746d946658a2d5d39b2008bdad2d2b2e127c.zip
[kde-base] KDE SC 4.7.3
(Portage version: 2.2.0_alpha72/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/superkaramba')
-rw-r--r--kde-base/superkaramba/ChangeLog7
-rw-r--r--kde-base/superkaramba/superkaramba-4.7.3.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/kde-base/superkaramba/ChangeLog b/kde-base/superkaramba/ChangeLog
index eda01f357252..e0ac346822af 100644
--- a/kde-base/superkaramba/ChangeLog
+++ b/kde-base/superkaramba/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/superkaramba
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/superkaramba/ChangeLog,v 1.179 2011/10/28 20:04:53 abcd Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/superkaramba/ChangeLog,v 1.180 2011/11/02 20:48:04 alexxy Exp $
+
+*superkaramba-4.7.3 (02 Nov 2011)
+
+ 02 Nov 2011; Alexey Shvetsov <alexxy@gentoo.org> +superkaramba-4.7.3.ebuild:
+ Version bump KDE SC 4.7.3
*superkaramba-4.7.2-r1 (28 Oct 2011)
diff --git a/kde-base/superkaramba/superkaramba-4.7.3.ebuild b/kde-base/superkaramba/superkaramba-4.7.3.ebuild
new file mode 100644
index 000000000000..c9cde87866d5
--- /dev/null
+++ b/kde-base/superkaramba/superkaramba-4.7.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/superkaramba/superkaramba-4.7.3.ebuild,v 1.1 2011/11/02 20:48:04 alexxy Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="python? 2"
+KDE_SCM="git"
+if [[ ${PV} == *9999 ]]; then
+ kde_eclass="kde4-base"
+else
+ KMNAME="kdeutils"
+ kde_eclass="kde4-meta"
+fi
+inherit python ${kde_eclass}
+
+DESCRIPTION="A tool to create interactive applets for the KDE desktop."
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug python"
+
+DEPEND="
+ media-libs/qimageblitz
+ python? ( $(add_kdebase_dep pykde4) )
+"
+RDEPEND="${DEPEND}
+ python? ( $(add_kdebase_dep krosspython) )
+"
+
+PATCHES=( "${FILESDIR}/${PN}-as-needed.patch" )
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+ ${kde_eclass}_pkg_setup
+}
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with python PythonLibs)
+ )
+
+ ${kde_eclass}_src_configure
+}