summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Heinlein <keytoaster@gentoo.org>2008-10-02 11:56:19 +0000
committerTobias Heinlein <keytoaster@gentoo.org>2008-10-02 11:56:19 +0000
commit341f59f44e2d541aa3c005c05953ee657105c240 (patch)
tree75d1e2c110f3e2b818c5c2808d9ad6f90c94a380 /kde-base
parentSparc stable --- Bug #238731 --- Immediate stable because of missed problems (diff)
downloadgentoo-2-341f59f44e2d541aa3c005c05953ee657105c240.tar.gz
gentoo-2-341f59f44e2d541aa3c005c05953ee657105c240.tar.bz2
gentoo-2-341f59f44e2d541aa3c005c05953ee657105c240.zip
Added kdelibs-4.1.2 from the kde-testing overlay.
(Portage version: 2.2_rc11/cvs/Linux 2.6.26-gentoo-r1 x86_64)
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/kdelibs/ChangeLog8
-rw-r--r--kde-base/kdelibs/kdelibs-4.1.2.ebuild191
2 files changed, 198 insertions, 1 deletions
diff --git a/kde-base/kdelibs/ChangeLog b/kde-base/kdelibs/ChangeLog
index 3fdf6acc0988..9833fc2f8568 100644
--- a/kde-base/kdelibs/ChangeLog
+++ b/kde-base/kdelibs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kdelibs
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/ChangeLog,v 1.540 2008/09/15 14:42:21 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/ChangeLog,v 1.541 2008/10/02 11:56:19 keytoaster Exp $
+
+*kdelibs-4.1.2 (02 Oct 2008)
+
+ 02 Oct 2008; Tobias Heinlein <keytoaster@gentoo.org>
+ +kdelibs-4.1.2.ebuild:
+ Added kdelibs-4.1.2 from the kde-testing overlay.
15 Sep 2008; Carsten Lohrke <carlo@gentoo.org> kdelibs-3.5.10.ebuild:
Remove the kdebindings-meta blocker, which went more or less accidentally in
diff --git a/kde-base/kdelibs/kdelibs-4.1.2.ebuild b/kde-base/kdelibs/kdelibs-4.1.2.ebuild
new file mode 100644
index 000000000000..554bf1794451
--- /dev/null
+++ b/kde-base/kdelibs/kdelibs-4.1.2.ebuild
@@ -0,0 +1,191 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/kdelibs-4.1.2.ebuild,v 1.1 2008/10/02 11:56:19 keytoaster Exp $
+
+EAPI="2"
+
+CPPUNIT_REQUIRED="optional"
+OPENGL_REQUIRED="optional"
+inherit kde4-base
+
+DESCRIPTION="KDE libraries needed by all KDE programs."
+HOMEPAGE="http://www.kde.org/"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="3dnow acl alsa altivec bindist +bzip2 debug doc fam htmlhandbook jpeg2k
+kerberos mmx nls openexr +semantic-desktop spell sse sse2 ssl zeroconf"
+LICENSE="LGPL-2.1"
+RESTRICT="test"
+
+COMMONDEPEND="
+ !<kde-base/kdebase-3.5.7-r6
+ !<kde-base/kdebase-startkde-3.5.7-r1
+ !=kde-base/kdebase-3.5.8
+ !=kde-base/kdebase-3.5.8-r1
+ !=kde-base/kdebase-3.5.8-r2
+ !=kde-base/kdebase-startkde-3.5.8
+ !kdeprefix? ( !<=kde-misc/kdnssd-avahi-0.1.2:0 )
+ >=app-misc/strigi-0.5.9
+ >=dev-libs/libxml2-2.6.6
+ >=dev-libs/libxslt-1.1.17
+ media-libs/fontconfig
+ >=media-libs/freetype-2
+ media-libs/giflib
+ media-libs/jpeg
+ media-libs/libpng
+ >=media-sound/phonon-4.2.0
+ >=sys-apps/dbus-0.91[X]
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXcursor
+ x11-libs/libXdmcp
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXft
+ x11-libs/libXpm
+ x11-libs/libXrender
+ x11-libs/libXtst
+ >=x11-misc/shared-mime-info-0.20
+ acl? ( kernel_linux? ( sys-apps/acl ) )
+ alsa? ( >=media-libs/alsa-lib-1.0.14a[midi] )
+ fam? ( virtual/fam )
+ jpeg2k? ( media-libs/jasper )
+ kerberos? ( virtual/krb5 )
+ nls? ( virtual/libintl )
+ openexr? ( >=media-libs/openexr-1.2.2-r2 media-libs/ilmbase )
+ opengl? ( virtual/opengl )
+ >=dev-libs/libpcre-4.5
+ semantic-desktop? ( >=dev-libs/soprano-2.1 )
+ spell? ( app-text/aspell app-dicts/aspell-en app-text/enchant )
+ ssl? ( >=dev-libs/openssl-0.9.7d )
+ zeroconf? ( || ( net-dns/avahi[mdnsresponder-compat]
+ !bindist? ( net-misc/mDNSResponder ) ) )
+"
+
+DEPEND="${COMMONDEPEND}
+ doc? ( app-doc/doxygen )
+ sys-devel/gettext
+"
+
+RDEPEND="${COMMONDEPEND}
+ x11-apps/rgb
+ x11-apps/iceauth
+"
+
+PATCHES=( "${FILESDIR}/${PN}-4.1.1-cmake-modules.patch" )
+
+src_configure() {
+ if use zeroconf; then
+ if has_version net-dns/avahi; then
+ mycmakeargs="${mycmakeargs} -DWITH_Avahi=ON -DWITH_DNSSD=OFF"
+ elif has_version net-misc/mDNSResponder; then
+ mycmakeargs="${mycmakeargs} -DWITH_Avahi=OFF -DWITH_DNSSD=ON"
+ else
+ die "USE=\"zeroconf\" enabled but neither net-dns/avahi nor net-misc/mDNSResponder were found."
+ fi
+ fi
+ if use kdeprefix; then
+ HME=".kde${SLOT}"
+ else
+ HME=".kde4"
+ fi
+ mycmakeargs="${mycmakeargs}
+ -DWITH_HSPELL=OFF
+ -DKDE_DEFAULT_HOME=${HME}
+ $(cmake-utils_has 3dnow X86_3DNOW)
+ $(cmake-utils_has altivec PPC_ALTIVEC)
+ $(cmake-utils_has mmx X86_MMX)
+ $(cmake-utils_has sse X86_SSE)
+ $(cmake-utils_has sse2 X86_SSE2)
+ $(cmake-utils_use_with acl ACL)
+ $(cmake-utils_use_with alsa Alsa)
+ $(cmake-utils_use_with bzip2 BZip2)
+ $(cmake-utils_use_with fam FAM)
+ $(cmake-utils_use_with jpeg2k Jasper)
+ $(cmake-utils_use_with kerberos GSSAPI)
+ $(cmake-utils_use_with nls Libintl)
+ $(cmake-utils_use_with openexr OpenEXR)
+ $(cmake-utils_use_with opengl OpenGL)
+ $(cmake-utils_use_with semantic-desktop Soprano)
+ $(cmake-utils_use_with spell ASPELL)
+ $(cmake-utils_use_with spell ENCHANT)
+ $(cmake-utils_use_with ssl OpenSSL)
+ "
+ kde4-base_src_configure
+}
+
+src_compile() {
+ kde4-base_src_compile
+
+ # The building of apidox is not managed anymore by the build system
+ if use doc; then
+ einfo "Building API documentation"
+ cd "${S}"/doc/api/
+ ./doxygen.sh "${S}" || die "APIDOX generation failed"
+ fi
+}
+
+src_install() {
+ kde4-base_src_install
+
+ if use doc; then
+ einfo "Installing API documentation. This could take a bit of time."
+ cd "${S}"/doc/api/
+ docinto /HTML/en/kdelibs-apidox
+ dohtml -r ${P}-apidocs/* || die "Install phase of KDE4 API Documentation failed"
+ fi
+
+ dodir /etc/env.d
+ dodir /etc/revdep-rebuild
+
+ # List all the multilib libdirs
+ local _libdir _libdirs
+ for _libdir in $(get_all_libdirs); do
+ _libdirs="${_libdirs}:${PREFIX}/${_libdir}"
+ done
+ _libdirs=${_libdirs#:}
+
+ cat <<-EOF > "${T}"/43kdepaths-${SLOT} # number goes down with version bump
+ PATH="${PREFIX}/bin"
+ ROOTPATH="${PREFIX}/sbin:${PREFIX}/bin"
+ LDPATH="${_libdirs}"
+ MANPATH="${PREFIX}/share/man"
+ CONFIG_PROTECT="${PREFIX}/share/config ${PREFIX}/env ${PREFIX}/shutdown /usr/share/config"
+ KDEDIRS="/usr:/usr/local:${PREFIX}"
+ #KDE_IS_PRELINKED=1
+ XDG_DATA_DIRS="/usr/share:${PREFIX}/share:/usr/local/share"
+ COLON_SEPARATED="XDG_DATA_DIRS"
+ EOF
+ doenvd "${T}"/43kdepaths-${SLOT}
+
+ # make sure 'source /etc/profile' doesn't hose the PATH
+ dodir /etc/profile.d
+ cat <<-'EOF' > "${D}"/etc/profile.d/44kdereorderpaths-${SLOT}.sh
+ if [ -n "${KDEDIR}" ]; then
+ export PATH=${KDEDIR}/bin:$(echo ${PATH} | sed "s#${KDEDIR}/s\?bin:##g")
+ export ROOTPATH=${KDEDIR}/sbin:${KDEDIR}/bin:$(echo ${PATH} | sed "s#${KDEDIR}/s\?bin:##g")
+ fi
+ EOF
+
+ cat <<-EOF > "${D}/etc/revdep-rebuild/50-kde-${SLOT}"
+ SEARCH_DIRS="${PREFIX}/bin ${PREFIX}/lib*"
+ EOF
+ # Ensure that the correct permissions are present on ${KDEDIR}/share/config
+ chmod 755 ${KDEDIR}/share/config
+
+}
+
+pkg_postinst() {
+ if use zeroconf; then
+ echo
+ elog "To make zeroconf support available in KDE make sure that the 'mdnsd' daemon"
+ elog "is running. Make sure also that multicast dns lookups are enabled by editing"
+ elog "the 'hosts:' line in /etc/nsswitch.conf to include 'mdns', e.g.:"
+ elog " hosts: files mdns dns"
+ echo
+ fi
+
+ kde4-base_pkg_postinst
+}