summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2005-10-13 15:08:44 +0000
committerDan Armak <danarmak@gentoo.org>2005-10-13 15:08:44 +0000
commit5e701f1b73cdb2b79272e032438917a4ee0d7e32 (patch)
tree3414a6e8763136a9831e42cd9a076c260192a5bb /kde-base
parentMasked pmount (diff)
downloadgentoo-2-5e701f1b73cdb2b79272e032438917a4ee0d7e32.tar.gz
gentoo-2-5e701f1b73cdb2b79272e032438917a4ee0d7e32.tar.bz2
gentoo-2-5e701f1b73cdb2b79272e032438917a4ee0d7e32.zip
fix compilation: added missing dep on kdemultimedia-arts and KMCOPYLIB instructions for USE=arts.
(Portage version: 2.0.53_rc5)
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/akode/ChangeLog6
-rw-r--r--kde-base/akode/Manifest2
-rw-r--r--kde-base/akode/akode-3.4.3.ebuild6
3 files changed, 10 insertions, 4 deletions
diff --git a/kde-base/akode/ChangeLog b/kde-base/akode/ChangeLog
index 35b48dba3af7..df0bd24fc5d6 100644
--- a/kde-base/akode/ChangeLog
+++ b/kde-base/akode/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for kde-base/akode
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/akode/ChangeLog,v 1.21 2005/10/13 00:09:49 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/akode/ChangeLog,v 1.22 2005/10/13 15:08:44 danarmak Exp $
+
+ 13 Oct 2005; Dan Armak <danarmak@gentoo.org> akode-3.4.3.ebuild:
+ Added missing dep on kdemultimedia-arts and KMCOPYLIB instructions for
+ USE=arts.
*akode-3.4.3 (13 Oct 2005)
diff --git a/kde-base/akode/Manifest b/kde-base/akode/Manifest
index c23654696012..d400c8319257 100644
--- a/kde-base/akode/Manifest
+++ b/kde-base/akode/Manifest
@@ -2,7 +2,7 @@ MD5 bb0f790818142f6756fd972f1d04069f ChangeLog 3108
MD5 a443791437dd7163afdf38c26b27cf46 akode-3.4.1-r1.ebuild 1239
MD5 ea2902384b1afd69066f6a3f6d30c5a9 akode-3.4.1.ebuild 1118
MD5 4119db129be52ce806e5f589476ec15c akode-3.4.2.ebuild 1123
-MD5 8e30703485b48b723b21d9f2bb66d68a akode-3.4.3.ebuild 1125
+MD5 96e9f430c95e65979626b44d4c2f62a9 akode-3.4.3.ebuild 1223
MD5 5503be4dfa64fd0d3bf2165747a97fb0 files/digest-akode-3.4.1 227
MD5 5503be4dfa64fd0d3bf2165747a97fb0 files/digest-akode-3.4.1-r1 227
MD5 453075362e3201c7f44fea430afec5d5 files/digest-akode-3.4.2 308
diff --git a/kde-base/akode/akode-3.4.3.ebuild b/kde-base/akode/akode-3.4.3.ebuild
index 842d2034768e..19b1a0c8b8a2 100644
--- a/kde-base/akode/akode-3.4.3.ebuild
+++ b/kde-base/akode/akode-3.4.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/akode/akode-3.4.3.ebuild,v 1.1 2005/10/13 00:09:49 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/akode/akode-3.4.3.ebuild,v 1.2 2005/10/13 15:08:44 danarmak Exp $
KMNAME=kdemultimedia
MAXKDEVER=$PV
@@ -10,7 +10,7 @@ inherit kde-meta
DESCRIPTION="aRts plugins for various formats"
KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
IUSE="alsa arts flac jack mp3 speex vorbis"
-DEPEND="arts? ( $(deprange $PV $MAXKDEVER kde-base/arts) )
+DEPEND="arts? ( $(deprange $PV $MAXKDEVER kde-base/arts) $(deprange 3.4.1 $MAXKDEVER kde-base/kdemultimedia-arts) )
flac? ( media-libs/flac )
vorbis? ( media-sound/vorbis-tools )
speex? ( media-libs/speex )
@@ -23,6 +23,8 @@ DEPEND="arts? ( $(deprange $PV $MAXKDEVER kde-base/arts) )
# MISSING: polypaudio - no gentoo ebuild as yet
# TODO: configure needs a pkg-config file for media-sound/jack to detect it
+KMCOPYLIB="libartsbuilder arts/runtime"
+
src_compile() {
use speex && myconf="$myconf --with-extra-includes=/usr/include/speex"
myconf="$myconf $(use_with mp3 libmad) $(use_with flac) $(use_with speex)