summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2011-10-18 23:09:59 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2011-10-18 23:09:59 +0000
commit753ebf7ae787bdd79d7b5419e83edd92f4edcedc (patch)
treeb0e3ce179666adefacc6a5a7f99ad65180b4dbe1 /kde-base
parentRe-added 4.7 translations, bug 387513 (diff)
downloadgentoo-2-753ebf7ae787bdd79d7b5419e83edd92f4edcedc.tar.gz
gentoo-2-753ebf7ae787bdd79d7b5419e83edd92f4edcedc.tar.bz2
gentoo-2-753ebf7ae787bdd79d7b5419e83edd92f4edcedc.zip
vendor-perl, not site-perl, bug 387477
(Portage version: 2.1.10.28/cvs/Linux x86_64)
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/perlqt/ChangeLog10
-rw-r--r--kde-base/perlqt/files/perlqt-4.7.2-vendor.patch12
-rw-r--r--kde-base/perlqt/perlqt-4.7.1-r1.ebuild46
-rw-r--r--kde-base/perlqt/perlqt-4.7.2-r1.ebuild46
4 files changed, 113 insertions, 1 deletions
diff --git a/kde-base/perlqt/ChangeLog b/kde-base/perlqt/ChangeLog
index e56794938710..ca3d7256826b 100644
--- a/kde-base/perlqt/ChangeLog
+++ b/kde-base/perlqt/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for kde-base/perlqt
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/perlqt/ChangeLog,v 1.6 2011/10/15 17:26:13 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/perlqt/ChangeLog,v 1.7 2011/10/18 23:09:59 dilfridge Exp $
+
+*perlqt-4.7.2-r1 (18 Oct 2011)
+*perlqt-4.7.1-r1 (18 Oct 2011)
+
+ 18 Oct 2011; Andreas K. Huettel <dilfridge@gentoo.org>
+ +perlqt-4.7.1-r1.ebuild, +perlqt-4.7.2-r1.ebuild,
+ +files/perlqt-4.7.2-vendor.patch:
+ vendor-perl, not site-perl, bug 387477
15 Oct 2011; Andreas K. Huettel <dilfridge@gentoo.org> -perlqt-4.7.0.ebuild:
Drop KDE 4.7.0
diff --git a/kde-base/perlqt/files/perlqt-4.7.2-vendor.patch b/kde-base/perlqt/files/perlqt-4.7.2-vendor.patch
new file mode 100644
index 000000000000..33205601123e
--- /dev/null
+++ b/kde-base/perlqt/files/perlqt-4.7.2-vendor.patch
@@ -0,0 +1,12 @@
+diff -ruN perlqt-4.7.2.orig/CMakeLists.txt perlqt-4.7.2/CMakeLists.txt
+--- perlqt-4.7.2.orig/CMakeLists.txt 2011-05-20 22:33:46.000000000 +0200
++++ perlqt-4.7.2/CMakeLists.txt 2011-10-19 01:03:04.040639531 +0200
+@@ -38,7 +38,7 @@
+ add_definitions(-DDEBUG)
+
+ include (FindPerlMore)
+-set(CUSTOM_PERL_SITE_ARCH_DIR ${PERL_SITE_ARCH_DIR} CACHE DIR "Custom installation directory for perl binary extension")
++set(CUSTOM_PERL_SITE_ARCH_DIR ${PERL_VENDOR_ARCH_DIR} CACHE DIR "Custom installation directory for perl binary extension")
+
+ # the RPATH to be used when installing, but only if it's not a system directory
+ GET_FILENAME_COMPONENT(SMOKE_LIB_DIR ${SMOKE_BASE_LIBRARY} PATH)
diff --git a/kde-base/perlqt/perlqt-4.7.1-r1.ebuild b/kde-base/perlqt/perlqt-4.7.1-r1.ebuild
new file mode 100644
index 000000000000..361a202d31e1
--- /dev/null
+++ b/kde-base/perlqt/perlqt-4.7.1-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/perlqt/perlqt-4.7.1-r1.ebuild,v 1.1 2011/10/18 23:09:59 dilfridge Exp $
+
+EAPI=4
+
+DECLARATIVE_REQUIRED="optional"
+MULTIMEDIA_REQUIRED="optional"
+OPENGL_REQUIRED="optional"
+QTHELP_REQUIRED="optional"
+KDE_REQUIRED="never"
+KDE_SCM="git"
+inherit kde4-base
+
+DESCRIPTION="Qt Perl bindings"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug phonon qimageblitz qscintilla qwt test webkit"
+
+RDEPEND="
+ >=dev-lang/perl-5.10.1
+ $(add_kdebase_dep smokeqt 'declarative?,multimedia?,opengl?,phonon?,qimageblitz?,qscintilla?,qthelp?,qwt?,webkit?')
+"
+DEPEND="${RDEPEND}
+ test? ( dev-perl/List-MoreUtils )
+"
+
+# Split from kdebindings-perl in 4.7
+add_blocker kdebindings-perl
+
+PATCHES=( "${FILESDIR}/${PN}-4.7.2-vendor.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ -DDISABLE_Qt3Support=ON
+ $(cmake-utils_use_disable declarative QtDeclarative)
+ $(cmake-utils_use_disable multimedia QtMultimedia)
+ $(cmake-utils_use_disable opengl QtOpenGL)
+ $(cmake-utils_use_with phonon)
+ $(cmake-utils_use_with qimageblitz QImageBlitz)
+ $(cmake-utils_use_with qscintilla QScintilla)
+ $(cmake-utils_use_disable qthelp QtHelp)
+ $(cmake-utils_use_disable qwt)
+ $(cmake-utils_use_disable webkit QtWebKit)
+ )
+ kde4-base_src_configure
+}
diff --git a/kde-base/perlqt/perlqt-4.7.2-r1.ebuild b/kde-base/perlqt/perlqt-4.7.2-r1.ebuild
new file mode 100644
index 000000000000..a23dfd7e40b2
--- /dev/null
+++ b/kde-base/perlqt/perlqt-4.7.2-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/perlqt/perlqt-4.7.2-r1.ebuild,v 1.1 2011/10/18 23:09:59 dilfridge Exp $
+
+EAPI=4
+
+DECLARATIVE_REQUIRED="optional"
+MULTIMEDIA_REQUIRED="optional"
+OPENGL_REQUIRED="optional"
+QTHELP_REQUIRED="optional"
+KDE_REQUIRED="never"
+KDE_SCM="git"
+inherit kde4-base
+
+DESCRIPTION="Qt Perl bindings"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug phonon qimageblitz qscintilla qwt test webkit"
+
+RDEPEND="
+ >=dev-lang/perl-5.10.1
+ $(add_kdebase_dep smokeqt 'declarative?,multimedia?,opengl?,phonon?,qimageblitz?,qscintilla?,qthelp?,qwt?,webkit?')
+"
+DEPEND="${RDEPEND}
+ test? ( dev-perl/List-MoreUtils )
+"
+
+# Split from kdebindings-perl in 4.7
+add_blocker kdebindings-perl
+
+PATCHES=( "${FILESDIR}/${PN}-4.7.2-vendor.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ -DDISABLE_Qt3Support=ON
+ $(cmake-utils_use_disable declarative QtDeclarative)
+ $(cmake-utils_use_disable multimedia QtMultimedia)
+ $(cmake-utils_use_disable opengl QtOpenGL)
+ $(cmake-utils_use_with phonon)
+ $(cmake-utils_use_with qimageblitz QImageBlitz)
+ $(cmake-utils_use_with qscintilla QScintilla)
+ $(cmake-utils_use_disable qthelp QtHelp)
+ $(cmake-utils_use_disable qwt)
+ $(cmake-utils_use_disable webkit QtWebKit)
+ )
+ kde4-base_src_configure
+}