summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-09-12 00:00:23 +0000
committerJohannes Huber <johu@gentoo.org>2012-09-12 00:00:23 +0000
commita761b0efa9d4ab4f49bcbf9d36a33d39e1de19ad (patch)
tree407a1277404f8bea91e8cd80f7bfb460c114ba7e /kde-base
parentUnmask telepathy-qt-0.9.3 and KDE telepathy 0.5.0 as issues with test use fla... (diff)
downloadgentoo-2-a761b0efa9d4ab4f49bcbf9d36a33d39e1de19ad.tar.gz
gentoo-2-a761b0efa9d4ab4f49bcbf9d36a33d39e1de19ad.tar.bz2
gentoo-2-a761b0efa9d4ab4f49bcbf9d36a33d39e1de19ad.zip
Add upstream patch to fix build with gcc44 and clang spotted by Mr. Anderson <walch.martin@web.de> amd Andreas Sturmlechner <andreas.sturmlechner@gmail.com> wrt bug #434340.
(Portage version: 2.2.0_alpha125/cvs/Linux x86_64)
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/nepomuk-core/ChangeLog8
-rw-r--r--kde-base/nepomuk-core/files/nepomuk-core-4.9.1-gcc44.patch29
-rw-r--r--kde-base/nepomuk-core/nepomuk-core-4.9.1.ebuild4
3 files changed, 39 insertions, 2 deletions
diff --git a/kde-base/nepomuk-core/ChangeLog b/kde-base/nepomuk-core/ChangeLog
index 1714bcea8b28..417ec409d2e0 100644
--- a/kde-base/nepomuk-core/ChangeLog
+++ b/kde-base/nepomuk-core/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/nepomuk-core
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/nepomuk-core/ChangeLog,v 1.5 2012/09/04 18:45:09 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/nepomuk-core/ChangeLog,v 1.6 2012/09/12 00:00:23 johu Exp $
+
+ 12 Sep 2012; Johannes Huber <johu@gentoo.org>
+ +files/nepomuk-core-4.9.1-gcc44.patch, nepomuk-core-4.9.1.ebuild:
+ Add upstream patch to fix build with gcc44 and clang spotted by Mr. Anderson
+ <walch.martin@web.de> amd Andreas Sturmlechner
+ <andreas.sturmlechner@gmail.com> wrt bug #434340.
*nepomuk-core-4.9.1 (04 Sep 2012)
diff --git a/kde-base/nepomuk-core/files/nepomuk-core-4.9.1-gcc44.patch b/kde-base/nepomuk-core/files/nepomuk-core-4.9.1-gcc44.patch
new file mode 100644
index 000000000000..faec792d1d35
--- /dev/null
+++ b/kde-base/nepomuk-core/files/nepomuk-core-4.9.1-gcc44.patch
@@ -0,0 +1,29 @@
+commit c910021ee37ff0356eddbc3df725f8f3f598d019
+Author: Raphael Kubo da Costa <rakuco@FreeBSD.org>
+Date: Mon Sep 3 18:23:59 2012 -0300
+
+ Fix the build with gcc 4.2 and clang.
+
+ The Nepomuk2 and Nepomuk2::Query namespaces are included, which causes some
+ ambiguity in the `query' argument of intiWatcherForQuery(), which can be
+ expanded as both Nepomuk2::Query::Query (from libnepomukcore/query/query.h)
+ or Nepomuk2::Query (from libnepomukcore/query/negationterm.h).
+
+ Meanwhile, this was fixed in master by someone else who didn't fix the
+ KDE/4.9 branch (see eaeae8d).
+
+ CCMAIL: nepomuk@kde.org
+
+diff --git a/services/queryservice/folder.cpp b/services/queryservice/folder.cpp
+index b7125cb..b4ab5c6 100644
+--- a/services/queryservice/folder.cpp
++++ b/services/queryservice/folder.cpp
+@@ -101,7 +101,7 @@ namespace {
+ }
+ }
+
+- void intiWatcherForQuery(ResourceWatcher* watcher, const Query::Query& query) {
++ void intiWatcherForQuery(ResourceWatcher* watcher, const Nepomuk2::Query::Query& query) {
+ // The empty property is for comparison terms which do not have a property
+ // in that case we want to monitor all properties
+ bool emptyProperty = false;
diff --git a/kde-base/nepomuk-core/nepomuk-core-4.9.1.ebuild b/kde-base/nepomuk-core/nepomuk-core-4.9.1.ebuild
index c539f205e48a..1035eca3c1eb 100644
--- a/kde-base/nepomuk-core/nepomuk-core-4.9.1.ebuild
+++ b/kde-base/nepomuk-core/nepomuk-core-4.9.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/nepomuk-core/nepomuk-core-4.9.1.ebuild,v 1.1 2012/09/04 18:45:09 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/nepomuk-core/nepomuk-core-4.9.1.ebuild,v 1.2 2012/09/12 00:00:23 johu Exp $
EAPI=4
@@ -20,3 +20,5 @@ add_blocker nepomuk '<4.8.80'
RESTRICT="test"
# bug 392989
+
+PATCHES=( "${FILESDIR}/${P}-gcc44.patch" )