summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Chatzimichos <tampakrap@gentoo.org>2010-09-06 02:02:56 +0000
committerTheo Chatzimichos <tampakrap@gentoo.org>2010-09-06 02:02:56 +0000
commitd7cfcdcb1bdfd168fbf982ef4fbde8861ccc21eb (patch)
tree719bee94c0f80c992729896f625ec976484e91a2 /kde-base
parentVersion bump KDE SC 4.5.1 (diff)
downloadgentoo-2-d7cfcdcb1bdfd168fbf982ef4fbde8861ccc21eb.tar.gz
gentoo-2-d7cfcdcb1bdfd168fbf982ef4fbde8861ccc21eb.tar.bz2
gentoo-2-d7cfcdcb1bdfd168fbf982ef4fbde8861ccc21eb.zip
Version bump KDE SC 4.5.1
(Portage version: 2.2_rc75/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/smoke/ChangeLog7
-rw-r--r--kde-base/smoke/smoke-4.5.1.ebuild47
2 files changed, 53 insertions, 1 deletions
diff --git a/kde-base/smoke/ChangeLog b/kde-base/smoke/ChangeLog
index 9879de697f12..36125386d2e1 100644
--- a/kde-base/smoke/ChangeLog
+++ b/kde-base/smoke/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/smoke
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/smoke/ChangeLog,v 1.113 2010/08/09 11:31:16 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/smoke/ChangeLog,v 1.114 2010/09/06 02:02:56 tampakrap Exp $
+
+*smoke-4.5.1 (06 Sep 2010)
+
+ 06 Sep 2010; Theo Chatzimichos <tampakrap@gentoo.org> +smoke-4.5.1.ebuild:
+ Version bump
09 Aug 2010; Tomáš Chvátal <scarabeus@gentoo.org>
-smoke-4.4.4-r1.ebuild:
diff --git a/kde-base/smoke/smoke-4.5.1.ebuild b/kde-base/smoke/smoke-4.5.1.ebuild
new file mode 100644
index 000000000000..9322fb58a9f4
--- /dev/null
+++ b/kde-base/smoke/smoke-4.5.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/smoke/smoke-4.5.1.ebuild,v 1.1 2010/09/06 02:02:56 tampakrap Exp $
+
+EAPI="3"
+
+KMNAME="kdebindings"
+MULTIMEDIA_REQUIRED="optional"
+WEBKIT_REQUIRED="optional"
+inherit kde4-meta
+
+DESCRIPTION="Scripting Meta Object Kompiler Engine"
+KEYWORDS=""
+IUSE="akonadi attica debug okular +phonon qimageblitz qscintilla qwt semantic-desktop"
+
+COMMON_DEPEND="
+ $(add_kdebase_dep kdelibs 'semantic-desktop?')
+ akonadi? ( $(add_kdebase_dep kdepimlibs) )
+ attica? ( dev-libs/libattica )
+ okular? ( $(add_kdebase_dep okular) )
+ phonon? ( >=media-sound/phonon-4.3.80[xcb] )
+ qimageblitz? ( >=media-libs/qimageblitz-0.0.4 )
+ qscintilla? ( x11-libs/qscintilla )
+ qwt? ( x11-libs/qwt:5 )
+"
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}"
+
+KMEXTRA="generator/"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with akonadi)
+ $(cmake-utils_use_with akonadi KdepimLibs)
+ $(cmake-utils_use_with attica LibAttica)
+ $(cmake-utils_use_disable multimedia QtMultimedia)
+ $(cmake-utils_use_with okular)
+ $(cmake-utils_use_with phonon)
+ $(cmake-utils_use_with qimageblitz QImageBlitz)
+ $(cmake-utils_use_with qscintilla QScintilla)
+ $(cmake-utils_use_with qwt Qwt)
+ $(cmake-utils_use_with semantic-desktop Nepomuk)
+ $(cmake-utils_use_with semantic-desktop Soprano)
+ $(cmake-utils_use_disable webkit QtWebKit)
+ )
+ kde4-meta_src_configure
+}