summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2009-05-30 09:45:56 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2009-05-30 09:45:56 +0000
commit07dcbfd6c69723a1a51ae43b533432820f2e12d0 (patch)
treee364e8f39f51b80d91435cf03210148190915bd3 /kde-misc/kio-ftps/kio-ftps-0.2.ebuild
parentPunt Old. (diff)
downloadgentoo-2-07dcbfd6c69723a1a51ae43b533432820f2e12d0.tar.gz
gentoo-2-07dcbfd6c69723a1a51ae43b533432820f2e12d0.tar.bz2
gentoo-2-07dcbfd6c69723a1a51ae43b533432820f2e12d0.zip
Initial commit. Per bug #125314. Thanks to Krzysztof Głowiński for basic ebuild.
(Portage version: 2.2_rc33/cvs/Linux i686)
Diffstat (limited to 'kde-misc/kio-ftps/kio-ftps-0.2.ebuild')
-rw-r--r--kde-misc/kio-ftps/kio-ftps-0.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/kde-misc/kio-ftps/kio-ftps-0.2.ebuild b/kde-misc/kio-ftps/kio-ftps-0.2.ebuild
new file mode 100644
index 000000000000..438ca666470c
--- /dev/null
+++ b/kde-misc/kio-ftps/kio-ftps-0.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/kio-ftps/kio-ftps-0.2.ebuild,v 1.1 2009/05/30 09:45:56 scarabeus Exp $
+
+EAPI="2"
+
+inherit kde4-base
+
+DESCRIPTION="A ftps KIO slave for KDE"
+HOMEPAGE="http://kasablanca.berlios.de/kio-ftps/"
+SRC_URI="mirror://berlios/kasablanca/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# This is just for some app we can use kio-ftps with
+RDEPEND="|| (
+ >=kde-base/konqueror-${KDE_MINIMAL}
+ >=kde-base/dolphin-${KDE_MINIMAL}
+)"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ # remove all temp files
+ rm -rf *~
+ # fix linking
+ sed -i \
+ -e "s:\${KDE4_KDECORE_LIBS}:\${KDE4_KIO_LIBS}:g" \
+ CMakeLists.txt || die "sed linking failed"
+}