summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabio Erculiani <lxnay@gentoo.org>2012-02-12 07:29:48 +0000
committerFabio Erculiani <lxnay@gentoo.org>2012-02-12 07:29:48 +0000
commit0dd4b45f6f7e38885156292372e1cdff78a17be2 (patch)
tree919fdfbed82a7df956fa2777490cd0a7cfc72a16 /kde-misc/magneto-kde
parentversion bump (diff)
downloadgentoo-2-0dd4b45f6f7e38885156292372e1cdff78a17be2.tar.gz
gentoo-2-0dd4b45f6f7e38885156292372e1cdff78a17be2.tar.bz2
gentoo-2-0dd4b45f6f7e38885156292372e1cdff78a17be2.zip
version bump
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'kde-misc/magneto-kde')
-rw-r--r--kde-misc/magneto-kde/ChangeLog9
-rw-r--r--kde-misc/magneto-kde/magneto-kde-1.0_rc87.ebuild39
2 files changed, 46 insertions, 2 deletions
diff --git a/kde-misc/magneto-kde/ChangeLog b/kde-misc/magneto-kde/ChangeLog
index 1e4c4b12b2fd..d29f10957279 100644
--- a/kde-misc/magneto-kde/ChangeLog
+++ b/kde-misc/magneto-kde/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-misc/magneto-kde
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-misc/magneto-kde/ChangeLog,v 1.16 2011/12/22 17:56:36 lxnay Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/magneto-kde/ChangeLog,v 1.17 2012/02/12 07:29:48 lxnay Exp $
+
+*magneto-kde-1.0_rc87 (12 Feb 2012)
+
+ 12 Feb 2012; Fabio Erculiani <lxnay@gentoo.org> +magneto-kde-1.0_rc87.ebuild:
+ version bump
*magneto-kde-1.0_rc80 (22 Dec 2011)
diff --git a/kde-misc/magneto-kde/magneto-kde-1.0_rc87.ebuild b/kde-misc/magneto-kde/magneto-kde-1.0_rc87.ebuild
new file mode 100644
index 000000000000..c776192ed7ef
--- /dev/null
+++ b/kde-misc/magneto-kde/magneto-kde-1.0_rc87.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/magneto-kde/magneto-kde-1.0_rc87.ebuild,v 1.1 2012/02/12 07:29:48 lxnay Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+inherit eutils python
+
+DESCRIPTION="Entropy Package Manager notification applet KDE frontend"
+HOMEPAGE="http://www.sabayon.org"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+SRC_URI="mirror://sabayon/sys-apps/entropy-${PV}.tar.bz2"
+S="${WORKDIR}/entropy-${PV}/magneto"
+
+RDEPEND="~app-misc/magneto-loader-${PV}
+ kde-base/pykde4
+ dev-python/PyQt4[dbus]"
+DEPEND=""
+
+src_compile() {
+ einfo "nothing to compile"
+}
+
+src_install() {
+ emake DESTDIR="${D}" LIBDIR="usr/lib" magneto-kde-install || die "make install failed"
+}
+
+pkg_postinst() {
+ python_mod_optimize "/usr/lib/entropy/magneto/magneto/kde"
+}
+
+pkg_postrm() {
+ python_mod_cleanup "/usr/lib/entropy/magneto/magneto/kde"
+}