summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2010-08-09 20:48:40 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2010-08-09 20:48:40 +0000
commitfcfc19fa8acba17c935c63238000a3c3be5bb16a (patch)
tree45e73e3b16029aff525d68ca352131dd7f6d0dbf /kde-misc/tellico
parentFinally fix CFLAGS in Makefile patch thanks to Samuli Suominen <ssuominen@gen... (diff)
downloadgentoo-2-fcfc19fa8acba17c935c63238000a3c3be5bb16a.tar.gz
gentoo-2-fcfc19fa8acba17c935c63238000a3c3be5bb16a.tar.bz2
gentoo-2-fcfc19fa8acba17c935c63238000a3c3be5bb16a.zip
Version bump.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'kde-misc/tellico')
-rw-r--r--kde-misc/tellico/ChangeLog7
-rw-r--r--kde-misc/tellico/tellico-2.3.ebuild52
2 files changed, 58 insertions, 1 deletions
diff --git a/kde-misc/tellico/ChangeLog b/kde-misc/tellico/ChangeLog
index 4b6ea8f7fb6a..c255935c7f56 100644
--- a/kde-misc/tellico/ChangeLog
+++ b/kde-misc/tellico/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-misc/tellico
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-misc/tellico/ChangeLog,v 1.90 2010/05/15 17:18:35 reavertm Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/tellico/ChangeLog,v 1.91 2010/08/09 20:48:40 scarabeus Exp $
+
+*tellico-2.3 (09 Aug 2010)
+
+ 09 Aug 2010; Tomáš Chvátal <scarabeus@gentoo.org> +tellico-2.3.ebuild:
+ Version bump.
15 May 2010; Maciej Mrozowski <reavertm@gentoo.org> tellico-2.2.ebuild:
Update qimageblitz category, deps cleanup
diff --git a/kde-misc/tellico/tellico-2.3.ebuild b/kde-misc/tellico/tellico-2.3.ebuild
new file mode 100644
index 000000000000..c231907bcd8f
--- /dev/null
+++ b/kde-misc/tellico/tellico-2.3.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/tellico/tellico-2.3.ebuild,v 1.1 2010/08/09 20:48:39 scarabeus Exp $
+
+EAPI=2
+
+KDE_LINGUAS="ca ca@valencia cs da de el en_GB es et fi fr gl hu it nb nds nl nn
+pl pt pt_BR ru sv tr uk zh_CN"
+KDE_DOC_DIRS="doc doc-translations/%lingua_${PN}"
+inherit kde4-base
+
+DESCRIPTION="A collection manager for the KDE environment"
+HOMEPAGE="http://tellico-project.org/"
+SRC_URI="http://tellico-project.org/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="4"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="addressbook cddb debug +handbook pdf scanner taglib v4l xmp yaz"
+
+DEPEND="
+ dev-libs/libxml2
+ dev-libs/libxslt
+ media-libs/qimageblitz
+ x11-libs/qt-dbus:4
+ addressbook? ( >=kde-base/kdepimlibs-${KDE_MINIMAL} )
+ cddb? ( >=kde-base/libkcddb-${KDE_MINIMAL} )
+ pdf? ( >=app-text/poppler-0.12.3-r3[qt4] )
+ scanner? ( >=kde-base/libksane-${KDE_MINIMAL} )
+ taglib? ( >=media-libs/taglib-1.5 )
+ v4l? ( media-libs/libv4l )
+ xmp? ( >=media-libs/exempi-2 )
+ yaz? ( >=dev-libs/yaz-2 )
+"
+RDEPEND="${DEPEND}"
+
+DOCS="AUTHORS ChangeLog README"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_enable v4l WEBCAM)
+ $(cmake-utils_use_with xmp Exempi)
+ $(cmake-utils_use_with scanner KSane)
+ $(cmake-utils_use_with cddb Kcddb)
+ $(cmake-utils_use_with addressbook KdepimLibs)
+ $(cmake-utils_use_with pdf PopplerQt4)
+ $(cmake-utils_use_with taglib)
+ $(cmake-utils_use_with yaz)
+ )
+
+ kde4-base_src_configure
+}