summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-06-19 20:06:37 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-06-19 20:06:37 +0000
commit4faeaf2fab3335dd199071d533c0824051084a9a (patch)
treea1c91a8b51b29286326b831f824e838dedf642ba /kde-misc
parentFix DESCRIPTION and SRC_URI for bug #137250. (diff)
downloadgentoo-2-4faeaf2fab3335dd199071d533c0824051084a9a.tar.gz
gentoo-2-4faeaf2fab3335dd199071d533c0824051084a9a.tar.bz2
gentoo-2-4faeaf2fab3335dd199071d533c0824051084a9a.zip
Add new version (with patch to fix crash at startup).
(Portage version: 2.1.1_pre1-r1)
Diffstat (limited to 'kde-misc')
-rw-r--r--kde-misc/rsibreak/ChangeLog8
-rw-r--r--kde-misc/rsibreak/files/digest-rsibreak-0.7.03
-rw-r--r--kde-misc/rsibreak/files/rsibreak-0.7.0-crash.patch19
-rw-r--r--kde-misc/rsibreak/rsibreak-0.7.0.ebuild41
4 files changed, 70 insertions, 1 deletions
diff --git a/kde-misc/rsibreak/ChangeLog b/kde-misc/rsibreak/ChangeLog
index 42a9cb4c2c83..600674a2b9ee 100644
--- a/kde-misc/rsibreak/ChangeLog
+++ b/kde-misc/rsibreak/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-misc/rsibreak
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-misc/rsibreak/ChangeLog,v 1.10 2006/05/10 10:28:20 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/rsibreak/ChangeLog,v 1.11 2006/06/19 20:06:37 flameeyes Exp $
+
+*rsibreak-0.7.0 (19 Jun 2006)
+
+ 19 Jun 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +files/rsibreak-0.7.0-crash.patch, +rsibreak-0.7.0.ebuild:
+ Add new version (with patch to fix crash at startup).
10 May 2006; Diego Pettenò <flameeyes@gentoo.org>
+files/rsibreak-0.6.0-parallel.patch, rsibreak-0.6.0.ebuild:
diff --git a/kde-misc/rsibreak/files/digest-rsibreak-0.7.0 b/kde-misc/rsibreak/files/digest-rsibreak-0.7.0
new file mode 100644
index 000000000000..4a5f407dea59
--- /dev/null
+++ b/kde-misc/rsibreak/files/digest-rsibreak-0.7.0
@@ -0,0 +1,3 @@
+MD5 b49913f4f36b139282dc84d16344b53e Rsibreak-0.7.0.tar.bz2 569279
+RMD160 309da5a95279b73b39af66ca020176837515803c Rsibreak-0.7.0.tar.bz2 569279
+SHA256 e42054440396c0d5bcfa086a98e5e58ca384bed00c9e657b3786603d74ae3be3 Rsibreak-0.7.0.tar.bz2 569279
diff --git a/kde-misc/rsibreak/files/rsibreak-0.7.0-crash.patch b/kde-misc/rsibreak/files/rsibreak-0.7.0-crash.patch
new file mode 100644
index 000000000000..7be8febd8990
--- /dev/null
+++ b/kde-misc/rsibreak/files/rsibreak-0.7.0-crash.patch
@@ -0,0 +1,19 @@
+--- rsibreak/src/rsiwidget.cpp (revision 553033)
++++ rsibreak/src/rsiwidget.cpp (working copy)
+@@ -167,7 +167,6 @@
+ connect( m_dcopIface, SIGNAL( signalSuspend( bool) ),
+ m_relaxpopup, SLOT( setVisible( bool ) ) );
+
+- setIcon( 0 );
+ srand ( time(NULL) );
+
+ QBoxLayout *topLayout = new QVBoxLayout( this, 5);
+@@ -203,6 +202,8 @@
+
+ readConfig();
+
++ setIcon( 0 );
++
+ // if there are no images found, the break will appear in black.
+ // if the text color is black (default) then change that.
+ if (m_files.count() == 0 &&
diff --git a/kde-misc/rsibreak/rsibreak-0.7.0.ebuild b/kde-misc/rsibreak/rsibreak-0.7.0.ebuild
new file mode 100644
index 000000000000..2db5660b554f
--- /dev/null
+++ b/kde-misc/rsibreak/rsibreak-0.7.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/rsibreak/rsibreak-0.7.0.ebuild,v 1.1 2006/06/19 20:06:37 flameeyes Exp $
+
+USE_KEG_PACKAGING="yes"
+
+LANGS="bg br ca cs da de el en_GB es fr ga gl it ka nl pl pt sr sr@Latn sv tr"
+
+inherit kde
+
+MY_P="${PN/rsi/Rsi}-${PV/_rc/-rc}"
+
+DESCRIPTION="A small utility which bothers you at certain intervals"
+SRC_URI="http://www.rsibreak.org/images/e/e8/${MY_P}.tar.bz2"
+HOMEPAGE="http://www.rsibreak.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+
+S="${WORKDIR}/${PN}-${PV/_rc/-rc}"
+
+RDEPEND="|| ( (
+ x11-libs/libXext
+ x11-libs/libX11
+ x11-libs/libXScrnSaver
+ ) virtual/x11 )"
+
+DEPEND="${RDEPEND}
+ || ( (
+ x11-proto/xextproto
+ x11-proto/xproto
+ x11-proto/scrnsaverproto
+ ) virtual/x11 )"
+
+need-kde 3.3
+
+PATCHES="${FILESDIR}/${P}-crash.patch"