summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcus D. Hanwell <cryos@gentoo.org>2008-09-27 15:55:50 +0000
committerMarcus D. Hanwell <cryos@gentoo.org>2008-09-27 15:55:50 +0000
commit580af383c0f2d70455666259fe5c0afe6eed1e36 (patch)
tree5c76938e8ea4f740f5e682b7d78692a2f30b53c4 /kde-misc
parentbump to 2.18.3, updated translations and build fixes. (diff)
downloadgentoo-2-580af383c0f2d70455666259fe5c0afe6eed1e36.tar.gz
gentoo-2-580af383c0f2d70455666259fe5c0afe6eed1e36.tar.bz2
gentoo-2-580af383c0f2d70455666259fe5c0afe6eed1e36.zip
Revision bumped version to install inside the KDE prefix, only used by KDE 3.5, fixes bug 237830.
(Portage version: 2.2_rc11/cvs/Linux 2.6.26-gentoo-r1 x86_64)
Diffstat (limited to 'kde-misc')
-rw-r--r--kde-misc/kdnssd-avahi/ChangeLog9
-rw-r--r--kde-misc/kdnssd-avahi/kdnssd-avahi-0.1.2-r1.ebuild39
2 files changed, 47 insertions, 1 deletions
diff --git a/kde-misc/kdnssd-avahi/ChangeLog b/kde-misc/kdnssd-avahi/ChangeLog
index 14f8e77a8593..5d4a13abf49b 100644
--- a/kde-misc/kdnssd-avahi/ChangeLog
+++ b/kde-misc/kdnssd-avahi/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for kde-misc/kdnssd-avahi
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-misc/kdnssd-avahi/ChangeLog,v 1.19 2008/03/04 23:45:20 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/kdnssd-avahi/ChangeLog,v 1.20 2008/09/27 15:55:50 cryos Exp $
+
+*kdnssd-avahi-0.1.2-r1 (27 Sep 2008)
+
+ 27 Sep 2008; Marcus D. Hanwell <cryos@gentoo.org>
+ +kdnssd-avahi-0.1.2-r1.ebuild:
+ Revision bumped version to install inside the KDE prefix, only used by KDE
+ 3.5, fixes bug 237830.
04 Mar 2008; Ryan Hill <dirtyepic@gentoo.org> kdnssd-avahi-0.1.2.ebuild:
Keyword ~mips.
diff --git a/kde-misc/kdnssd-avahi/kdnssd-avahi-0.1.2-r1.ebuild b/kde-misc/kdnssd-avahi/kdnssd-avahi-0.1.2-r1.ebuild
new file mode 100644
index 000000000000..2b3bfec323e5
--- /dev/null
+++ b/kde-misc/kdnssd-avahi/kdnssd-avahi-0.1.2-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/kdnssd-avahi/kdnssd-avahi-0.1.2-r1.ebuild,v 1.1 2008/09/27 15:55:50 cryos Exp $
+
+inherit kde
+
+DESCRIPTION="DNS Service Discovery kioslave using Avahi (rather than mDNSResponder)"
+HOMEPAGE="http://wiki.kde.org/tiki-index.php?page=Zeroconf+in+KDE"
+SRC_URI="http://helios.et.put.poznan.pl/~jstachow/pub/${PN}_${PV}.orig.tar.gz
+ mirror://gentoo/kde-admindir-3.5.5.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+RDEPEND="net-dns/avahi"
+DEPEND="${RDEPEND}"
+
+need-kde 3.5
+
+# Install into the KDE prefix, only used by KDE. See bug 237830.
+PREFIX="/usr/kde/3.5"
+
+pkg_setup() {
+ if ! built_with_use net-dns/avahi qt3 dbus; then
+ eerror "To compile kdnssd-avahi package you need Avahi with DBus and Qt 3.x support."
+ eerror "but net-dns/avahi is not built with qt3 and/or dbus USE flags enabled."
+ die "Please, rebuild net-dns/avahi with the \"qt3\" and \"dbus\" USE flags."
+ fi
+}
+
+src_compile() {
+ kde_src_compile myconf configure
+
+ emake -C "${S}/${PN}" mocs || die "make mocs failed"
+
+ kde_src_compile make
+}