summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-09-02 18:41:49 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-09-02 18:41:49 +0000
commit94b55edcfdac5fb629ef17db868b6c7dc97b7009 (patch)
tree4a1923e482d0b897637dffe0c4d4c7f0218e32d6 /kde-misc
parentVersion bump wrt bug #143809, thanks to Polarina for providing needed patches (diff)
downloadgentoo-2-94b55edcfdac5fb629ef17db868b6c7dc97b7009.tar.gz
gentoo-2-94b55edcfdac5fb629ef17db868b6c7dc97b7009.tar.bz2
gentoo-2-94b55edcfdac5fb629ef17db868b6c7dc97b7009.zip
Version bump, with external GeoIP patch.
(Portage version: 2.1.1_rc1-r2)
Diffstat (limited to 'kde-misc')
-rw-r--r--kde-misc/tork/ChangeLog9
-rw-r--r--kde-misc/tork/files/digest-tork-0.073
-rw-r--r--kde-misc/tork/files/tork-0.07-geoip.patch62
-rw-r--r--kde-misc/tork/files/tork-0.07-qt335.patch70
-rw-r--r--kde-misc/tork/tork-0.07.ebuild35
5 files changed, 178 insertions, 1 deletions
diff --git a/kde-misc/tork/ChangeLog b/kde-misc/tork/ChangeLog
index a104d02f1287..c6fd9834b16d 100644
--- a/kde-misc/tork/ChangeLog
+++ b/kde-misc/tork/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for kde-misc/tork
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-misc/tork/ChangeLog,v 1.4 2006/08/31 17:49:59 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/tork/ChangeLog,v 1.5 2006/09/02 18:41:49 flameeyes Exp $
+
+*tork-0.07 (02 Sep 2006)
+
+ 02 Sep 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +files/tork-0.07-geoip.patch, +files/tork-0.07-qt335.patch,
+ +tork-0.07.ebuild:
+ Version bump, with external GeoIP patch.
*tork-0.06 (31 Aug 2006)
diff --git a/kde-misc/tork/files/digest-tork-0.07 b/kde-misc/tork/files/digest-tork-0.07
new file mode 100644
index 000000000000..6ce74ba0b6a8
--- /dev/null
+++ b/kde-misc/tork/files/digest-tork-0.07
@@ -0,0 +1,3 @@
+MD5 ad7b4fd40e9ca1638837a3f0fd478a83 tork-0.07.tar.bz2 1435686
+RMD160 30b9128560d3167df49327b1c7c57b62855385a5 tork-0.07.tar.bz2 1435686
+SHA256 f31723df1e357a2909337b246f1db46a044b40310c3d3da1fb118fd6d603a804 tork-0.07.tar.bz2 1435686
diff --git a/kde-misc/tork/files/tork-0.07-geoip.patch b/kde-misc/tork/files/tork-0.07-geoip.patch
new file mode 100644
index 000000000000..6b681bc9f3cf
--- /dev/null
+++ b/kde-misc/tork/files/tork-0.07-geoip.patch
@@ -0,0 +1,62 @@
+Index: tork-0.07/configure.in.in
+===================================================================
+--- tork-0.07.orig/configure.in.in
++++ tork-0.07/configure.in.in
+@@ -209,22 +209,3 @@ if test "$ac_cv_openssl_linker_option" !
+ LDFLAGS="$ac_cv_openssl_linker_option $LDFLAGS"
+ fi
+
+-
+-# - GeoIP
+-
+-GEOVERSION=1.4.0
+-PACKAGE=GeoIP
+-GEOIP_VERSION_INFO=`echo $GEOVERSION | awk -F. '{ printf "%d:%d:%d", $1+$2, $3, $2 }'`
+-AC_SUBST(GEOIP_VERSION_INFO)
+-
+-AC_ARG_WITH(city,
+-[ --with-city=\"no\" Enable/disable support for GeoIP City Edition. (yes)])
+-if test "$with_city" = "no" ; then
+- echo Disabling GeoIP City Edition support
+- WITH_CITY=1
+-else
+- echo Enabling GeoIP City Edition support
+- WITH_CITY=0
+-fi
+-AC_SUBST(WITH_CITY)
+-AM_CONDITIONAL(WITH_CITY, test "$with_city" != "no")
+Index: tork-0.07/src/Makefile.am
+===================================================================
+--- tork-0.07.orig/src/Makefile.am
++++ tork-0.07/src/Makefile.am
+@@ -4,7 +4,7 @@
+ # of the other Makefile.am variables
+ bin_PROGRAMS = tork
+
+-SUBDIRS=icons about arkollon GeoIP-1.4.0 .
++SUBDIRS=icons about arkollon .
+
+ # set the include path for X, qt and KDE
+ INCLUDES = $(all_includes)
+@@ -16,7 +16,7 @@ METASOURCES = AUTO
+ tork_LDFLAGS = $(KDE_RPATH) $(all_libraries)
+
+ # the libraries to link against.
+-tork_LDADD = $(LIB_KFILE) $(LIB_KHTML) -L GeoIP-1.4.0/libGeoIP/libGeoIP.la
++tork_LDADD = $(LIB_KFILE) $(LIB_KHTML) -lGeoIP
+
+ # which sources should be compiled for tork
+ tork_SOURCES = torkconfig.kcfgc main.cpp tork.cpp torkview.cpp torkview_base.ui \
+Index: tork-0.07/src/torkview.cpp
+===================================================================
+--- tork-0.07.orig/src/torkview.cpp
++++ tork-0.07/src/torkview.cpp
+@@ -30,7 +30,7 @@
+ #include "portsandicons.h"
+ #include "torkconfig.h"
+
+-#include "GeoIP-1.4.0/libGeoIP/GeoIP.h"
++#include "GeoIP.h"
+
+
+ #include "kdebug.h"
diff --git a/kde-misc/tork/files/tork-0.07-qt335.patch b/kde-misc/tork/files/tork-0.07-qt335.patch
new file mode 100644
index 000000000000..91c599ed28b1
--- /dev/null
+++ b/kde-misc/tork/files/tork-0.07-qt335.patch
@@ -0,0 +1,70 @@
+Index: tork-0.07/src/torkview_base.ui
+===================================================================
+--- tork-0.07.orig/src/torkview_base.ui
++++ tork-0.07/src/torkview_base.ui
+@@ -521,7 +521,7 @@
+ <customwidgets>
+ <customwidget>
+ <class>DndListView</class>
+- <header location="local">/home/robert/Development/tork/src/dndlistview.h</header>
++ <header location="local">dndlistview.h</header>
+ <sizehint>
+ <width>-1</width>
+ <height>-1</height>
+@@ -593,7 +593,4 @@
+ <function access="private" specifier="non virtual">init()</function>
+ </functions>
+ <layoutdefaults spacing="6" margin="11"/>
+-<includehints>
+- <includehint>dndlistview.h</includehint>
+-</includehints>
+ </UI>
+Index: tork-0.07/src/firstrunwizard.ui
+===================================================================
+--- tork-0.07.orig/src/firstrunwizard.ui
++++ tork-0.07/src/firstrunwizard.ui
+@@ -673,16 +673,4 @@
+ <function access="private" specifier="non virtual">configureKonqi()</function>
+ </functions>
+ <layoutdefaults spacing="6" margin="11"/>
+-<includehints>
+- <includehint>kactivelabel.h</includehint>
+- <includehint>kurlrequester.h</includehint>
+- <includehint>klineedit.h</includehint>
+- <includehint>kpushbutton.h</includehint>
+- <includehint>kactivelabel.h</includehint>
+- <includehint>kactivelabel.h</includehint>
+- <includehint>kurlrequester.h</includehint>
+- <includehint>klineedit.h</includehint>
+- <includehint>kpushbutton.h</includehint>
+- <includehint>kactivelabel.h</includehint>
+-</includehints>
+ </UI>
+Index: tork-0.07/src/hidsrvwizard.ui
+===================================================================
+--- tork-0.07.orig/src/hidsrvwizard.ui
++++ tork-0.07/src/hidsrvwizard.ui
+@@ -369,9 +369,4 @@
+ <customwidgets>
+ </customwidgets>
+ <layoutdefaults spacing="6" margin="11"/>
+-<includehints>
+- <includehint>kurlrequester.h</includehint>
+- <includehint>kcombobox.h</includehint>
+- <includehint>kpushbutton.h</includehint>
+-</includehints>
+ </UI>
+Index: tork-0.07/src/running.ui
+===================================================================
+--- tork-0.07.orig/src/running.ui
++++ tork-0.07/src/running.ui
+@@ -591,9 +591,4 @@
+ <function access="private" specifier="non virtual">init()</function>
+ </functions>
+ <layoutdefaults spacing="6" margin="11"/>
+-<includehints>
+- <includehint>kurlrequester.h</includehint>
+- <includehint>kcombobox.h</includehint>
+- <includehint>kpushbutton.h</includehint>
+-</includehints>
+ </UI>
diff --git a/kde-misc/tork/tork-0.07.ebuild b/kde-misc/tork/tork-0.07.ebuild
new file mode 100644
index 000000000000..9d599a007561
--- /dev/null
+++ b/kde-misc/tork/tork-0.07.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/tork/tork-0.07.ebuild,v 1.1 2006/09/02 18:41:49 flameeyes Exp $
+
+inherit kde
+
+DESCRIPTION="A Tor controller for the KDE desktop"
+HOMEPAGE="http://tork.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=""
+RDEPEND="net-misc/tor
+ dev-libs/openssl
+ >=dev-libs/geoip-1.4.0
+ >=net-proxy/privoxy-3.0.3-r5"
+
+need-kde 3.5
+
+PATCHES="${FILESDIR}/${P}-geoip.patch
+ ${FILESDIR}/${P}-qt335.patch"
+
+src_unpack() {
+ kde_src_unpack
+ rm -rf "${S}/src/GeoIP-1.4.0" "${S}/configure"
+}
+
+src_install() {
+ kde_src_install
+ rm -rf "${D}/usr/share/applnk"
+}