summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Dibb <beandog@gentoo.org>2007-03-02 05:38:57 +0000
committerSteve Dibb <beandog@gentoo.org>2007-03-02 05:38:57 +0000
commit98cae9df45ef8fdc4bbbe98ccfb1356204acaaff (patch)
tree2337747ccddc7f18a1ae32ea6277aa1ac8056997 /kde-misc
parentStable for HPPA (bug #168916). (diff)
downloadgentoo-2-98cae9df45ef8fdc4bbbe98ccfb1356204acaaff.tar.gz
gentoo-2-98cae9df45ef8fdc4bbbe98ccfb1356204acaaff.tar.bz2
gentoo-2-98cae9df45ef8fdc4bbbe98ccfb1356204acaaff.zip
Version bump
(Portage version: 2.1.1-r2)
Diffstat (limited to 'kde-misc')
-rw-r--r--kde-misc/tellico/ChangeLog7
-rw-r--r--kde-misc/tellico/files/digest-tellico-1.2.93
-rw-r--r--kde-misc/tellico/tellico-1.2.9.ebuild53
3 files changed, 62 insertions, 1 deletions
diff --git a/kde-misc/tellico/ChangeLog b/kde-misc/tellico/ChangeLog
index 6d2bcf81aeba..d59382540888 100644
--- a/kde-misc/tellico/ChangeLog
+++ b/kde-misc/tellico/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-misc/tellico
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-misc/tellico/ChangeLog,v 1.60 2007/02/18 13:48:22 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/tellico/ChangeLog,v 1.61 2007/03/02 05:38:57 beandog Exp $
+
+*tellico-1.2.9 (02 Mar 2007)
+
+ 02 Mar 2007; Steve Dibb <beandog@gentoo.org> +tellico-1.2.9.ebuild:
+ Version bump
18 Feb 2007; Simon Stelling <blubb@gentoo.org> tellico-1.2.7.ebuild:
stable on amd64; bug 165391
diff --git a/kde-misc/tellico/files/digest-tellico-1.2.9 b/kde-misc/tellico/files/digest-tellico-1.2.9
new file mode 100644
index 000000000000..72b4dde7e171
--- /dev/null
+++ b/kde-misc/tellico/files/digest-tellico-1.2.9
@@ -0,0 +1,3 @@
+MD5 b20f0fce12cff799124cff7031c5dd3b tellico-1.2.9.tar.gz 4692816
+RMD160 171f9e530c0b2cbf70e1f803eee6e940ac9ba7b1 tellico-1.2.9.tar.gz 4692816
+SHA256 ca24789eead77cd2fc43105af5072350ad0d62412f1f97d51d359d12efb00959 tellico-1.2.9.tar.gz 4692816
diff --git a/kde-misc/tellico/tellico-1.2.9.ebuild b/kde-misc/tellico/tellico-1.2.9.ebuild
new file mode 100644
index 000000000000..cc9524b4f5d2
--- /dev/null
+++ b/kde-misc/tellico/tellico-1.2.9.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/tellico/tellico-1.2.9.ebuild,v 1.1 2007/03/02 05:38:57 beandog Exp $
+
+inherit kde sgml-catalog
+
+MY_P=${P/_/}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="A collection manager for the KDE environment."
+HOMEPAGE="http://www.periapsis.org/tellico"
+SRC_URI="http://www.periapsis.org/tellico/download/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="calendar cddb yaz"
+
+RDEPEND=">=dev-libs/libxml2-2.6
+ >=dev-libs/libxslt-1.0.19
+ cddb? ( || ( kde-base/libkcddb kde-base/kdemultimedia ) )
+ calendar? ( || ( ( kde-base/ktnef kde-base/libkcal ) kde-base/kdepim ) )
+ media-libs/taglib
+ yaz? ( dev-libs/yaz )"
+
+need-kde 3.4 #Real lowest version is 3.3.1
+
+src_compile() {
+ local myconf="$(use_enable cddb libkcddb) $(use_enable calendar libkcal)"
+ kde_src_compile
+}
+
+pkg_postinst() {
+ einfo "Installing catalog..."
+ ${ROOT}/usr/bin/xmlcatalog --noout --add "delegatePublic" \
+ "-//Robby Stephenson/DTD Tellico V9.0//EN" \
+ "file://${ROOT}usr/share/apps/tellico/tellico.dtd" \
+ ${ROOT}/etc/xml/catalog
+ ${ROOT}/usr/bin/xmlcatalog --noout --add "delegateSystem" \
+ "http://www.periapsis.org/tellico/dtd/v9/tellico.dtd" \
+ "file://${ROOT}usr/share/apps/tellico/tellico.dtd" \
+ ${ROOT}/etc/xml/catalog
+ ${ROOT}/usr/bin/xmlcatalog --noout --add "delegateURI" \
+ "http://www.periapsis.org/tellico/dtd/v9/tellico.dtd" \
+ "file://${ROOT}usr/share/apps/tellico/tellico.dtd" \
+ ${ROOT}/etc/xml/catalog
+}
+
+pkg_postrm() {
+ ${ROOT}/usr/bin/xmlcatalog --noout --del \
+ "file://${ROOT}usr/share/apps/tellico/tellico.dtd" \
+ ${ROOT}/etc/xml/catalog
+}