summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2015-06-30 20:50:15 +0000
committerJohannes Huber <johu@gentoo.org>2015-06-30 20:50:15 +0000
commit9cd873cfc2c4a02cc5f90e2fe321707ebe4e543d (patch)
tree8c7fa598876bda2f956e3159f43c5166c7be413f /kde-plasma/plasma-meta/plasma-meta-5.3.2.ebuild
parentPatch build.xml and write tmp files elsewhere but NOT in /tmp. EAPI 5 bump. F... (diff)
downloadgentoo-2-9cd873cfc2c4a02cc5f90e2fe321707ebe4e543d.tar.gz
gentoo-2-9cd873cfc2c4a02cc5f90e2fe321707ebe4e543d.tar.bz2
gentoo-2-9cd873cfc2c4a02cc5f90e2fe321707ebe4e543d.zip
Version bump KDE Plasma 5.3.2
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0xFDF4F788)
Diffstat (limited to 'kde-plasma/plasma-meta/plasma-meta-5.3.2.ebuild')
-rw-r--r--kde-plasma/plasma-meta/plasma-meta-5.3.2.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/kde-plasma/plasma-meta/plasma-meta-5.3.2.ebuild b/kde-plasma/plasma-meta/plasma-meta-5.3.2.ebuild
new file mode 100644
index 000000000000..9c0c33a8a976
--- /dev/null
+++ b/kde-plasma/plasma-meta/plasma-meta-5.3.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-plasma/plasma-meta/plasma-meta-5.3.2.ebuild,v 1.1 2015/06/30 20:50:13 johu Exp $
+
+EAPI=5
+
+inherit kde5-functions
+
+DESCRIPTION="Merge this to pull in all Plasma 5 packages"
+HOMEPAGE="http://www.kde.org/workspaces/plasmadesktop/"
+
+LICENSE="metapackage"
+SLOT="5"
+KEYWORDS="~amd64"
+IUSE="bluetooth +display-manager gtk +sddm networkmanager +wallpapers"
+
+RDEPEND="
+ $(add_plasma_dep baloo)
+ $(add_plasma_dep breeze)
+ $(add_plasma_dep kde-cli-tools)
+ $(add_plasma_dep kdecoration)
+ $(add_plasma_dep kfilemetadata)
+ $(add_plasma_dep khelpcenter)
+ $(add_plasma_dep khotkeys)
+ $(add_plasma_dep kinfocenter)
+ $(add_plasma_dep kio-extras)
+ $(add_plasma_dep kmenuedit)
+ $(add_plasma_dep kscreen)
+ $(add_plasma_dep ksshaskpass)
+ $(add_plasma_dep ksysguard)
+ $(add_plasma_dep kwayland)
+ $(add_plasma_dep kwin)
+ $(add_plasma_dep kwrited)
+ $(add_plasma_dep libkscreen)
+ $(add_plasma_dep milou)
+ $(add_plasma_dep oxygen)
+ $(add_plasma_dep oxygen-fonts)
+ $(add_plasma_dep plasma-desktop)
+ $(add_plasma_dep plasma-workspace)
+ $(add_plasma_dep polkit-kde-agent)
+ $(add_plasma_dep powerdevil)
+ $(add_plasma_dep systemsettings)
+ bluetooth? (
+ $(add_plasma_dep bluedevil)
+ )
+ display-manager? (
+ sddm? ( x11-misc/sddm )
+ !sddm? ( x11-misc/lightdm )
+ )
+ gtk? ( $(add_plasma_dep kde-gtk-config) )
+ networkmanager? ( $(add_plasma_dep plasma-nm) )
+ sddm? ( $(add_plasma_dep sddm-kcm) )
+ wallpapers? ( $(add_plasma_dep plasma-workspace-wallpapers) )
+"