summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2012-05-12 10:08:47 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2012-05-12 10:08:47 +0000
commit1f4951c6a6c1baaf31771a8e56f3a41470773790 (patch)
tree9d81542b7665955423dbbbcc55e366a9ad3dcd9a /lxde-base/lxpanel
parentUpdate homepage and metadata. (diff)
downloadgentoo-2-1f4951c6a6c1baaf31771a8e56f3a41470773790.tar.gz
gentoo-2-1f4951c6a6c1baaf31771a8e56f3a41470773790.tar.bz2
gentoo-2-1f4951c6a6c1baaf31771a8e56f3a41470773790.zip
version bump. Bug #415519
(Portage version: 2.1.10.58/cvs/Linux x86_64)
Diffstat (limited to 'lxde-base/lxpanel')
-rw-r--r--lxde-base/lxpanel/ChangeLog8
-rw-r--r--lxde-base/lxpanel/files/lxpanel-0.5.9-sandbox.patch29
-rw-r--r--lxde-base/lxpanel/lxpanel-0.5.9.ebuild59
3 files changed, 95 insertions, 1 deletions
diff --git a/lxde-base/lxpanel/ChangeLog b/lxde-base/lxpanel/ChangeLog
index 2b50f16c6d0c..aef3d733644b 100644
--- a/lxde-base/lxpanel/ChangeLog
+++ b/lxde-base/lxpanel/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for lxde-base/lxpanel
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/lxde-base/lxpanel/ChangeLog,v 1.39 2012/05/07 10:14:24 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/lxde-base/lxpanel/ChangeLog,v 1.40 2012/05/12 10:08:47 hwoarang Exp $
+
+*lxpanel-0.5.9 (12 May 2012)
+
+ 12 May 2012; Markos Chandras <hwoarang@gentoo.org>
+ +files/lxpanel-0.5.9-sandbox.patch, +lxpanel-0.5.9.ebuild:
+ version bump. Bug #415519
*lxpanel-0.5.8-r3 (07 May 2012)
diff --git a/lxde-base/lxpanel/files/lxpanel-0.5.9-sandbox.patch b/lxde-base/lxpanel/files/lxpanel-0.5.9-sandbox.patch
new file mode 100644
index 000000000000..0f40c185bc6d
--- /dev/null
+++ b/lxde-base/lxpanel/files/lxpanel-0.5.9-sandbox.patch
@@ -0,0 +1,29 @@
+Index: lxpanel-0.5.9/src/plugins/Makefile.am
+===================================================================
+--- lxpanel-0.5.9.orig/src/plugins/Makefile.am
++++ lxpanel-0.5.9/src/plugins/Makefile.am
+@@ -49,6 +49,3 @@ EXTRA_DIST = \
+ icon.xpm
+
+ install-exec-hook:
+- rm -f $(DESTDIR)$(libdir)/lxpanel/plugins/*.la
+- rm -f $(DESTDIR)$(libdir)/lxpanel/plugins/*.a
+- rm -f $(DESTDIR)$(libdir)/lxpanel/plugins/*.
+Index: lxpanel-0.5.9/src/plugins/netstat/Makefile.am
+===================================================================
+--- lxpanel-0.5.9.orig/src/plugins/netstat/Makefile.am
++++ lxpanel-0.5.9/src/plugins/netstat/Makefile.am
+@@ -33,4 +33,3 @@ netstat_la_LDFLAGS = \
+ @LXPANEL_MODULE@
+
+ install-exec-hook:
+- rm -f "$(moduledir)\*.la" *.a
+Index: lxpanel-0.5.9/src/plugins/netstatus/Makefile.am
+===================================================================
+--- lxpanel-0.5.9.orig/src/plugins/netstatus/Makefile.am
++++ lxpanel-0.5.9/src/plugins/netstatus/Makefile.am
+@@ -34,4 +34,3 @@ netstatus_la_LDFLAGS = \
+ $(LXPANEL_MODULE)
+
+ install-exec-hook:
+- rm -f "$(moduledir)\*.la" *.a
diff --git a/lxde-base/lxpanel/lxpanel-0.5.9.ebuild b/lxde-base/lxpanel/lxpanel-0.5.9.ebuild
new file mode 100644
index 000000000000..d68fc0d0b72c
--- /dev/null
+++ b/lxde-base/lxpanel/lxpanel-0.5.9.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/lxde-base/lxpanel/lxpanel-0.5.9.ebuild,v 1.1 2012/05/12 10:08:47 hwoarang Exp $
+
+EAPI="4"
+
+inherit autotools eutils
+
+DESCRIPTION="Lightweight X11 desktop panel for LXDE"
+HOMEPAGE="http://lxde.org/"
+SRC_URI="mirror://sourceforge/lxde/LXPanel%20%28desktop%20panel%29/LXPanel%20${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~ppc ~x86 ~x86-interix ~amd64-linux ~x86-linux"
+SLOT="0"
+IUSE="+alsa wifi"
+RESTRICT="test" # bug 249598
+
+RDEPEND="x11-libs/gtk+:2
+ x11-libs/libXmu
+ x11-libs/libXpm
+ lxde-base/lxmenu-data
+ lxde-base/menu-cache
+ alsa? ( media-libs/alsa-lib )
+ wifi? ( net-wireless/wireless-tools )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ sys-devel/gettext"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.5.8-dynamic-width.patch
+ epatch "${FILESDIR}"/${P}-sandbox.patch
+ eautoreconf
+}
+
+src_configure() {
+ local plugins="netstatus,volume,cpu deskno,batt, \
+ kbled,xkb,thermal,cpufreq,monitors,wnckpager"
+ use wifi && plugins+=",netstat"
+ use alsa && plugins+=",volumealsa"
+ [[ ${CHOST} == *-interix* ]] && plugins=deskno,kbled,xkb
+
+ econf $(use_enable alsa) --with-x --with-plugins="${plugins}"
+ # the gtk+ dep already pulls in libX11, so we might as well hardcode with-x
+}
+
+src_install () {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog README
+
+ # Get rid of the .la files.
+ find "${D}" -name '*.la' -delete
+}
+
+pkg_postinst() {
+ elog "If you have problems with broken icons shown in the main panel,"
+ elog "you will have to configure panel settings via its menu."
+ elog "This will not be an issue with first time installations."
+}