summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJauhien Piatlicki <jauhien@gentoo.org>2014-11-08 17:35:54 +0000
committerJauhien Piatlicki <jauhien@gentoo.org>2014-11-08 17:35:54 +0000
commit9b77f4fe2689d6ad4173a080cb16af4f80b2cd18 (patch)
treeb1bb2664d7f8c70de2c515a573738c6a702925ac /lxqt-base/lxqt-common
parentCopy stable keywords from dev-lang/perl-5.18 provider (diff)
downloadgentoo-2-9b77f4fe2689d6ad4173a080cb16af4f80b2cd18.tar.gz
gentoo-2-9b77f4fe2689d6ad4173a080cb16af4f80b2cd18.tar.bz2
gentoo-2-9b77f4fe2689d6ad4173a080cb16af4f80b2cd18.zip
version bump
(Portage version: 2.2.14_rc1/cvs/Linux x86_64, signed Manifest commit with key 0xB2EFA1D4)
Diffstat (limited to 'lxqt-base/lxqt-common')
-rw-r--r--lxqt-base/lxqt-common/ChangeLog7
-rw-r--r--lxqt-base/lxqt-common/lxqt-common-0.8.0.ebuild37
2 files changed, 43 insertions, 1 deletions
diff --git a/lxqt-base/lxqt-common/ChangeLog b/lxqt-base/lxqt-common/ChangeLog
index 6a045ae7d1a3..c9f7c7218e10 100644
--- a/lxqt-base/lxqt-common/ChangeLog
+++ b/lxqt-base/lxqt-common/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for lxqt-base/lxqt-common
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/lxqt-base/lxqt-common/ChangeLog,v 1.3 2014/11/02 21:22:14 jauhien Exp $
+# $Header: /var/cvsroot/gentoo-x86/lxqt-base/lxqt-common/ChangeLog,v 1.4 2014/11/08 17:35:54 jauhien Exp $
+
+*lxqt-common-0.8.0 (08 Nov 2014)
+
+ 08 Nov 2014; Jauhien Piatlicki <jauhien@gentoo.org> +lxqt-common-0.8.0.ebuild:
+ version bump
02 Nov 2014; Jauhien Piatlicki <jauhien@gentoo.org> lxqt-common-0.7.0.ebuild:
make dependencies more precise (preparation for LXQt 0.8.0 release)
diff --git a/lxqt-base/lxqt-common/lxqt-common-0.8.0.ebuild b/lxqt-base/lxqt-common/lxqt-common-0.8.0.ebuild
new file mode 100644
index 000000000000..e02ac1a4429c
--- /dev/null
+++ b/lxqt-base/lxqt-common/lxqt-common-0.8.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/lxqt-base/lxqt-common/lxqt-common-0.8.0.ebuild,v 1.1 2014/11/08 17:35:54 jauhien Exp $
+
+EAPI=5
+inherit cmake-utils
+
+DESCRIPTION="LXQt common resources"
+HOMEPAGE="http://www.lxqt.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://git.lxde.org/git/lxde/${PN}.git"
+else
+ SRC_URI="http://lxqt.org/downloads/lxqt/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+
+DEPEND="~lxqt-base/liblxqt-${PV}"
+RDEPEND="${DEPEND}"
+PDEPEND="~lxqt-base/lxqt-session-${PV}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_QT5=ON
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ dodir "/etc/X11/Sessions"
+ dosym "/usr/bin/startlxqt" "/etc/X11/Sessions/lxqt"
+}