summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2010-09-26 04:47:07 +0000
committerTim Harder <radhermit@gentoo.org>2010-09-26 04:47:07 +0000
commit21599da986f49f5260a189e0a9de6a4b41758112 (patch)
tree9db892a3937576dfcfb7d15d891d865e3c28c9f0 /mail-client/cone
parentVersion bump (diff)
downloadgentoo-2-21599da986f49f5260a189e0a9de6a4b41758112.tar.gz
gentoo-2-21599da986f49f5260a189e0a9de6a4b41758112.tar.bz2
gentoo-2-21599da986f49f5260a189e0a9de6a4b41758112.zip
Version bump (fixes bug #321845, thanks to Azamat H. Hackimov for reporting) and update LICENSE to GPL-3. Also, add USE flags, dependencies, and configure flags for gnutls, idn, ipv6, and ldap (bug #202466).
(Portage version: 2.2_rc85/cvs/Linux x86_64)
Diffstat (limited to 'mail-client/cone')
-rw-r--r--mail-client/cone/ChangeLog9
-rw-r--r--mail-client/cone/cone-0.84.ebuild40
2 files changed, 48 insertions, 1 deletions
diff --git a/mail-client/cone/ChangeLog b/mail-client/cone/ChangeLog
index aa41dcdb9700..a9da67c02786 100644
--- a/mail-client/cone/ChangeLog
+++ b/mail-client/cone/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for mail-client/cone
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/cone/ChangeLog,v 1.23 2010/08/01 22:04:13 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/cone/ChangeLog,v 1.24 2010/09/26 04:47:07 radhermit Exp $
+
+*cone-0.84 (26 Sep 2010)
+
+ 26 Sep 2010; Tim Harder <radhermit@gentoo.org> +cone-0.84.ebuild:
+ Version bump (fixes bug #321845, thanks to Azamat H. Hackimov for
+ reporting) and update LICENSE to GPL-3. Also, add USE flags, dependencies,
+ and configure flags for gnutls, idn, ipv6, and ldap (bug #202466).
01 Aug 2010; Ryan Hill <dirtyepic@gentoo.org> cone-0.79.ebuild,
+files/cone-0.79-gcc45.patch:
diff --git a/mail-client/cone/cone-0.84.ebuild b/mail-client/cone/cone-0.84.ebuild
new file mode 100644
index 000000000000..e92434b666f0
--- /dev/null
+++ b/mail-client/cone/cone-0.84.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/cone/cone-0.84.ebuild,v 1.1 2010/09/26 04:47:07 radhermit Exp $
+
+EAPI="2"
+
+DESCRIPTION="CONE: COnsole News reader and Emailer"
+HOMEPAGE="http://www.courier-mta.org/cone/"
+SRC_URI="mirror://sourceforge/courier/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="crypt fam gnutls idn ipv6 ldap spell"
+
+RDEPEND=">=dev-libs/openssl-0.9.6
+ dev-libs/libxml2
+ sys-libs/ncurses
+ crypt? ( >=app-crypt/gnupg-1.0.4 )
+ fam? ( virtual/fam )
+ gnutls? ( net-libs/gnutls )
+ idn? ( net-dns/libidn )
+ ipv6? ( net-dns/libidn )
+ ldap? ( net-nds/openldap )
+ spell? ( virtual/aspell-dict )"
+DEPEND="${RDEPEND}
+ dev-lang/perl"
+
+src_configure() {
+ econf \
+ $(use_with ldap ldapaddressbook) \
+ $(use_with gnutls) \
+ $(use_with idn libidn) \
+ $(use_with ipv6)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ emake DESTDIR="${D}" install-configure || die "emake install-configure failed"
+}