summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2007-11-19 13:50:55 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2007-11-19 13:50:55 +0000
commit0b40ad5e9f12d7043dd4464410bb1a39e443af99 (patch)
tree74efe21d16d34a23409856940aaa1eda8f02df86 /mail-client/evolution
parentRemove old versions. (diff)
downloadgentoo-2-0b40ad5e9f12d7043dd4464410bb1a39e443af99.tar.gz
gentoo-2-0b40ad5e9f12d7043dd4464410bb1a39e443af99.tar.bz2
gentoo-2-0b40ad5e9f12d7043dd4464410bb1a39e443af99.zip
fix test fixing to actually be in the right place
(Portage version: 2.1.3.19)
Diffstat (limited to 'mail-client/evolution')
-rw-r--r--mail-client/evolution/ChangeLog6
-rw-r--r--mail-client/evolution/evolution-2.12.0.ebuild26
-rw-r--r--mail-client/evolution/evolution-2.12.1.ebuild32
3 files changed, 34 insertions, 30 deletions
diff --git a/mail-client/evolution/ChangeLog b/mail-client/evolution/ChangeLog
index 9092e896dc0f..fe1c7e26beb9 100644
--- a/mail-client/evolution/ChangeLog
+++ b/mail-client/evolution/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for mail-client/evolution
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/evolution/ChangeLog,v 1.208 2007/11/06 17:08:00 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/evolution/ChangeLog,v 1.209 2007/11/19 13:50:55 eva Exp $
+
+ 19 Nov 2007; Gilles Dartiguelongue <eva@gentoo.org>
+ evolution-2.12.0.ebuild, evolution-2.12.1.ebuild:
+ fix test fixing to actually be applied in the right place
06 Nov 2007; Raúl Porcel <armin76@gentoo.org> evolution-2.10.3.ebuild:
sparc stable wrt #193339
diff --git a/mail-client/evolution/evolution-2.12.0.ebuild b/mail-client/evolution/evolution-2.12.0.ebuild
index 9215448ba708..0dfd516015d4 100644
--- a/mail-client/evolution/evolution-2.12.0.ebuild
+++ b/mail-client/evolution/evolution-2.12.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/evolution/evolution-2.12.0.ebuild,v 1.5 2007/11/02 15:58:10 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/evolution/evolution-2.12.0.ebuild,v 1.6 2007/11/19 13:50:55 eva Exp $
inherit gnome2 flag-o-matic
@@ -98,6 +98,18 @@ pkg_setup() {
G2CONF="${G2CONF} $(use_with krb4 krb4 /usr)"
fi
+ # dang - I've changed this to do --enable-plugins=experimental. This will autodetect
+ # new-mail-notify and exchange, but that cannot be helped for the moment.
+ # They should be changed to depend on a --enable-<foo> like mono is. This
+ # cleans up a ton of crap from this ebuild.
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # Mail-remote doesn't build
+ epatch "${FILESDIR}"/${PN}-2.11.90-mail-remote-broken.patch
+
# Fix tests (again)
echo "evolution-addressbook.xml" >> "${S}"/po/POTFILES.in
echo "evolution-calendar.xml" >> "${S}"/po/POTFILES.in
@@ -116,18 +128,6 @@ pkg_setup() {
echo "evolution-task-editor.xml" >> "${S}"/po/POTFILES.in
echo "evolution-tasks.xml" >> "${S}"/po/POTFILES.in
echo "evolution.xml" >> "${S}"/po/POTFILES.in
-
- # dang - I've changed this to do --enable-plugins=experimental. This will autodetect
- # new-mail-notify and exchange, but that cannot be helped for the moment.
- # They should be changed to depend on a --enable-<foo> like mono is. This
- # cleans up a ton of crap from this ebuild.
-}
-
-src_unpack() {
- gnome2_src_unpack
-
- # Mail-remote doesn't build
- epatch "${FILESDIR}"/${PN}-2.11.90-mail-remote-broken.patch
}
src_compile() {
diff --git a/mail-client/evolution/evolution-2.12.1.ebuild b/mail-client/evolution/evolution-2.12.1.ebuild
index 471b56e5efdd..f16ebe33f639 100644
--- a/mail-client/evolution/evolution-2.12.1.ebuild
+++ b/mail-client/evolution/evolution-2.12.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/evolution/evolution-2.12.1.ebuild,v 1.5 2007/11/02 15:58:10 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/evolution/evolution-2.12.1.ebuild,v 1.6 2007/11/19 13:50:55 eva Exp $
inherit gnome2 flag-o-matic
@@ -98,6 +98,21 @@ pkg_setup() {
G2CONF="${G2CONF} $(use_with krb4 krb4 /usr)"
fi
+ # dang - I've changed this to do --enable-plugins=experimental. This will autodetect
+ # new-mail-notify and exchange, but that cannot be helped for the moment.
+ # They should be changed to depend on a --enable-<foo> like mono is. This
+ # cleans up a ton of crap from this ebuild.
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # Mail-remote doesn't build
+ epatch "${FILESDIR}"/${P}-mail-remote-broken.patch
+
+ # Fix timezone offsets on fbsd. bug #183708
+ epatch "${FILESDIR}"/${PN}-2.10.2-fbsd.patch
+
# Fix tests (again)
echo "evolution-addressbook.xml" >> "${S}"/po/POTFILES.in
echo "evolution-calendar.xml" >> "${S}"/po/POTFILES.in
@@ -116,21 +131,6 @@ pkg_setup() {
echo "evolution-task-editor.xml" >> "${S}"/po/POTFILES.in
echo "evolution-tasks.xml" >> "${S}"/po/POTFILES.in
echo "evolution.xml" >> "${S}"/po/POTFILES.in
-
- # dang - I've changed this to do --enable-plugins=experimental. This will autodetect
- # new-mail-notify and exchange, but that cannot be helped for the moment.
- # They should be changed to depend on a --enable-<foo> like mono is. This
- # cleans up a ton of crap from this ebuild.
-}
-
-src_unpack() {
- gnome2_src_unpack
-
- # Mail-remote doesn't build
- epatch "${FILESDIR}"/${P}-mail-remote-broken.patch
-
- # Fix timezone offsets on fbsd. bug #183708
- epatch "${FILESDIR}"/${PN}-2.10.2-fbsd.patch
}
src_compile() {