summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeonardo Boshell <leonardop@gentoo.org>2006-11-21 01:40:57 +0000
committerLeonardo Boshell <leonardop@gentoo.org>2006-11-21 01:40:57 +0000
commit7818c154c47677414096e81b674c12c61f88bb9d (patch)
tree0f681b73e453d3b1c70974a8dde501e61ebd66ef /mail-client/evolution
parentDropped 'dbus' USE flag since the code doesn't actually use dbus. Cleaning ol... (diff)
downloadgentoo-2-7818c154c47677414096e81b674c12c61f88bb9d.tar.gz
gentoo-2-7818c154c47677414096e81b674c12c61f88bb9d.tar.bz2
gentoo-2-7818c154c47677414096e81b674c12c61f88bb9d.zip
Adjusted dbus dependency (bug #154521). Pruning old ebuilds/patches.
(Portage version: 2.1.2_rc1-r7)
Diffstat (limited to 'mail-client/evolution')
-rw-r--r--mail-client/evolution/ChangeLog12
-rw-r--r--mail-client/evolution/evolution-2.6.2-r1.ebuild13
-rw-r--r--mail-client/evolution/evolution-2.8.1.1.ebuild13
3 files changed, 27 insertions, 11 deletions
diff --git a/mail-client/evolution/ChangeLog b/mail-client/evolution/ChangeLog
index a1953111ac04..9d30e1e5ad4c 100644
--- a/mail-client/evolution/ChangeLog
+++ b/mail-client/evolution/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for mail-client/evolution
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/evolution/ChangeLog,v 1.149 2006/10/26 15:33:07 dang Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/evolution/ChangeLog,v 1.150 2006/11/21 01:40:57 leonardop Exp $
+
+ 21 Nov 2006; Leonardo Boshell <leonardop@gentoo.org>
+ evolution-2.6.2-r1.ebuild, evolution-2.8.1.1.ebuild:
+ Adjusted dbus dependency (bug #154521).
+
+ 21 Nov 2006; Leonardo Boshell <leonardop@gentoo.org>
+ evolution-2.6.2-r1.ebuild:
+ Set evolution-data-server dependecy version to =1.6*, since the internal
+ structure of EContactPhoto is different in >=1.7.90, breaking compilation
+ (bug #148431).
26 Oct 2006; Daniel Gryniewicz <dang@gentoo.org> evolution-2.8.1.1.ebuild:
evo 2.8 needs glib 2.10 or better
diff --git a/mail-client/evolution/evolution-2.6.2-r1.ebuild b/mail-client/evolution/evolution-2.6.2-r1.ebuild
index 9a49e1e4a9ac..a44815aa2492 100644
--- a/mail-client/evolution/evolution-2.6.2-r1.ebuild
+++ b/mail-client/evolution/evolution-2.6.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/evolution/evolution-2.6.2-r1.ebuild,v 1.9 2006/10/20 23:03:15 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/evolution/evolution-2.6.2-r1.ebuild,v 1.10 2006/11/21 01:40:57 leonardop Exp $
inherit eutils flag-o-matic alternatives gnome2 autotools
@@ -15,15 +15,18 @@ KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86"
IUSE="bogofilter crypt dbus debug doc gstreamer hal ipv6 kerberos krb4 ldap mono nntp pda profile spell ssl widescreen"
# Pango dependency required to avoid font rendering problems
+
# evolution-data-server dep is 1.5 because in the e-utils directories,
-# the includes reference locations only present in eds > 1.5
+# the includes reference locations only present in eds > 1.5.
+# See also bug #148431.
+
RDEPEND=">=x11-themes/gnome-icon-theme-1.2
dev-libs/atk
>=gnome-extra/gtkhtml-3.9.90
>=dev-libs/glib-2
>=gnome-base/orbit-2.9.8
>=gnome-base/libbonobo-2
- >=gnome-extra/evolution-data-server-1.5.90
+ =gnome-extra/evolution-data-server-1.6*
>=gnome-base/libbonoboui-2.4.2
>=gnome-base/gnome-vfs-2.4
>=gnome-base/libgnomeui-2
@@ -51,7 +54,9 @@ RDEPEND=">=x11-themes/gnome-icon-theme-1.2
gstreamer? (
>=media-libs/gstreamer-0.10
>=media-libs/gst-plugins-base-0.10 )
- dbus? ( sys-apps/dbus )
+ dbus? ( || (
+ dev-libs/dbus-glib
+ ( >=sys-apps/dbus-0.61 <sys-apps/dbus-0.90 ) ) )
mono? ( >=dev-lang/mono-1 )
bogofilter? ( mail-filter/bogofilter )
!bogofilter? ( mail-filter/spamassassin )"
diff --git a/mail-client/evolution/evolution-2.8.1.1.ebuild b/mail-client/evolution/evolution-2.8.1.1.ebuild
index 95e44fc463d4..55a326b7035d 100644
--- a/mail-client/evolution/evolution-2.8.1.1.ebuild
+++ b/mail-client/evolution/evolution-2.8.1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/evolution/evolution-2.8.1.1.ebuild,v 1.2 2006/10/26 15:33:07 dang Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/evolution/evolution-2.8.1.1.ebuild,v 1.3 2006/11/21 01:40:57 leonardop Exp $
inherit eutils flag-o-matic alternatives gnome2 autotools
@@ -16,8 +16,6 @@ KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
IUSE="bogofilter crypt dbus debug doc hal ipv6 kerberos krb4 ldap mono nntp pda profile spell ssl"
# Pango dependency required to avoid font rendering problems
-# evolution-data-server dep is 1.5 because in the e-utils directories,
-# the includes reference locations only present in eds > 1.5
RDEPEND=">=x11-themes/gnome-icon-theme-1.2
dev-libs/atk
>=gnome-extra/gtkhtml-3.9.90
@@ -45,12 +43,15 @@ RDEPEND=">=x11-themes/gnome-icon-theme-1.2
>=app-pda/gnome-pilot-conduits-2 )
spell? ( >=app-text/gnome-spell-1.0.5 )
crypt? ( >=app-crypt/gnupg-1.2.2 )
- ssl? ( >=dev-libs/nspr-4.6.1
- >=dev-libs/nss-3.11 )
+ ssl? (
+ >=dev-libs/nspr-4.6.1
+ >=dev-libs/nss-3.11 )
ldap? ( >=net-nds/openldap-2 )
kerberos? ( virtual/krb5 )
krb4? ( virtual/krb5 )
- dbus? ( sys-apps/dbus )
+ dbus? ( || (
+ dev-libs/dbus-glib
+ ~sys-apps/dbus-0.62 ) )
mono? ( >=dev-lang/mono-1 )
bogofilter? ( mail-filter/bogofilter )
!bogofilter? ( mail-filter/spamassassin )"