summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Martin <slarti@gentoo.org>2006-04-08 10:51:45 +0000
committerTom Martin <slarti@gentoo.org>2006-04-08 10:51:45 +0000
commitde0b04b4584abc9d2452b0e36c04d3a844673857 (patch)
treeebedec54a33a92c2d1e5711dc42025e28995f548 /mail-client/mail-notification
parentRemove old, not working version (bug #119814 and #123974); Version bump (diff)
downloadgentoo-2-de0b04b4584abc9d2452b0e36c04d3a844673857.tar.gz
gentoo-2-de0b04b4584abc9d2452b0e36c04d3a844673857.tar.bz2
gentoo-2-de0b04b4584abc9d2452b0e36c04d3a844673857.zip
Add a few ebuild fixes for Evolution 2.6; thanks to Ben Davis <ben@xsusio.com> in bug #127430. The ebuilds should now scale better to future versions of Evolution.
(Portage version: 2.1_pre7-r4)
Diffstat (limited to 'mail-client/mail-notification')
-rw-r--r--mail-client/mail-notification/ChangeLog9
-rw-r--r--mail-client/mail-notification/files/mail-notification-2.0-evolution-2.6.diff52
-rw-r--r--mail-client/mail-notification/mail-notification-2.0.ebuild17
3 files changed, 71 insertions, 7 deletions
diff --git a/mail-client/mail-notification/ChangeLog b/mail-client/mail-notification/ChangeLog
index 9a9cf06108d7..3d1ba6659692 100644
--- a/mail-client/mail-notification/ChangeLog
+++ b/mail-client/mail-notification/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for mail-client/mail-notification
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/mail-notification/ChangeLog,v 1.27 2006/03/15 00:43:31 allanonjl Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/mail-notification/ChangeLog,v 1.28 2006/04/08 10:51:45 slarti Exp $
+
+ 08 Apr 2006; Tom Martin <slarti@gentoo.org>
+ +files/mail-notification-2.0-evolution-2.6.diff,
+ mail-notification-2.0.ebuild:
+ Add a few ebuild fixes for Evolution 2.6; thanks to Ben Davis
+ <ben@xsusio.com> in bug #127430. The ebuilds should now scale better to
+ future versions of Evolution.
14 Mar 2006; John N. Laliberte <allanonjl@gentoo.org>
mail-notification-2.0.ebuild:
diff --git a/mail-client/mail-notification/files/mail-notification-2.0-evolution-2.6.diff b/mail-client/mail-notification/files/mail-notification-2.0-evolution-2.6.diff
new file mode 100644
index 000000000000..2b853f5569a1
--- /dev/null
+++ b/mail-client/mail-notification/files/mail-notification-2.0-evolution-2.6.diff
@@ -0,0 +1,52 @@
+--- configure.orig Mon Oct 24 10:40:20 2005
++++ configure Mon Oct 24 10:40:46 2005
+@@ -24784,12 +24784,12 @@
+ if test "x$ac_cv_env_EVOLUTION_PLUGIN_CFLAGS_set" = "xset"; then
+ pkg_cv_EVOLUTION_PLUGIN_CFLAGS=$ac_cv_env_EVOLUTION_PLUGIN_CFLAGS_value
+ elif test -n "$PKG_CONFIG"; then
+- if { (echo "$as_me:$LINENO: \$PKG_CONFIG --exists \"evolution-plugin-2.2 \$evolution_plugin_min_version\" >/dev/null 2>&1") >&5
+- ($PKG_CONFIG --exists "evolution-plugin-2.2 $evolution_plugin_min_version" >/dev/null 2>&1) 2>&5
++ if { (echo "$as_me:$LINENO: \$PKG_CONFIG --exists \"evolution-plugin-2.6 \$evolution_plugin_min_version\" >/dev/null 2>&1") >&5
++ ($PKG_CONFIG --exists "evolution-plugin-2.6 $evolution_plugin_min_version" >/dev/null 2>&1) 2>&5
+ ac_status=$?
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); }; then
+- pkg_cv_EVOLUTION_PLUGIN_CFLAGS=`$PKG_CONFIG --cflags "evolution-plugin-2.2 $evolution_plugin_min_version" 2>/dev/null`
++ pkg_cv_EVOLUTION_PLUGIN_CFLAGS=`$PKG_CONFIG --cflags "evolution-plugin-2.6 $evolution_plugin_min_version" 2>/dev/null`
+ else
+ pkg_failed=yes
+ fi
+@@ -24807,12 +24807,12 @@
+ if test "x$ac_cv_env_EVOLUTION_PLUGIN_LIBS_set" = "xset"; then
+ pkg_cv_EVOLUTION_PLUGIN_LIBS=$ac_cv_env_EVOLUTION_PLUGIN_LIBS_value
+ elif test -n "$PKG_CONFIG"; then
+- if { (echo "$as_me:$LINENO: \$PKG_CONFIG --exists \"evolution-plugin-2.2 \$evolution_plugin_min_version\" >/dev/null 2>&1") >&5
+- ($PKG_CONFIG --exists "evolution-plugin-2.2 $evolution_plugin_min_version" >/dev/null 2>&1) 2>&5
++ if { (echo "$as_me:$LINENO: \$PKG_CONFIG --exists \"evolution-plugin-2.6 \$evolution_plugin_min_version\" >/dev/null 2>&1") >&5
++ ($PKG_CONFIG --exists "evolution-plugin-2.6 $evolution_plugin_min_version" >/dev/null 2>&1) 2>&5
+ ac_status=$?
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); }; then
+- pkg_cv_EVOLUTION_PLUGIN_LIBS=`$PKG_CONFIG --libs "evolution-plugin-2.2 $evolution_plugin_min_version" 2>/dev/null`
++ pkg_cv_EVOLUTION_PLUGIN_LIBS=`$PKG_CONFIG --libs "evolution-plugin-2.6 $evolution_plugin_min_version" 2>/dev/null`
+ else
+ pkg_failed=yes
+ fi
+@@ -24824,7 +24824,7 @@
+ echo "${ECHO_T}$pkg_cv_EVOLUTION_PLUGIN_LIBS" >&6
+
+ if test $pkg_failed = yes; then
+- EVOLUTION_PLUGIN_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "evolution-plugin-2.2 $evolution_plugin_min_version"`
++ EVOLUTION_PLUGIN_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "evolution-plugin-2.6 $evolution_plugin_min_version"`
+ # Put the nasty error message in config.log where it belongs
+ echo "$EVOLUTION_PLUGIN_PKG_ERRORS" 1>&5
+
+@@ -24841,7 +24841,7 @@
+ if test $found = yes; then
+ echo "$as_me:$LINENO: checking for the Evolution plugin directory" >&5
+ echo $ECHO_N "checking for the Evolution plugin directory... $ECHO_C" >&6
+- evolution_plugindir=`$PKG_CONFIG --variable=plugindir evolution-plugin-2.2 2>/dev/null`
++ evolution_plugindir=`$PKG_CONFIG --variable=plugindir evolution-plugin-2.6 2>/dev/null`
+ if test -n "$evolution_plugindir"; then
+ echo "$as_me:$LINENO: result: $evolution_plugindir" >&5
+ echo "${ECHO_T}$evolution_plugindir" >&6
diff --git a/mail-client/mail-notification/mail-notification-2.0.ebuild b/mail-client/mail-notification/mail-notification-2.0.ebuild
index 86251795d43b..ee6f4d13f2b1 100644
--- a/mail-client/mail-notification/mail-notification-2.0.ebuild
+++ b/mail-client/mail-notification/mail-notification-2.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/mail-notification/mail-notification-2.0.ebuild,v 1.5 2006/03/15 00:43:31 allanonjl Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/mail-notification/mail-notification-2.0.ebuild,v 1.6 2006/04/08 10:51:45 slarti Exp $
inherit eutils gnome2 multilib flag-o-matic
@@ -34,6 +34,10 @@ DEPEND=">=x11-libs/gtk+-2.6
sylpheed? ( virtual/sylpheed )"
pkg_setup() {
+ if use evolution ; then
+ EVO_VERSION="$(best_version mail-client/evolution)"
+ fi
+
G2CONF="${G2CONF} $(use_enable ssl)"
G2CONF="${G2CONF} $(use_enable sasl)"
G2CONF="${G2CONF} $(use_enable ipv6)"
@@ -42,7 +46,7 @@ pkg_setup() {
G2CONF="${G2CONF} $(use_enable pop pop3)"
G2CONF="${G2CONF} $(use_enable gmail)"
G2CONF="${G2CONF} $(use_enable evolution)"
- G2CONF="${G2CONF} --with-evolution-source-dir=/usr/include/evolution-2.4/"
+ G2CONF="${G2CONF} --with-evolution-source-dir=/usr/include/${EVO_VERSION}/"
G2CONF="${G2CONF} $(use_enable sylpheed)"
}
@@ -50,9 +54,9 @@ src_unpack() {
unpack ${A}
cd ${S}
- epatch ${FILESDIR}/${P}-evolution-2.4.diff
- epatch ${FILESDIR}/${P}-buildfix.diff
- epatch ${FILESDIR}/${P}-gmail-properties-fix.diff
+ epatch "${FILESDIR}/${P}-evolution-${EVO_VERSION}.diff"
+ epatch "${FILESDIR}/${P}-buildfix.diff"
+ epatch "${FILESDIR}/${P}-gmail-properties-fix.diff"
gnome2_omf_fix
}
@@ -63,7 +67,8 @@ src_compile() {
}
src_install() {
- gnome2_src_install evolution_plugindir="/usr/$(get_libdir)/evolution/2.4/plugins"
+ gnome2_src_install
+ evolution_plugindir="/usr/$(get_libdir)/evolution/${EVO_VERSION}/plugins"
}
pkg_postinst() {