summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2010-07-11 23:12:53 +0000
committerSebastian Pipping <sping@gentoo.org>2010-07-11 23:12:53 +0000
commitded77643df424db12064afee4b11e08d7bd05d7d (patch)
treebc6025016095d3c8b9e7185e9f26108293a3703c /mail-client/mailx
parentNew alpha release with a truckload of bug fixes. (diff)
downloadgentoo-2-ded77643df424db12064afee4b11e08d7bd05d7d.tar.gz
gentoo-2-ded77643df424db12064afee4b11e08d7bd05d7d.tar.bz2
gentoo-2-ded77643df424db12064afee4b11e08d7bd05d7d.zip
mail-client/mailx: Apply patch to fix compile error (bug #310493)
(Portage version: 2.2_rc67_p185/cvs/Linux i686)
Diffstat (limited to 'mail-client/mailx')
-rw-r--r--mail-client/mailx/ChangeLog10
-rw-r--r--mail-client/mailx/files/mailx-8.1.2.20050715-offsetof.patch36
-rw-r--r--mail-client/mailx/mailx-8.1.2.20050715-r2.ebuild63
3 files changed, 108 insertions, 1 deletions
diff --git a/mail-client/mailx/ChangeLog b/mail-client/mailx/ChangeLog
index dfe156f264cb..55da082d7ecb 100644
--- a/mail-client/mailx/ChangeLog
+++ b/mail-client/mailx/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for mail-client/mailx
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/mailx/ChangeLog,v 1.54 2010/01/11 17:57:56 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/mailx/ChangeLog,v 1.55 2010/07/11 23:12:53 sping Exp $
+
+*mailx-8.1.2.20050715-r2 (11 Jul 2010)
+
+ 11 Jul 2010; Sebastian Pipping <sping@gentoo.org>
+ +mailx-8.1.2.20050715-r2.ebuild,
+ +files/mailx-8.1.2.20050715-offsetof.patch:
+ Apply patch 225901 by Vasiliy A. Balkanov renaming internal macro
+ offsetof() to offsetofmailx() to fix a compile error (bug #310493)
11 Jan 2010; Raúl Porcel <armin76@gentoo.org>
mailx-8.1.2.20040524-r1.ebuild, mailx-8.1.2.20050715.ebuild,
diff --git a/mail-client/mailx/files/mailx-8.1.2.20050715-offsetof.patch b/mail-client/mailx/files/mailx-8.1.2.20050715-offsetof.patch
new file mode 100644
index 000000000000..7af81285d33c
--- /dev/null
+++ b/mail-client/mailx/files/mailx-8.1.2.20050715-offsetof.patch
@@ -0,0 +1,36 @@
+diff -r -u mailx-8.1.2-0.20050715cvs.orig.orig/def.h mailx-8.1.2-0.20050715cvs.orig/def.h
+--- mailx-8.1.2-0.20050715cvs.orig.orig/def.h 2003-10-14 21:50:20.000000000 +0900
++++ mailx-8.1.2-0.20050715cvs.orig/def.h 2010-03-31 10:29:37.000000000 +0900
+@@ -97,7 +97,7 @@
+ * Given a file address, determine the block number it represents.
+ */
+ #define blockof(off) ((int) ((off) / 4096))
+-#define offsetof(off) ((int) ((off) % 4096))
++#define offsetofmailx(off) ((int) ((off) % 4096))
+ #define positionof(block, offset) ((off_t)(block) * 4096 + (offset))
+
+ /*
+diff -r -u mailx-8.1.2-0.20050715cvs.orig.orig/edit.c mailx-8.1.2-0.20050715cvs.orig/edit.c
+--- mailx-8.1.2-0.20050715cvs.orig.orig/edit.c 2004-05-25 01:34:32.000000000 +0900
++++ mailx-8.1.2-0.20050715cvs.orig/edit.c 2010-03-31 10:41:28.000000000 +0900
+@@ -111,7 +111,7 @@
+ (void)fseek(otf, 0L, 2);
+ size = ftell(otf);
+ mp->m_block = blockof(size);
+- mp->m_offset = offsetof(size);
++ mp->m_offset = offsetofmailx(size);
+ mp->m_size = fsize(fp);
+ mp->m_lines = 0;
+ mp->m_flag |= MODIFY;
+diff -r -u mailx-8.1.2-0.20050715cvs.orig.orig/fio.c mailx-8.1.2-0.20050715cvs.orig/fio.c
+--- mailx-8.1.2-0.20050715cvs.orig.orig/fio.c 2004-05-25 01:34:32.000000000 +0900
++++ mailx-8.1.2-0.20050715cvs.orig/fio.c 2010-03-31 10:29:28.000000000 +0900
+@@ -139,7 +139,7 @@
+ this.m_size = 0;
+ this.m_lines = 0;
+ this.m_block = blockof(offset);
+- this.m_offset = offsetof(offset);
++ this.m_offset = offsetofmailx(offset);
+ inhead = 1;
+ } else if (linebuf[0] == 0) {
+ inhead = 0;
diff --git a/mail-client/mailx/mailx-8.1.2.20050715-r2.ebuild b/mail-client/mailx/mailx-8.1.2.20050715-r2.ebuild
new file mode 100644
index 000000000000..b0a59c5ec9d5
--- /dev/null
+++ b/mail-client/mailx/mailx-8.1.2.20050715-r2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/mailx/mailx-8.1.2.20050715-r2.ebuild,v 1.1 2010/07/11 23:12:53 sping Exp $
+
+inherit eutils flag-o-matic
+
+MX_MAJ_VER=${PV%.*}
+MX_MIN_VER=${PV##*.}
+MY_PV=${MX_MAJ_VER}-0.${MX_MIN_VER}cvs
+S=${WORKDIR}/${PN}-${MY_PV}.orig/
+debian_patch=${PN}_${MY_PV}-1.diff.gz
+
+DESCRIPTION="The /bin/mail program, which is used to send mail via shell scripts"
+HOMEPAGE="http://www.debian.org/"
+SRC_URI="mirror://gentoo/mailx_${MY_PV}.orig.tar.gz
+ mirror://gentoo/${debian_patch}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+DEPEND=">=net-libs/liblockfile-1.03
+ virtual/mta
+ !mail-client/mailutils
+ mail-client/mailx-support
+ !virtual/mailx"
+PROVIDE="virtual/mailx"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${DISTDIR}/${debian_patch}"
+ epatch "${FILESDIR}/${P}-nostrip.patch"
+ sed -i -e "s: -O2: \$(EXTRAFLAGS):g" Makefile
+ epatch "${FILESDIR}/${P}-offsetof.patch"
+}
+
+src_compile() {
+ make EXTRAFLAGS="${CFLAGS}" || die
+}
+
+src_install() {
+ dodir /bin /usr/share/man/man1 /etc /usr/lib
+
+ insinto /bin
+ insopts -m 755
+ doins mail || die
+
+ doman mail.1
+
+ dosym mail /bin/Mail
+ dosym mail /bin/mailx
+ dosym mail.1 /usr/share/man/man1/Mail.1
+
+ cd "${S}"/misc
+ insinto /usr/share/${PN}/
+ insopts -m 644
+ doins mail.help mail.tildehelp || die
+ insinto /etc
+ insopts -m 644
+ doins mail.rc || die
+}