summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2009-01-11 11:19:55 +0000
committerFabian Groffen <grobian@gentoo.org>2009-01-11 11:19:55 +0000
commitb7bc30a41cf12d919d153500cec1eb139074b7b5 (patch)
tree698636764f821c17c8aae66ad869f63a21b81a77 /mail-client/mutt
parentdrop system libltdl usage as it causes crashes (diff)
downloadgentoo-2-b7bc30a41cf12d919d153500cec1eb139074b7b5.tar.gz
gentoo-2-b7bc30a41cf12d919d153500cec1eb139074b7b5.tar.bz2
gentoo-2-b7bc30a41cf12d919d153500cec1eb139074b7b5.zip
Version bump. Added new patches in Gentoo patchset. Masked because sidebar patch does not apply. Acked by Ferdy.
(Portage version: 2.1.4.5)
Diffstat (limited to 'mail-client/mutt')
-rw-r--r--mail-client/mutt/ChangeLog10
-rw-r--r--mail-client/mutt/mutt-1.5.19.ebuild207
2 files changed, 215 insertions, 2 deletions
diff --git a/mail-client/mutt/ChangeLog b/mail-client/mutt/ChangeLog
index b987ef6ecef3..d23027259bc2 100644
--- a/mail-client/mutt/ChangeLog
+++ b/mail-client/mutt/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for mail-client/mutt
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/mutt/ChangeLog,v 1.122 2008/08/23 01:43:01 cardoe Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/mutt/ChangeLog,v 1.123 2009/01/11 11:19:55 grobian Exp $
+
+*mutt-1.5.19 (11 Jan 2009)
+
+ 11 Jan 2009; Fabian Groffen <grobian@gentoo.org> +mutt-1.5.19.ebuild:
+ Version bump. Added new patches in Gentoo patchset. Masked because sidebar
+ patch does not apply.
23 Aug 2008; Doug Goldstein <cardoe@gentoo.org> metadata.xml:
add GLEP 56 USE flag desc from use.local.desc
diff --git a/mail-client/mutt/mutt-1.5.19.ebuild b/mail-client/mutt/mutt-1.5.19.ebuild
new file mode 100644
index 000000000000..21931273ad82
--- /dev/null
+++ b/mail-client/mutt/mutt-1.5.19.ebuild
@@ -0,0 +1,207 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/mutt/mutt-1.5.19.ebuild,v 1.1 2009/01/11 11:19:55 grobian Exp $
+
+inherit eutils flag-o-matic autotools
+
+PATCHSET_REV=""
+
+# note: latest sidebar patches can be found here:
+# http://www.lunar-linux.org/index.php?option=com_content&task=view&id=44
+SIDEBAR_PATCH_N="patch-1.5.18.sidebar.20080611.txt"
+
+DESCRIPTION="a small but very powerful text-based mail client"
+HOMEPAGE="http://www.mutt.org"
+SRC_URI="ftp://ftp.mutt.org/mutt/devel/${P}.tar.gz
+ !vanilla? (
+ !sidebar? (
+ mirror://gentoo/${P}-gentoo-patches${PATCHSET_REV}.tar.bz2
+ http://dev.gentoo.org/~grobian/distfiles/${P}-gentoo-patches${PATCHSET_REV}.tar.bz2
+ )
+ )
+ sidebar? (
+ http://www.lunar-linux.org/~tchan/mutt/${SIDEBAR_PATCH_N}
+ )"
+IUSE="berkdb crypt debug gdbm gnutls gpgme idn imap mbox nls nntp pop qdbm sasl
+sidebar smime smtp ssl vanilla"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+RDEPEND=">=sys-libs/ncurses-5.2
+ qdbm? ( dev-db/qdbm )
+ !qdbm? (
+ gdbm? ( sys-libs/gdbm )
+ !gdbm? ( berkdb? ( >=sys-libs/db-4 ) )
+ )
+ imap? (
+ gnutls? ( >=net-libs/gnutls-1.0.17 )
+ !gnutls? ( ssl? ( >=dev-libs/openssl-0.9.6 ) )
+ sasl? ( >=dev-libs/cyrus-sasl-2 )
+ )
+ pop? (
+ gnutls? ( >=net-libs/gnutls-1.0.17 )
+ !gnutls? ( ssl? ( >=dev-libs/openssl-0.9.6 ) )
+ sasl? ( >=dev-libs/cyrus-sasl-2 )
+ )
+ smtp? (
+ gnutls? ( >=net-libs/gnutls-1.0.17 )
+ !gnutls? ( ssl? ( >=dev-libs/openssl-0.9.6 ) )
+ sasl? ( >=dev-libs/cyrus-sasl-2 )
+ )
+ idn? ( net-dns/libidn )
+ gpgme? ( >=app-crypt/gpgme-0.9.0 )
+ smime? ( >=dev-libs/openssl-0.9.6 )
+ app-misc/mime-types"
+DEPEND="${RDEPEND}
+ net-mail/mailbase
+ !vanilla? (
+ dev-libs/libxml2
+ dev-libs/libxslt
+ app-text/docbook-xsl-stylesheets
+ || ( www-client/lynx www-client/w3m www-client/elinks )
+ )"
+
+PATCHDIR="${WORKDIR}"/${P}-gentoo-patches${PATCHSET_REV}
+
+src_unpack() {
+ unpack ${A//${SIDEBAR_PATCH_N}} && cd "${S}" || die "unpack failed"
+
+ if ! use vanilla && ! use sidebar ; then
+ use nntp || rm "${PATCHDIR}"/06-nntp.patch
+ for p in "${PATCHDIR}"/*.patch ; do
+ epatch "${p}"
+ done
+ fi
+
+ if use sidebar ; then
+ use vanilla || \
+ ewarn "The sidebar patch is only applied to a vanilla mutt tree."
+ epatch "${DISTDIR}"/${SIDEBAR_PATCH_N}
+ fi
+
+ AT_M4DIR="m4" eautoreconf
+}
+
+src_compile() {
+ declare myconf="
+ $(use_enable nls) \
+ $(use_enable gpgme) \
+ $(use_enable imap) \
+ $(use_enable pop) \
+ $(use_enable smtp) \
+ $(use_enable crypt pgp) \
+ $(use_enable smime) \
+ $(use_enable debug) \
+ $(use_with idn) \
+ --with-curses \
+ --sysconfdir=/etc/${PN} \
+ --with-docdir=/usr/share/doc/${PN}-${PVR} \
+ --with-regex \
+ --enable-nfs-fix --enable-external-dotlock \
+ $(use_with !nntp mixmaster) \
+ --with-exec-shell=/bin/sh"
+
+ case $CHOST in
+ *-darwin7)
+ # locales are broken on Panther
+ myconf="${myconf} --enable-locales-fix --without-wc-funcs"
+ myconf="${myconf} --disable-fcntl --enable-flock"
+ ;;
+ *-darwin*)
+ # wc-funcs are buggy on OSX
+ myconf="${myconf} --without-wc-funcs"
+ myconf="${myconf} --disable-fcntl --enable-flock"
+ ;;
+ *-solaris*)
+ # Solaris has no flock in the standard headers
+ myconf="${myconf} --enable-fcntl --disable-flock"
+ ;;
+ *)
+ myconf="${myconf} --disable-fcntl --enable-flock"
+ ;;
+ esac
+
+ # See Bug #22787
+ unset WANT_AUTOCONF_2_5 WANT_AUTOCONF
+
+ # mutt prioritizes gdbm over bdb, so we will too.
+ # hcache feature requires at least one database is in USE.
+ if use qdbm; then
+ myconf="${myconf} --enable-hcache \
+ --with-qdbm --without-gdbm --without-bdb"
+ elif use gdbm ; then
+ myconf="${myconf} --enable-hcache \
+ --without-qdbm --with-gdbm --without-bdb"
+ elif use berkdb; then
+ myconf="${myconf} --enable-hcache \
+ --without-gdbm --without-qdbm --with-bdb"
+ else
+ myconf="${myconf} --disable-hcache \
+ --without-qdbm --without-gdbm --without-bdb"
+ fi
+
+ # there's no need for gnutls, ssl or sasl without socket support
+ if use pop || use imap || use smtp ; then
+ if use gnutls; then
+ myconf="${myconf} --with-gnutls"
+ elif use ssl; then
+ myconf="${myconf} --with-ssl"
+ fi
+ # not sure if this should be mutually exclusive with the other two
+ myconf="${myconf} $(use_with sasl)"
+ else
+ myconf="${myconf} --without-gnutls --without-ssl --without-sasl"
+ fi
+
+ # See Bug #11170
+ case ${ARCH} in
+ alpha|ppc) replace-flags "-O[3-9]" "-O2" ;;
+ esac
+
+ if use mbox; then
+ myconf="${myconf} --with-mailpath=/var/spool/mail"
+ else
+ myconf="${myconf} --with-homespool=Maildir"
+ fi
+
+ if ! use vanilla; then
+ # rr.compressed patch
+ myconf="${myconf} --enable-compressed"
+
+ # nntp patch
+ myconf="${myconf} $(use_enable nntp)"
+ fi
+
+ econf ${myconf} || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "install failed"
+ find "${D}"/usr/share/doc -type f | grep -v "html\|manual" | xargs gzip
+ if use mbox; then
+ insinto /etc/mutt
+ newins "${FILESDIR}"/Muttrc.mbox Muttrc
+ else
+ insinto /etc/mutt
+ doins "${FILESDIR}"/Muttrc
+ fi
+
+ # A newer file is provided by app-misc/mime-types. So we link it.
+ rm "${D}"/etc/${PN}/mime.types
+ dosym /etc/mime.types /etc/${PN}/mime.types
+
+ # charset.alias is installed by libiconv
+ rm -f "${D}"/usr/lib/charset.alias
+ rm -f "${D}"/usr/share/locale/locale.alias
+
+ dodoc BEWARE COPYRIGHT ChangeLog NEWS OPS* PATCHES README* TODO VERSION
+}
+
+pkg_postinst() {
+ echo
+ elog "If you are new to mutt you may want to take a look at"
+ elog "the Gentoo QuickStart Guide to Mutt E-Mail:"
+ elog " http://www.gentoo.org/doc/en/guide-to-mutt.xml"
+ echo
+}