summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Kacian <ticho@gentoo.org>2006-10-03 14:24:58 +0000
committerAndrej Kacian <ticho@gentoo.org>2006-10-03 14:24:58 +0000
commit8d1d57d5c870fc786047f7cbdc48a8ced670dd70 (patch)
treebd599e2815258f01664d886f18e4b54416480c8f /mail-client/sylpheed-claws-acpi-notifier
parentBump to 3.5.5 (pre-release) (diff)
downloadgentoo-2-8d1d57d5c870fc786047f7cbdc48a8ced670dd70.tar.gz
gentoo-2-8d1d57d5c870fc786047f7cbdc48a8ced670dd70.tar.bz2
gentoo-2-8d1d57d5c870fc786047f7cbdc48a8ced670dd70.zip
Version bump.
(Portage version: 2.1.2_pre2-r2)
Diffstat (limited to 'mail-client/sylpheed-claws-acpi-notifier')
-rw-r--r--mail-client/sylpheed-claws-acpi-notifier/ChangeLog8
-rw-r--r--mail-client/sylpheed-claws-acpi-notifier/files/digest-sylpheed-claws-acpi-notifier-1.0.33
-rw-r--r--mail-client/sylpheed-claws-acpi-notifier/sylpheed-claws-acpi-notifier-1.0.3.ebuild44
3 files changed, 54 insertions, 1 deletions
diff --git a/mail-client/sylpheed-claws-acpi-notifier/ChangeLog b/mail-client/sylpheed-claws-acpi-notifier/ChangeLog
index 1cd39d989de4..a37e87f43ee6 100644
--- a/mail-client/sylpheed-claws-acpi-notifier/ChangeLog
+++ b/mail-client/sylpheed-claws-acpi-notifier/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for mail-client/sylpheed-claws-acpi-notifier
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed-claws-acpi-notifier/ChangeLog,v 1.4 2006/07/06 23:19:32 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed-claws-acpi-notifier/ChangeLog,v 1.5 2006/10/03 14:24:58 ticho Exp $
+
+*sylpheed-claws-acpi-notifier-1.0.3 (03 Oct 2006)
+
+ 03 Oct 2006; <ticho@gentoo.org>
+ +sylpheed-claws-acpi-notifier-1.0.3.ebuild:
+ Version bump.
06 Jul 2006; Marius Mauch <genone@gentoo.org>
sylpheed-claws-acpi-notifier-0.8.ebuild,
diff --git a/mail-client/sylpheed-claws-acpi-notifier/files/digest-sylpheed-claws-acpi-notifier-1.0.3 b/mail-client/sylpheed-claws-acpi-notifier/files/digest-sylpheed-claws-acpi-notifier-1.0.3
new file mode 100644
index 000000000000..0c6e57480b5b
--- /dev/null
+++ b/mail-client/sylpheed-claws-acpi-notifier/files/digest-sylpheed-claws-acpi-notifier-1.0.3
@@ -0,0 +1,3 @@
+MD5 db771d49bf9bde1cce075b93f8028a19 sylpheed-claws-extra-plugins-2.5.2.tar.bz2 3991186
+RMD160 8e59b11fdcf6dbee11ca2c28d7616593d420333a sylpheed-claws-extra-plugins-2.5.2.tar.bz2 3991186
+SHA256 2ac9469dfb914ab20fd73b75388db6e3e0a305883c789e34a5c9458feb838349 sylpheed-claws-extra-plugins-2.5.2.tar.bz2 3991186
diff --git a/mail-client/sylpheed-claws-acpi-notifier/sylpheed-claws-acpi-notifier-1.0.3.ebuild b/mail-client/sylpheed-claws-acpi-notifier/sylpheed-claws-acpi-notifier-1.0.3.ebuild
new file mode 100644
index 000000000000..cec4a0a96663
--- /dev/null
+++ b/mail-client/sylpheed-claws-acpi-notifier/sylpheed-claws-acpi-notifier-1.0.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed-claws-acpi-notifier/sylpheed-claws-acpi-notifier-1.0.3.ebuild,v 1.1 2006/10/03 14:24:58 ticho Exp $
+
+inherit eutils
+
+MY_PN="${PN#sylpheed-claws-}"
+MY_PN="${MY_PN/-/_}"
+MY_P="${MY_PN}-${PV}"
+SC_BASE="2.5.2"
+SC_BASE_NAME="sylpheed-claws-extra-plugins-${SC_BASE}"
+
+DESCRIPTION="This plugin enables mail notification via LEDs on some laptops."
+HOMEPAGE="http://claws.sylpheed.org"
+SRC_URI="mirror://sourceforge/sylpheed-claws/${SC_BASE_NAME}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+DEPEND=">=mail-client/sylpheed-claws-${SC_BASE}"
+
+S="${WORKDIR}/${SC_BASE_NAME}/${MY_P}"
+
+src_install() {
+ make DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog NEWS README
+
+ # kill useless files
+ rm -f ${D}usr/lib*/sylpheed-claws/plugins/*.{a,la}
+}
+
+pkg_postinst() {
+ PROC_IFACES="$(echo /proc/acpi/{asus/mled,ibm/led,acer/mailled}) /proc/driver/acerhk/led"
+
+ local procfile
+ local message_shown=false
+
+ for procfile in ${PROC_IFACES}; do
+ if [[ -f ${procfile} ]]; then
+ elog "Make sure ${procfile} is writable by users of this plugin."
+ message_shown=true
+ fi
+ done
+}