summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2012-10-06 08:58:28 +0000
committerPacho Ramos <pacho@gentoo.org>2012-10-06 08:58:28 +0000
commit0b7b4150fcd2c56aaa258844cd363bbbc664347a (patch)
treeca8fb36fa949ac208e9759d523b578dcd0613824 /mail-client
parentarm stable, bug #427544 (diff)
downloadgentoo-2-0b7b4150fcd2c56aaa258844cd363bbbc664347a.tar.gz
gentoo-2-0b7b4150fcd2c56aaa258844cd363bbbc664347a.tar.bz2
gentoo-2-0b7b4150fcd2c56aaa258844cd363bbbc664347a.zip
Revision bump syncing with fedora, it includes a snapshot incorporating most of the fixes have been around different distributions for years, also port it to gtk3, gmime-2.6 and stop using glade. It's also compatible with Gnome3. Taken maintainership also.
(Portage version: 2.1.11.24/cvs/Linux x86_64)
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/mail-notification/ChangeLog11
-rw-r--r--mail-client/mail-notification/mail-notification-5.4-r6.ebuild103
-rw-r--r--mail-client/mail-notification/metadata.xml3
3 files changed, 116 insertions, 1 deletions
diff --git a/mail-client/mail-notification/ChangeLog b/mail-client/mail-notification/ChangeLog
index e105e9332702..ed9fdf2b563a 100644
--- a/mail-client/mail-notification/ChangeLog
+++ b/mail-client/mail-notification/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for mail-client/mail-notification
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/mail-notification/ChangeLog,v 1.112 2012/05/21 23:35:20 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/mail-notification/ChangeLog,v 1.113 2012/10/06 08:58:28 pacho Exp $
+
+*mail-notification-5.4-r6 (06 Oct 2012)
+
+ 06 Oct 2012; Pacho Ramos <pacho@gentoo.org> +mail-notification-5.4-r6.ebuild,
+ metadata.xml:
+ Revision bump syncing with fedora, it includes a snapshot incorporating most
+ of the fixes have been around different distributions for years, also port it
+ to gtk3, gmime-2.6 and stop using glade. It's also compatible with Gnome3.
+ Taken maintainership also.
21 May 2012; Mike Frysinger <vapier@gentoo.org>
mail-notification-5.4-r4.ebuild, mail-notification-5.4-r5.ebuild:
diff --git a/mail-client/mail-notification/mail-notification-5.4-r6.ebuild b/mail-client/mail-notification/mail-notification-5.4-r6.ebuild
new file mode 100644
index 000000000000..5ab6d9c90974
--- /dev/null
+++ b/mail-client/mail-notification/mail-notification-5.4-r6.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/mail-notification/mail-notification-5.4-r6.ebuild,v 1.1 2012/10/06 08:58:28 pacho Exp $
+
+EAPI=4
+inherit gnome2 multilib flag-o-matic toolchain-funcs eutils
+
+DESCRIPTION="A GNOME trayicon which checks for email, with support for many online and offline mailbox formats."
+HOMEPAGE="http://www.nongnu.org/mailnotify/ https://github.com/epienbroek/mail-notification"
+
+GIT_REVISION="b4ca832" # Same as Fedora
+SRC_URI="https://github.com/epienbroek/${PN}/tarball/${GIT_REVISION} -> ${PN}-${GIT_REVISION}.tar.gz"
+S="${WORKDIR}/epienbroek-${PN}-${GIT_REVISION}"
+
+KEYWORDS="~amd64 ~x86 ~x86-linux"
+SLOT="0"
+LICENSE="GPL-3"
+IUSE="evo +gnome-keyring sasl +sound ssl sylpheed"
+
+LANGS="bg ca cs de es fr ja nl pl pt pt_BR ru sr sr@Latn sv"
+for lang in ${LANGS}; do
+ IUSE+=" linguas_${lang}"
+done
+
+# gmime is actually optional, but it's used by so much of the package
+# it's pointless making it optional. gnome-keyring is required for
+# several specific access methods, and thus linked to those USE flags
+# instead of adding a keyring USE flag.
+RDEPEND="x11-libs/gtk+:3
+ >=dev-libs/glib-2.14
+ >=gnome-base/gconf-2.6
+ >=gnome-base/libgnomeui-2.14
+ dev-libs/dbus-glib
+ dev-libs/gmime:2.6
+ >=x11-libs/libnotify-0.4.1
+ gnome-keyring? ( gnome-base/libgnome-keyring )
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ sasl? ( >=dev-libs/cyrus-sasl-2 )
+ sound? ( media-libs/gstreamer:0.10 )
+ evo? ( >=mail-client/evolution-3 )
+ sylpheed? ( mail-client/sylpheed )"
+
+DEPEND="${RDEPEND}
+ app-text/scrollkeeper
+ dev-util/gob
+ virtual/pkgconfig
+ >=dev-util/intltool-0.35.0"
+
+# this now uses JB (the Jean-Yves Lefort's Build System) as a build system
+# instead of autotools, this is a little helper function that basically does
+# the same thing as use_enable
+use_var() {
+ echo "${2:-$1}=$(usex $1)"
+}
+
+src_prepare() {
+ sed -i -e '/jb_rule_set_install_message/d' \
+ -e '/jb_rule_add_install_command/d' \
+ jbsrc/jb.c || die
+
+ # We are not Ubuntu, and I suspect that this is the cause of #215281
+ epatch "${FILESDIR}/${P}-remove-ubuntu-special-case.patch"
+
+ # Fix .desktop files to make them freedesktop compliant
+ sed -i -e '/Encoding/d' data/mail-notification-properties.desktop.in \
+ data/mail-notification.desktop.in || die
+}
+
+src_configure() {
+ set -- \
+ ./jb configure destdir="${D}" prefix="${EPREFIX}/usr" libdir="${EPREFIX}/usr/$(get_libdir)" \
+ sysconfdir="${EPREFIX}/etc" localstatedir="${EPREFIX}/var" cc="$(tc-getCC)" \
+ cflags="${CFLAGS}" cppflags="${CXXFLAGS}" ldflags="${LDFLAGS}" \
+ scrollkeeper-dir="${EPREFIX}/var/lib/scrollkeeper" \
+ $(use_var evo evolution) \
+ $(use_var gnome-keyring gmail) \
+ $(use_var gnome-keyring imap) \
+ $(use_var gnome-keyring pop3) \
+ $(use_var sasl) \
+ $(use_var ssl) \
+ $(use_var sylpheed)
+ echo "$@"
+ "$@" || die
+}
+
+src_compile() {
+ ./jb build || die
+}
+
+src_install() {
+ GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL="1" ./jb install || die
+ dodoc NEWS README AUTHORS TODO TRANSLATING
+ rm -rf "${ED}/var/lib/scrollkeeper"
+
+ einfo "Cleaning up locales..."
+ for lang in ${LANGS}; do
+ use "linguas_${lang}" && {
+ einfo "- keeping ${lang}"
+ continue
+ }
+ rm -Rf "${D}"/usr/share/locale/"${lang}" || die
+ done
+}
diff --git a/mail-client/mail-notification/metadata.xml b/mail-client/mail-notification/metadata.xml
index df9b7c294eb9..22c330757089 100644
--- a/mail-client/mail-notification/metadata.xml
+++ b/mail-client/mail-notification/metadata.xml
@@ -2,6 +2,9 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>net-mail</herd>
+<maintainer>
+ <email>pacho@gentoo.org</email>
+</maintainer>
<longdescription>
A GNOME trayicon which checks for email. Supports mbox, MH,
Maildir, IMAP, Sylpheed, POP3, Gmail and Evolution. Authenticates via