summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2004-08-09 20:25:16 +0000
committerDaniel Black <dragonheart@gentoo.org>2004-08-09 20:25:16 +0000
commit0e7324cf579de2e491e97be87da24a5c22b7110e (patch)
tree02a5eb4ca090355415779cf5605b8583c391df12 /mail-client
parentMarked ~amd64, #59088. (Manifest recommit) (diff)
downloadgentoo-2-0e7324cf579de2e491e97be87da24a5c22b7110e.tar.gz
gentoo-2-0e7324cf579de2e491e97be87da24a5c22b7110e.tar.bz2
gentoo-2-0e7324cf579de2e491e97be87da24a5c22b7110e.zip
overzealous trimming last time. Reintroduced gtk-1 version. Fixes bug #59875
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/balsa/ChangeLog8
-rw-r--r--mail-client/balsa/balsa-1.4.3.ebuild64
-rw-r--r--mail-client/balsa/files/balsa-1.4.0-gentoo.diff23
-rw-r--r--mail-client/balsa/files/digest-balsa-1.4.31
4 files changed, 95 insertions, 1 deletions
diff --git a/mail-client/balsa/ChangeLog b/mail-client/balsa/ChangeLog
index 8be90072b4fc..18ab6cd9a819 100644
--- a/mail-client/balsa/ChangeLog
+++ b/mail-client/balsa/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for mail-client/balsa
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/balsa/ChangeLog,v 1.6 2004/08/09 20:14:09 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/balsa/ChangeLog,v 1.7 2004/08/09 20:25:16 dragonheart Exp $
+
+*balsa-1.4.3 (10 Aug 2004)
+
+ 10 Aug 2004; Daniel Black <dragonheart@gentoo.org>
+ +files/balsa-1.4.0-gentoo.diff, +balsa-1.4.3.ebuild:
+ overzealous trimming last time. Reintroduced gtk-1 version. Fixes bug #59875
*balsa-2.0.14 (10 Aug 2004)
diff --git a/mail-client/balsa/balsa-1.4.3.ebuild b/mail-client/balsa/balsa-1.4.3.ebuild
new file mode 100644
index 000000000000..dd799cca92fb
--- /dev/null
+++ b/mail-client/balsa/balsa-1.4.3.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/balsa/balsa-1.4.3.ebuild,v 1.5 2004/08/09 20:25:16 dragonheart Exp $
+
+inherit eutils
+
+IUSE="ssl nls cups gtkhtml spell perl"
+
+DESCRIPTION="Balsa: email client for GNOME"
+SRC_URI="http://www.theochem.kth.se/~pawsa/${PN}/${P}.tar.bz2"
+HOMEPAGE="http://www.balsa.net"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ~ppc sparc"
+
+DEPEND="=dev-libs/glib-1.2*
+ =x11-libs/gtk+-1.2*
+ >=media-libs/imlib-1.9.10-r1
+ >=gnome-base/gnome-libs-1.4.1.4
+ >=gnome-base/ORBit-0.5.10-r1
+ >=media-libs/gdk-pixbuf-0.13.0
+ >=net-libs/libesmtp-0.8.11
+ nls? ( sys-devel/gettext )
+ ssl? ( dev-libs/openssl )
+ cups? ( >=gnome-base/gnome-print-0.30 )
+ perl? ( >=dev-libs/libpcre-3.4 )
+ spell? ( virtual/aspell-dict )
+ gtkhtml? ( >=gnome-extra/gtkhtml-0.16.1 )"
+
+src_unpack() {
+ unpack ${A}
+
+ # Patch to use the new aspell instead of the old, crusty pspell modules
+ cd ${S}
+ epatch ${FILESDIR}/${PN}-1.4.0-gentoo.diff
+}
+
+src_compile() {
+ local myconf
+
+ use nls || myconf="${myconf} --disable-nls"
+ use ssl && myconf="${myconf} --with-ssl"
+ use gtkhtml && myconf="${myconf} --enable-gtkhtml"
+ use perl && myconf="${myconf} --enable-pcre"
+ use spell && myconf="${myconf} --with-aspell=yes"
+
+ myconf="${myconf} --with-mailpath=/var/mail --enable-threads"
+
+ autoconf || die
+ econf ${myconf} || die "configure balsa failed"
+ emake || die "emake failed"
+}
+
+src_install () {
+ local myinst
+ myinst="gnomeconfdir=${D}/etc \
+ gnomedatadir=${D}/usr/share"
+
+ einstall ${myinst} || die "make install failed"
+ dodoc AUTHORS COPYING ChangeLog HACKING INSTALL NEWS README TODO
+ docinto docs
+ dodoc docs/*
+}
diff --git a/mail-client/balsa/files/balsa-1.4.0-gentoo.diff b/mail-client/balsa/files/balsa-1.4.0-gentoo.diff
new file mode 100644
index 000000000000..2ec9a5276598
--- /dev/null
+++ b/mail-client/balsa/files/balsa-1.4.0-gentoo.diff
@@ -0,0 +1,23 @@
+diff -urN balsa-1.4.0.old/configure.in balsa-1.4.0/configure.in
+--- balsa-1.4.0.old/configure.in Mon Aug 19 11:04:50 2002
++++ balsa-1.4.0/configure.in Tue Sep 10 06:19:57 2002
+@@ -49,9 +49,16 @@
+ dnl this should come after `AC_PROG_CC'
+ GNOME_X_CHECKS
+
+-AC_CHECK_LIB(pspell, new_pspell_manager,,[
+- AC_MSG_ERROR([*** libpspell(-devel) not found. Please check http://balsa.gnome.org/ for information on the required files.])
+-], -lstdc++ -lpspell-modules)
++AC_ARG_WITH(aspell,
++ [ --with-aspell Turn on aspell ],
++ [case "${withval}" in
++ yes) LIBS="-lstdc++ -laspell" ;
++ aspell=true ;;
++ no) LIBS="-lstdc++" ;
++ aspell=false ;;
++ *) AC_MSG_ERROR(bad value ${withval} for --with-aspell) ;;
++ esac],[LIBS=""])
++AM_CONDITIONAL(WITH_ASPELL, test, x$aspell = xtrue)
+
+ dnl Reset
+ # LDFLAGS="$balsa_save_LDFLAGS"
diff --git a/mail-client/balsa/files/digest-balsa-1.4.3 b/mail-client/balsa/files/digest-balsa-1.4.3
new file mode 100644
index 000000000000..ce117b498676
--- /dev/null
+++ b/mail-client/balsa/files/digest-balsa-1.4.3
@@ -0,0 +1 @@
+MD5 26ac08c059d2aaa73bd76d21150a6d24 balsa-1.4.3.tar.bz2 2385240