summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2012-05-24 22:06:14 +0000
committerMike Gilbert <floppym@gentoo.org>2012-05-24 22:06:14 +0000
commit1bedefad74fc6f8423e2c9c2aa3c37bed0230ee8 (patch)
tree1c73b48327c5ad33e83f00b8db7cecafbd1e7d33 /mail-client
parentremove old (diff)
downloadgentoo-2-1bedefad74fc6f8423e2c9c2aa3c37bed0230ee8.tar.gz
gentoo-2-1bedefad74fc6f8423e2c9c2aa3c37bed0230ee8.tar.bz2
gentoo-2-1bedefad74fc6f8423e2c9c2aa3c37bed0230ee8.zip
Convert DOS line-endings in shell scripts. Bug 391889.
(Portage version: 2.2.0_alpha107/cvs/Linux x86_64)
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/thunderbird/ChangeLog6
-rw-r--r--mail-client/thunderbird/thunderbird-10.0.4.ebuild9
-rw-r--r--mail-client/thunderbird/thunderbird-12.0.1-r1.ebuild9
3 files changed, 21 insertions, 3 deletions
diff --git a/mail-client/thunderbird/ChangeLog b/mail-client/thunderbird/ChangeLog
index 29d8cba84180..cf056010c3dc 100644
--- a/mail-client/thunderbird/ChangeLog
+++ b/mail-client/thunderbird/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for mail-client/thunderbird
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/thunderbird/ChangeLog,v 1.143 2012/05/24 12:46:20 anarchy Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/thunderbird/ChangeLog,v 1.144 2012/05/24 22:06:14 floppym Exp $
+
+ 24 May 2012; Mike Gilbert <floppym@gentoo.org> thunderbird-10.0.4.ebuild,
+ thunderbird-12.0.1-r1.ebuild:
+ Convert DOS line-endings in shell scripts. Bug 391889.
24 May 2012; Jory A. Pratt <anarchy@gentoo.org> thunderbird-12.0.1-r1.ebuild:
Fix bug #417329, thanks floppym@gentoo.org
diff --git a/mail-client/thunderbird/thunderbird-10.0.4.ebuild b/mail-client/thunderbird/thunderbird-10.0.4.ebuild
index 86f2f3a6f4df..a9019d416c98 100644
--- a/mail-client/thunderbird/thunderbird-10.0.4.ebuild
+++ b/mail-client/thunderbird/thunderbird-10.0.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/thunderbird/thunderbird-10.0.4.ebuild,v 1.4 2012/05/04 08:42:22 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/thunderbird/thunderbird-10.0.4.ebuild,v 1.5 2012/05/24 22:06:14 floppym Exp $
EAPI="3"
WANT_AUTOCONF="2.1"
@@ -133,6 +133,13 @@ src_prepare() {
-i "${S}"/mozilla/config/system-headers \
-i "${S}"/mozilla/js/src/config/system-headers || die "Sed failed"
+ # Shell scripts sometimes contain DOS line endings; bug 391889
+ grep -rlZ --include="*.sh" $'\r$' . |
+ while read -r -d $'\0' file ; do
+ einfo edos2unix "${file}"
+ edos2unix "${file}"
+ done
+
# Allow user to apply any additional patches without modifing ebuild
epatch_user
diff --git a/mail-client/thunderbird/thunderbird-12.0.1-r1.ebuild b/mail-client/thunderbird/thunderbird-12.0.1-r1.ebuild
index 834dfc3ef705..3117de54884b 100644
--- a/mail-client/thunderbird/thunderbird-12.0.1-r1.ebuild
+++ b/mail-client/thunderbird/thunderbird-12.0.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/thunderbird/thunderbird-12.0.1-r1.ebuild,v 1.2 2012/05/24 12:46:20 anarchy Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/thunderbird/thunderbird-12.0.1-r1.ebuild,v 1.3 2012/05/24 22:06:14 floppym Exp $
EAPI="3"
WANT_AUTOCONF="2.1"
@@ -135,6 +135,13 @@ src_prepare() {
-i "${S}"/mozilla/config/system-headers \
-i "${S}"/mozilla/js/src/config/system-headers || die "Sed failed"
+ # Shell scripts sometimes contain DOS line endings; bug 391889
+ grep -rlZ --include="*.sh" $'\r$' . |
+ while read -r -d $'\0' file ; do
+ einfo edos2unix "${file}"
+ edos2unix "${file}"
+ done
+
# Allow user to apply any additional patches without modifing ebuild
epatch_user