summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrad Laue <brad@gentoo.org>2004-12-07 21:15:36 +0000
committerBrad Laue <brad@gentoo.org>2004-12-07 21:15:36 +0000
commit548aedab2e5e7ed2c22510c0ffa4ecc85537f274 (patch)
treeabebe5d6d3e3ba3fd2d4ea2c2c1d317f83f5fb30 /mail-client
parentppc stable as per bug #72521 (Manifest recommit) (diff)
downloadgentoo-2-548aedab2e5e7ed2c22510c0ffa4ecc85537f274.tar.gz
gentoo-2-548aedab2e5e7ed2c22510c0ffa4ecc85537f274.tar.bz2
gentoo-2-548aedab2e5e7ed2c22510c0ffa4ecc85537f274.zip
Update to 1.0
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/mozilla-thunderbird/ChangeLog7
-rw-r--r--mail-client/mozilla-thunderbird/files/digest-mozilla-thunderbird-1.03
-rw-r--r--mail-client/mozilla-thunderbird/mozilla-thunderbird-1.0.ebuild182
3 files changed, 191 insertions, 1 deletions
diff --git a/mail-client/mozilla-thunderbird/ChangeLog b/mail-client/mozilla-thunderbird/ChangeLog
index 2b11d5e8053f..f262a47c2bcc 100644
--- a/mail-client/mozilla-thunderbird/ChangeLog
+++ b/mail-client/mozilla-thunderbird/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for mail-client/mozilla-thunderbird
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/mozilla-thunderbird/ChangeLog,v 1.37 2004/11/18 14:05:28 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/mozilla-thunderbird/ChangeLog,v 1.38 2004/12/07 21:15:36 brad Exp $
+
+*mozilla-thunderbird-1.0 (07 Dec 2004)
+
+ 07 Dec 2004; Brad Laue <brad@gentoo.org> +mozilla-thunderbird-1.0.ebuild:
+ Mozilla Thunderbird 1.0. Reclaim your inbox. Based on mozconfig eclass.
*mozilla-thunderbird-0.9-r3 (18 Nov 2004)
diff --git a/mail-client/mozilla-thunderbird/files/digest-mozilla-thunderbird-1.0 b/mail-client/mozilla-thunderbird/files/digest-mozilla-thunderbird-1.0
new file mode 100644
index 000000000000..54e25e916c82
--- /dev/null
+++ b/mail-client/mozilla-thunderbird/files/digest-mozilla-thunderbird-1.0
@@ -0,0 +1,3 @@
+MD5 232ffe434fd65f5f0284a760d6e4ba2a thunderbird-1.0-source.tar.bz2 33255315
+MD5 d2e6731ce7142cc63132cb29d91d0fd3 enigmail-0.89.5.tar.gz 358830
+MD5 4aa272b46c8cbf167dcd49a6d74cf526 ipc-1.1.2.tar.gz 102663
diff --git a/mail-client/mozilla-thunderbird/mozilla-thunderbird-1.0.ebuild b/mail-client/mozilla-thunderbird/mozilla-thunderbird-1.0.ebuild
new file mode 100644
index 000000000000..896b41b71fce
--- /dev/null
+++ b/mail-client/mozilla-thunderbird/mozilla-thunderbird-1.0.ebuild
@@ -0,0 +1,182 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/mozilla-thunderbird/mozilla-thunderbird-1.0.ebuild,v 1.1 2004/12/07 21:15:36 brad Exp $
+
+IUSE="crypt"
+
+unset ALLOWED_FLAGS # stupid extra-functions.sh ... bug 49179
+inherit flag-o-matic gcc eutils nsplugins mozconfig mozilla-launcher makeedit
+
+EMVER="0.89.5"
+IPCVER="1.1.2"
+
+DESCRIPTION="Thunderbird Mail Client"
+HOMEPAGE="http://www.mozilla.org/projects/thunderbird/"
+SRC_URI="http://ftp24moz.newaol.com/pub/mozilla.org/thunderbird/releases/${PV}/source/thunderbird-${PV}-source.tar.bz2
+ crypt? ( http://downloads.mozdev.org/enigmail/src/enigmail-${EMVER}.tar.gz
+ http://downloads.mozdev.org/enigmail/src/ipc-${IPCVER}.tar.gz )"
+
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~amd64 ~ia64"
+SLOT="0"
+LICENSE="MPL-1.1 NPL-1.1"
+
+RDEPEND="crypt? ( >=app-crypt/gnupg-1.2.1 )"
+
+S=${WORKDIR}/mozilla
+
+# Needed by src_compile() and src_install().
+# Would do in pkg_setup but that loses the export attribute, they
+# become pure shell variables.
+export MOZ_THUNDERBIRD=1
+
+src_unpack() {
+ unpack ${A} || die "unpack failed"
+ cd ${S} || die "cd failed"
+
+ if [[ $(gcc-major-version) -eq 3 ]]; then
+ # ABI Patch for alpha/xpcom for gcc-3.x
+ if [[ ${ARCH} == alpha ]]; then
+ epatch ${FILESDIR}/mozilla-alpha-xpcom-subs-fix.patch
+ fi
+ fi
+
+ # patch out ft caching code since the API changed between releases of
+ # freetype; this enables freetype-2.1.8+ compat.
+ # https://bugzilla.mozilla.org/show_bug.cgi?id=234035#c65
+ epatch ${FILESDIR}/mozilla-thunderbird-0.9-4ft2.patch
+
+ # Unpack the enigmail plugin
+ if use crypt; then
+ for x in ipc enigmail; do
+ mv ${WORKDIR}/${x} ${S}/extensions || die "mv failed"
+ cd ${S}/extensions/${x} || die "cd failed"
+ makemake # from mozilla.eclass
+ done
+ fi
+}
+
+src_compile() {
+ ####################################
+ #
+ # mozconfig, CFLAGS and CXXFLAGS setup
+ #
+ ####################################
+
+ mozconfig_init
+
+ # tb-specific settings
+ mozconfig_use_enable ldap
+ mozconfig_use_enable ldap ldap-experimental
+ mozconfig_annotate '' --with-default-mozilla-five-home=/usr/lib/MozillaThunderbird
+
+ # Finalize and report settings
+ mozconfig_final
+
+ # hardened GCC uses -fstack-protector-all by default, and this breaks
+ # firefox.
+ has_hardened && append-flags -fno-stack-protector-all
+ replace-flags -fstack-protector-all -fstack-protector
+
+ ####################################
+ #
+ # Configure and build Thunderbird
+ #
+ ####################################
+
+ econf || die "econf failed"
+
+ # This removes extraneous CFLAGS from the Makefiles to reduce RAM
+ # requirements while compiling
+ edit_makefiles
+
+ emake MOZ_THUNDERBIRD=1 || die "emake failed"
+
+ # Build the enigmail plugin
+ if use crypt; then
+ einfo "Building Enigmail plugin..."
+ cd ${S}/extensions/ipc || die "cd ipc failed"
+ make || die "make ipc failed"
+
+ cd ${S}/extensions/enigmail || die "cd enigmail failed"
+ make || die "make enigmail failed"
+ fi
+}
+
+src_install() {
+ dodir /usr/lib
+ dodir /usr/lib/MozillaThunderbird
+ cp -RL --no-preserve=links ${S}/dist/bin/* ${D}/usr/lib/MozillaThunderbird
+
+ # fix permissions
+ chown -R root:root ${D}/usr/lib/MozillaThunderbird
+
+ # use mozilla-launcher which supports thunderbird as of version 1.6.
+ # version 1.7-r1 moved the script to /usr/libexec
+ dodir /usr/bin
+ dosym /usr/libexec/mozilla-launcher /usr/bin/thunderbird
+
+ # Install icon and .desktop for menu entry
+ insinto /usr/share/pixmaps
+ doins ${FILESDIR}/icon/thunderbird-icon.png
+ # Fix bug 54179: Install .desktop file into /usr/share/applications
+ # instead of /usr/share/gnome/apps/Internet (18 Jun 2004 agriffis)
+ insinto /usr/share/applications
+ doins ${FILESDIR}/icon/mozillathunderbird.desktop
+
+ # Normally thunderbird-0.7.1 must be run as root once before it can
+ # be run as a normal user. Drop in some initialized files to
+ # avoid this.
+ einfo "Extracting thunderbird-${PV} initialization files"
+ tar xjpf ${FILESDIR}/thunderbird-0.7-init.tar.bz2 \
+ -C ${D}/usr/lib/MozillaThunderbird
+}
+
+pkg_preinst() {
+ # Remove entire installed instance to solve various
+ # problems, for example see bug 27719
+ rm -rf ${ROOT}/usr/lib/MozillaThunderbird
+}
+
+pkg_postinst() {
+ export MOZILLA_FIVE_HOME="${ROOT}/usr/lib/MozillaThunderbird"
+
+ # Fix permissions on misc files
+ find ${MOZILLA_FIVE_HOME}/ -perm 0700 -exec chmod 0755 {} \; || :
+
+ # Needed to update the run time bindings for REGXPCOM
+ # (do not remove next line!)
+ env-update
+
+ # Register Components and Chrome
+ #
+ # Bug 67031: Set HOME=~root in case this is being emerged via sudo.
+ # Otherwise the following commands will create ~/.mozilla owned by root
+ # and 700 perms, which makes subsequent execution of firefox by user
+ # impossible.
+ einfo "Registering Components and Chrome..."
+ HOME=~root LD_LIBRARY_PATH=/usr/lib/MozillaThunderbird ${MOZILLA_FIVE_HOME}/regxpcom
+ HOME=~root LD_LIBRARY_PATH=/usr/lib/MozillaThunderbird ${MOZILLA_FIVE_HOME}/regchrome
+
+ # Fix permissions of component registry
+ chmod 0644 ${MOZILLA_FIVE_HOME}/components/compreg.dat
+
+ # Fix directory permissions
+ find ${MOZILLA_FIVE_HOME}/ -type d -perm 0700 -exec chmod 0755 {} \; || :
+
+ # Fix permissions on chrome files
+ find ${MOZILLA_FIVE_HOME}/chrome/ -name '*.rdf' -exec chmod 0644 {} \; || :
+
+ # This should be called in the postinst and postrm of all the
+ # mozilla, mozilla-bin, firefox, firefox-bin, thunderbird and
+ # thunderbird-bin ebuilds.
+ update_mozilla_launcher_symlinks
+
+ einfo
+ einfo "Please note that the binary name has changed from MozillaThunderbird"
+ einfo "to simply thunderbird"
+ einfo
+}
+
+pkg_postrm() {
+ update_mozilla_launcher_symlinks
+}