summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Kacian <ticho@gentoo.org>2006-10-03 15:03:31 +0000
committerAndrej Kacian <ticho@gentoo.org>2006-10-03 15:03:31 +0000
commit6d5459e11cb7c3a5b6796c9be21dffb1bff9b9eb (patch)
tree94a8bf2d6d6c54edbed5e33655ccf6a74a16ebba /mail-client
parentInitial commit, bug #97533 (diff)
downloadgentoo-2-6d5459e11cb7c3a5b6796c9be21dffb1bff9b9eb.tar.gz
gentoo-2-6d5459e11cb7c3a5b6796c9be21dffb1bff9b9eb.tar.bz2
gentoo-2-6d5459e11cb7c3a5b6796c9be21dffb1bff9b9eb.zip
Version bump.
(Portage version: 2.1.2_pre2-r2)
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/sylpheed-claws-perl/ChangeLog7
-rw-r--r--mail-client/sylpheed-claws-perl/files/digest-sylpheed-claws-perl-0.9.53
-rw-r--r--mail-client/sylpheed-claws-perl/sylpheed-claws-perl-0.9.5.ebuild51
3 files changed, 60 insertions, 1 deletions
diff --git a/mail-client/sylpheed-claws-perl/ChangeLog b/mail-client/sylpheed-claws-perl/ChangeLog
index 4743d9a09deb..a6b26574d4ec 100644
--- a/mail-client/sylpheed-claws-perl/ChangeLog
+++ b/mail-client/sylpheed-claws-perl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for mail-client/sylpheed-claws-perl
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed-claws-perl/ChangeLog,v 1.9 2006/07/06 23:17:38 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed-claws-perl/ChangeLog,v 1.10 2006/10/03 15:03:31 ticho Exp $
+
+*sylpheed-claws-perl-0.9.5 (03 Oct 2006)
+
+ 03 Oct 2006; <ticho@gentoo.org> +sylpheed-claws-perl-0.9.5.ebuild:
+ Version bump.
06 Jul 2006; Marius Mauch <genone@gentoo.org>
sylpheed-claws-perl-0.6.ebuild, sylpheed-claws-perl-0.9.ebuild,
diff --git a/mail-client/sylpheed-claws-perl/files/digest-sylpheed-claws-perl-0.9.5 b/mail-client/sylpheed-claws-perl/files/digest-sylpheed-claws-perl-0.9.5
new file mode 100644
index 000000000000..0c6e57480b5b
--- /dev/null
+++ b/mail-client/sylpheed-claws-perl/files/digest-sylpheed-claws-perl-0.9.5
@@ -0,0 +1,3 @@
+MD5 db771d49bf9bde1cce075b93f8028a19 sylpheed-claws-extra-plugins-2.5.2.tar.bz2 3991186
+RMD160 8e59b11fdcf6dbee11ca2c28d7616593d420333a sylpheed-claws-extra-plugins-2.5.2.tar.bz2 3991186
+SHA256 2ac9469dfb914ab20fd73b75388db6e3e0a305883c789e34a5c9458feb838349 sylpheed-claws-extra-plugins-2.5.2.tar.bz2 3991186
diff --git a/mail-client/sylpheed-claws-perl/sylpheed-claws-perl-0.9.5.ebuild b/mail-client/sylpheed-claws-perl/sylpheed-claws-perl-0.9.5.ebuild
new file mode 100644
index 000000000000..e2a17da5370a
--- /dev/null
+++ b/mail-client/sylpheed-claws-perl/sylpheed-claws-perl-0.9.5.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed-claws-perl/sylpheed-claws-perl-0.9.5.ebuild,v 1.1 2006/10/03 15:03:31 ticho Exp $
+
+MY_P="${P##sylpheed-claws-}"
+MY_PN="${PN##sylpheed-claws-}"
+SC_BASE="2.5.2"
+SC_BASE_NAME="sylpheed-claws-extra-plugins-${SC_BASE}"
+
+DESCRIPTION="Plugin for sylpheed-claws to use perl to write filtering rules"
+HOMEPAGE="http://claws.sylpheed.org"
+SRC_URI="mirror://sourceforge/sylpheed-claws/${SC_BASE_NAME}.tar.bz2"
+#SRC_URI="http://claws.sylpheed.org/downloads/${MY_PN}_plugin-${PV}_gtk2.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE=""
+DEPEND=">=mail-client/sylpheed-claws-${SC_BASE}
+ dev-lang/perl"
+
+S="${WORKDIR}/${SC_BASE_NAME}/${MY_PN}_plugin-${PV}"
+
+src_compile() {
+ econf || die
+ emake || die
+
+ pod2man --section=1 --release=${PV} --name=sc_perl sc_perl.pod > sc_perl.1
+
+ cd tools
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog NEWS README
+
+ doman sc_perl.1
+
+ cd tools
+ exeinto /usr/lib/sylpheed-claws/tools
+ doexe *.pl
+
+ rm -f ${D}/usr/lib*/sylpheed-claws/plugins/*.{a,la}
+}
+
+pkg_postinst() {
+ echo
+ elog "The documentation for this plugin is contained in a manpage."
+ elog "You can access it with 'man sc_perl'"
+ echo
+}